1
[BUG] : 2.1.2 - Unable to access VPN settings

  1. keribang
    Froyo Dec 7, 2015

    keribang , Dec 7, 2015 :
    I am unable to access VPN setting manually. Going to Settings>VPN will get me this screen : Screenshot_2015-12-07-11-19-58.png

    Typing anything inserts invisible characters and clicking cancel will bring me back to the Settings page.

    Happens only on 2.1.2 (didn't happen in 2.1.1). However I can still use VPN via apps like OpenVPN or Hotsheild, just not able to manually create VPN as before.

    What I have done :
    1. Wipe cache & dalvik.
    2. Return back to stock. Unroot.
    3. Reflash full 2.1.2 OOS ROM.

    Btw, this happens on both Boeffla kernel rooted & on stock kernel unrooted.

    My OP2 is A2003 version.

    Anyone face the same issue? Any workaround?

    Thanks.
     

    #1
    JacKok likes this.
  2. keribang
    Froyo Dec 7, 2015

    keribang , Dec 7, 2015 :
    Looks like I'm answering myself. Problem solved by doing a complete wipe a.k.a factory reset.

    However, that also meant that I never know what caused it in the first place. My suspect is one of the apps installed caused it.

    EDIT : The problem returns after I've restored some of my apps. It is still there even when I booted into Safe Mode that made me suspect one of the built-in apps or Google apps is causing this OOS bug. @Helen please consider this bug for a fix in the next OOS update.
     
    Last edited: Dec 8, 2015

    #2
  3. griffincash
    Froyo Dec 9, 2015


    #3
    keribang likes this.
  4. OW3N111
    Jelly Bean Dec 9, 2015

    OW3N111 , Dec 9, 2015 :
    Is it not a dark theme or something making it do tht, I can access everything on 2.1.2 in vpn.


    Also try changing your keyboard theme
     

    #4
    keribang likes this.
  5. keribang
    Froyo Dec 9, 2015

    keribang , Dec 9, 2015 :
    It worked!!! Thank you @griffincash.

    The culprit is indeed the FP scanner. Here's what I've tried:

    - disable FP, VPN settings immediate available & still is after reboot.

    - disable FP, get back VPN settings, re-enable FP, still has VPN settings. Reboot (with FP re-enabled), lost the VPN settings again.

    So, I'll still tick this off as a bug @Helen with a workaround.

    No sir, didn't have dark theme on. Thanks for the suggestions. Resolved above, FP scanner is the culprit.
     

    #5
    OW3N111 likes this.
  6. JacKok
    Cupcake Apr 14, 2016

    JacKok , Apr 14, 2016 :
    Same problems here, for a long time now
    Also random software crashes only when VPN is connect, Phone freezes, and black screen :(
     

    #6