4
BUG - OnePlus 5: GPS Location problem

  1. MAguayo
    Donut Feb 12, 2019

    MAguayo , Feb 12, 2019 :
    Hi,
    My OnePlus 5 has problems with GPS (location) since I updated to 9.0.3.
    I tried to do a wipe cache, reinstall apps like Waze... but I always have the same problem.
    Is it anything known?
     

    #1
  2. sicoviello
    Cupcake Feb 13, 2019

    sicoviello , Feb 13, 2019 :
    Same problem with Oneplus 5T. I don't now if is Oxygen because I bought it two weeks ago and when I turned on at the first time it asks to update to 9.0.3. So for me never worked. Before 9.0.3 was working normally??
     

    #2
  3. borft
    Jelly Bean Feb 13, 2019

    borft , Feb 13, 2019 :
    Kan you guys be a little more specific? what is not working? are you not getting fix? is it reporting an incorrect location? what have you tried?
     

    #3
  4. sicoviello
    Cupcake Feb 13, 2019

    sicoviello , Feb 13, 2019 :
    In my case Waze shows the message "Waze is connecting to GPS" and after "No GPS signal". Same thing with Google Maps. When I realized this, I tried to use another apps to test the GPS, like the GPS Test. No success, no GPS signal. I did one video comparing a tablet Lenovo, mobile LG and 1+ 5t. Check it http://bit.ly/2DAs7j3
     

    #4
    MAguayo likes this.
  5. MAguayo
    Donut Feb 14, 2019

    MAguayo , Feb 14, 2019 :
    Hi,

    Sicovello. I have a OnePlus 5, 1,5 years ago. I had several problems with some versions like wifi connection, notifications, etc, but with GPS only in this version i have had problems. I updated 2 weeks ago and after that, when GPS failed, I downgraded to previous version (Android 8.1.0, OxygenOS 5.1.7) and GPS is fine now.

    Borft, I have the same problem that Sicoviello told you. Waze, Google Maps, MiFit, etc... Apps, which use location, don't run fine.
     

    #5
  6. Anderson_Dias
    Cupcake Feb 26, 2019

    Anderson_Dias , Feb 26, 2019 :
    I have the same problem on ONEPLUS5 when I upgraded to 9.0.3. My location on Waze and Google Maps appears far away from my real location. Do you have a solution for that? I am a few weeks without being able to use the localization applications
     

    #6
  7. lucianf
    Cupcake May 14, 2019

    lucianf , May 14, 2019 :
    Hey man, I am experiencing the same problems as other have raised so far but I have a bit more detail.

    The issues started as for others, after the update to 9.0.3 and since then there have been several other security updates but they have not touched the GPS according to their description.

    After a brief talk to OnePlus support they have directed me to reset the network settings (Settings->System->Reset Options -> Reset Wi-Fi, mobile & Bluetooth). This has deleted all my saved wifi and connected bluetooth devices. For a small amount of time the GPS worked after that for a few days, actually to be more precise it worked for about 4 or 5 trips with Waze (i don't keep the gps on all the time). After that it got back to not working.

    Then I discovered from reading stuff online about this problem that if I switch off the phone and then turn it back on holding the volume down and then wiping the cache (i found that this works best if the GPS is off before you turn the phone off and wipe the cache). After this procedure, the GPS will work with waze for a maximum of three trips and then the process will have to be repeated.

    Now even after the cache wipe, if I enter that factory settings thing with *#808# and try the GPS test, I will always get a Failed after 20 seconds with a cold start. Not sure what that means but I feel that it shouldn't happen.

    To make things weirder, I installed the following app:
    https://play.google.com/store/apps/details?id=com.eclipsim.gpsstatus2
    This app appears to find a GPS lock because it will show me a position even if Waze or Google Maps cannot get a lock.

    So if this answer is detailed enough do you have a solution now?
     

    #7
    Ashenmx and MAguayo like this.
  8. G_Adrian_Byron-Parker_Fi
    Cupcake May 27, 2019

    G_Adrian_Byron-Parker_Fi , May 27, 2019 :
    Hi,
    I have the same issue after Pie update. some days it works some days it dosent?

    If I usre a GPS monitor program the phone gives me lall gps data with no issue.

    Strangly, if i cannot get a location with waze or google maps and i run the gps program, both waze and google can then find location...

    Definatly a software bug and not hardware
     

    #8
    MAguayo likes this.
  9. Ashenmx
    Froyo May 27, 2019

    Ashenmx , May 27, 2019 :
    I do the same procedure with gps test app. Surely it's a software bug. But OnePlus is too busy to care
     

    #9
    arananegra likes this.
  10. arananegra
    Donut Aug 19, 2019

    arananegra , Aug 19, 2019 :
    I have the same problem as all of you guys have described. It is so sad having a phone which it's working fine but gps sucks.
     

    #10