5
Built in app to choose network type for any sim found

  1. saikiran4ever
    Jelly Bean Jan 4, 2017

    saikiran4ever , Jan 4, 2017 :
    This solution is for those who want to be able to choose 2g/3g for non-data sim.

    Important notes:

    #1. We can't use this app to choose LTE for both sims. It doesn't work. Only the data sim will receive LTE signal. Other sim will have no network if you do so.
    #2. If you are a jio user in India, and if you want to use the 2nd sim for data and still be able to have LTE/volte for jio, it's impossible.

    Hi All,
    In the latest nougat stable os, I found an app that allows us to choose the network type for both sims. (Maybe, this app was also there in the previous versions)
    In earlier versions, we had no straight forward option to choose network type for 2nd sim.

    The app is : com.qualcomm.qti.networksettings. You can find this under Apps after enabling Settings > Apps > 3 Dots > Show system. See the screen shot 1 attached.

    But, we can't directly launch it until we create a Shortcut for this app.
    - Download App Shortcut Maker from store.
    - Go to All Activities
    - Find "com.qualcomm.qti.networksettings"
    - Expand it and click on "com.qualcomm.qti.networksettings.Mobile NetworkSettings".
    - In the next screen, click on rename and give it a shorter nane and click on the Shortcut icon on the right bottom.
    - Done. Shortcut is on the desktop.
    - Now you can uninstall the App Shortcut Maker.

    Use this to choose network type for both sims. Find the attached screen shot 2.
     

    Attached Files:

    Last edited: Feb 26, 2017

    #1
  2. Gaurav910
    Gingerbread Feb 26, 2017

    Gaurav910 , Feb 26, 2017 :
    I am still not able to get signal for jio sim when data for Airtel is active even after selecting gsm/wcdma for Airtel & LTE for Jio SIM .
    Also how to hide deactivated SIM icon is showing in status bar.
     

    #2
  3. saikiran4ever
    Jelly Bean Feb 26, 2017

    saikiran4ever , Feb 26, 2017 :
    It doesn't work that way. If you have enabled data on Airtel, even if you select GSM/WCDMA for it, jio will lose signal.
    The reason, as far as i know, is that there is a single LTE/3G/2G modem on your phone which is blocked by Airtel (in 3g mode since you selected 3g/2g) and you have selected it as the data sim. So, since jio supports only 4g signal, and 4g modern is being blocked by Airtel, it doesn't receive any signal.
     

    #3
    Praty_28 likes this.
  4. Gaurav910
    Gingerbread Feb 26, 2017

    Gaurav910 , Feb 26, 2017 :
    Then how to get signal on Jio SIM while keeping data on Airtel .
    Also how to hide inactive SIM icon from status bar.
     

    #4
  5. saikiran4ever
    Jelly Bean Feb 26, 2017

    Last edited: Feb 26, 2017

    #5
    Praty_28 likes this.
  6. Gaurav910
    Gingerbread Feb 26, 2017


    #6
  7. saikiran4ever
    Jelly Bean Feb 26, 2017

    saikiran4ever , Feb 26, 2017 :
    May i know which issue should be fixed?
    #1 can't be fixed. Oneplus can fix #2.
     

    #7
  8. G_Jerome_V.Dika_Langel_d
    Eclair Feb 26, 2017

    G_Jerome_V.Dika_Langel_d , Feb 26, 2017 :
    You can't because jio works only through data. Even the voice call and SMS pass through data, not like traditional call and SMS which doesn't need data. That's why all calls and SMS are free in jio. So if you switch off data for jio you will not get signal for it.
     

    #8
  9. Gaurav910
    Gingerbread Feb 26, 2017

    Gaurav910 , Feb 26, 2017 :
    VOLTE enable device does not need to be connected to data all the time . The only issue is that out of two, only one SIM can be 4G while other has to be on 2G/3G . Since Jio need 4G so other sim has to be on gsm/utms network.
    But OP3 is not showing signal even if other sim kept on 2G/3G .
     

    #9
  10. Gaurav910
    Gingerbread Feb 26, 2017

    Gaurav910 , Feb 26, 2017 :
    Both issue .
     

    #10
    Shantanu111 likes this.
  11. saikiran4ever
    Jelly Bean Feb 26, 2017

    saikiran4ever , Feb 26, 2017 :
    My answer :
    If you have enabled data on Airtel, even if you select GSM/WCDMA for it, jio will lose signal.
    The reason, as far as i know, is that there is a single LTE/3G/2G modem on your phone which is blocked by Airtel (in 3g mode since you selected 3g/2g) and you have selected it as the data sim. So, since jio supports only 4g signal, and 4g modern is blocked by Airtel, it doesn't receive any signal
     
    Last edited: May 15, 2017

    #11
    Shantanu111 likes this.
  12. G_Jerome_V.Dika_Langel_d
    Eclair Feb 26, 2017

    G_Jerome_V.Dika_Langel_d , Feb 26, 2017 :
    The device need not. But jio needs data (4g data) to work as far as I know. So since both sim could not use data at the same time, if you choose to use jio data airtel will still have signal as it does not need data to be on. But if you choose to use airtel data (whether 2g/3g/4g) jio will not work because jio does not work without data on.
     

    #12
  13. Shantanu111
    Cupcake May 15, 2017

    Shantanu111 , May 15, 2017 :
    Oneplus should give options for each sim different network type. . i.e : I need Sim 1 LTE & SIM2 2G network, but it show both sim always LTE
     

    #13
  14. saikiran4ever
    Jelly Bean May 15, 2017


    #14
  15. saikiran4ever
    Jelly Bean Jun 1, 2017

    saikiran4ever , Jun 1, 2017 :
    An update on this guys:
    Unfortunately, in the latest open beta (17/8) they have replaced com.qualcomm.qti.networksettings.Mobile NetworkSettings with the default network settings app that doesn't let you choose network type for each sim separately. So, the solution which i gave in this thread doesn't work anymore.

    However, fortunately, we have another way of selecting network type for each sim. This solution was already posted by me long ago @ https://forums.oneplus.net/threads/...-with-dual-sim-inserted.455033/#post-15383298

    Copy of the same here:
    1. Download Shortcut Master (lite) from play store.
    2. Go to Menu > Search
    3. Type Engineering and search (remove any trailing spaces)
    4. Mark the 1st result (com.android.engineergingmode.engineergingmode) as your favorite or launch it.
    5. Go to Network Set > Sim card Select > Choose SIM1 or SIM2
    6. Go to RAT mode > Select <WHATEVER_YOU_WANT> for that SIM.
     

    #15
  16. F_Michal_Doblej_dBkm
    Ice Cream Sandwich Jun 1, 2017

    F_Michal_Doblej_dBkm , Jun 1, 2017 :
    LMFO there is nothing to fix op3/3t was newer ment to be working with 2 sims at the same time it is a dual sim dual stanby phone that says it all
     

    #16
    Heisenberg_009 likes this.
  17. kaz04
    Eclair Nov 27, 2017


    #17