8
Call ends Automatically within 3 Minutes

  1. X1563266222438
    Cupcake Mar 5, 2020

    X1563266222438 , Mar 5, 2020 :
    When I Get a call it always ends within 3 minutes time. I was tried more than 20 calls. when it's near to 3 minutes, I cannot hear other parties noise. then after the call automatically ends.
     

    #1
  2. vuongj3
    Cupcake Mar 13, 2020

    vuongj3 , Mar 13, 2020 :
    I'm having the same problem. Even when it's not real contact, like Voicemail, around the 3 minute mark the other side goes silent and then cuts off.
     

    #2
  3. apnisamudheen@gm
    Cupcake Mar 13, 2020


    #3
    X1563266222438 and vuongj3 like this.
  4. olivor
    Cupcake Aug 11, 2020


    #4
    D1585593592633 likes this.
  5. ZenBalancer
    Cupcake Aug 11, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 11, 2020 :
    The same problem as described started after applying OS update to 10.0.7.GM21BA on 10 August 2020.

    After around 3 minutes any regular SIM based phone call the other side's voice cuts off without the connection being dropped. The other side called back to confirm that they didn't go silent, so it's the connection. This happens on any recent call since.

    Since I didn't have this problem before the update, it seems like it's the update's fault.

    Help?!!
     
    Last edited: Aug 11, 2020

    #5
    olivor likes this.
  6. ZenBalancer
    Cupcake Aug 11, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 11, 2020 :
    I just found another user reporting this morning the same issue on the recent update thread.

    The user is using the India & Global version. So the issue doesn't seem to be limited to the EU only version which I'm dependant on. I'm using it in the Netherlands btw.

    Thread tittle: "OxygenOS 10.0.7 [EU] and 10.3.4 [India & Global] for the OnePlus 7 Pro and OnePlus 7"

    Permalink (you have to click in the browser and not the community app to go to the message on page 51): https://forums.oneplus.com/threads/...o-and-oneplus-7.1269796/page-51#post-21960086

    Message copy:
    "Hi I have just installed the new update 10.3.4 and I have a big bug : when I make or receive a call I cannot hear the people whom I am discussing. The call is not cut but microphone and loudspeakers seem out of order.
    Let me know how I can solve this problem please!!!
    Thank you very much to pay kindly attention to my sensitive request.
    Best regards, David from France"

    User O1597136325000 profile:
    https://forums.oneplus.com/members/o1597136325000.3270333/
     
    Last edited: Aug 11, 2020

    #6
  7. ZenBalancer
    Cupcake Aug 12, 2020

    ZenBalancer , Aug 12, 2020 :
    Olivor let me know that the following steps fixed his issue. But it didn't fix the issue on my phone...

    I copied the same steps from T-Mobile.

    Wipe cache partition

    Turn off your device.

    Press and hold the Volume down and Power button at the same time.

    When the OnePlus logo appears, release the Power button, but continue holding the Volume down button.

    At the Password screen, enter the Password or PIN number that you use to unlock your device. When done, tap Ok.

    Tap English.

    Tap Wipe data and cache.

    Tap Wipe cache.

    Tap Yes to continue.

    Tap Reboot to restart the phone.


    Hopefully it works for others too. But I still need a fix. Or additional steps after wiping the cache.

    Update: Olivor said that he seems to have spoken too soon. The problem also still affects his OnePlus after all. Maybe the above steps never worked to fix the issue or worked temporarily for him.
     
    Last edited: Aug 12, 2020

    #7
  8. tarun17
    Gingerbread Aug 12, 2020

    tarun17 , via OnePlus 7 Pro , Aug 12, 2020 :
    Tried. No success.
     

    #8
    ZenBalancer likes this.
  9. O1597136325000
    Cupcake Aug 12, 2020

    O1597136325000 , Aug 12, 2020 :
    Hi Everybody,

    I have tested the steps too from Olivor and i didn't fix the bug too.

    Please help !!!

    David
     

    #9
    ZenBalancer likes this.
  10. ZenBalancer
    Cupcake Aug 12, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 12, 2020 :
    Olivor said that he seems to have spoken too soon. The problem also still affects his OnePlus after all. Maybe the above steps never worked to fix the issue or worked temporarily for him.

    So no one active in this thread who has the problem knows how to fix it. Which includes of course me too.

    Olivor had also sent an email to customer support. Me too. Here I read in the Netherlands's support section on their site that they reply to email within 48 hours, but that there is also chat and phone support.

    But the link to this thread I had put in my email was removed in the confirmation email. I think I should start chat since I can't call for long because of this issue.
     

    #10
  11. ZenBalancer
    Cupcake Aug 12, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 12, 2020 :
    My email to technical support has been answered this morning, and it seems it was escalated from NL to Denmark.

    In it a workaround is suggested to remedy the situation for now, by reverting back to the older version until a fix is found and applied by the OnePlus team in China. I have posed additional questions for which I'm waiting for clarification to understand and manage general expectations about this issue.

    I don't know for instance which file it exactly is. EU or India and global and which version exactly. Nor whether any data will be lost. And some other questions.

    Copy of the reply:

    "Hi (name omitted),

    Thank you for contacting us and welcome to OnePlus!

    This is surely unfortunate.

    We cannot do anything about the current update in technical support - it's being troubleshooted in China. Hopefully there's a new update ready soon.

    Until then you can downgrade your phone to the last update:
    https://oneplussupport.s3.amazonaws.com/OP7/guacamoleb_14_E.25_200327.rar

    Read the guide at the end of the page on how to apply it:
    https://www.oneplus.com/nl/support/softwareupgrade/details?code=PM1574156267635

    Best regard

    Jimmi
    OnePlus Danmark
    #NeverSettle"
     

    #11
  12. D1582168481768
    Cupcake Aug 12, 2020

    D1582168481768 , Aug 12, 2020 :
    exactly the same issue after I upgraded the OS to latest version a few days ago. Bought my phone from North America region few months ago.

    issue:
    • can not hear the other party after a few minutes, even though the other part did not disconnected, nor went on silent mode.
    • call gets disconnected after a few minutes.

    @OnePlus Team: kindly suggest the solution as soon as possible, this is causing a lot of issue.

    Thanks.
    Abhi
     

    #12
    ZenBalancer likes this.
  13. ZenBalancer
    Cupcake Aug 12, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 12, 2020 :
    I don't think they read this thread. Please consider reaching their support through direct contact. See their support page for your region.

    Also they have suggested to me to revert back for now. See my earlier post for the reason why and how. I asked for the India & Global file to do it in case not available via that link.

    If you find out anything please let us know. Good luck.
     

    #13
    D1582168481768 likes this.
  14. olivor
    Cupcake Aug 13, 2020

    olivor , via OnePlus 7T Pro , Aug 13, 2020 :
    Hi ZenMaster, what ROM are you on? I think I am using Global rom? Will the link you posted work for my version as well?


    1597275138943.jpg


    Can you help?


    Yes, I spoke too soon.

    After wiping cache, I tried making a phone call ans lasted over 3 minutes.

    After some time, I tried making another phone call them the problem returned.

    Might just revert to older version to avoid this issue.
     

    #14
    ZenBalancer likes this.
  15. ZenBalancer
    Cupcake Aug 13, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 13, 2020 :
    😅 my pseudonym aside...

    I'm on EU. The support email is from Denmark. I asked for the India & Global version too. Maybe your support email will be supplied with the same workaround and correct ROM. Since the 7T Pro and 7 Pro don't use the same ROM.

    But I still have questions about the situation before I revert back.
     
    Last edited: Aug 13, 2020

    #15
  16. ZenBalancer
    Cupcake Aug 13, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 13, 2020 :
    So I got more clarification about the workaround file I was linked to and the situation regarding this confirmed bug by email from technical support Denmark.

    The thing to take into account that this file is meant for EU version 7 Pro and maybe 7, not other versions I guess.

    And I checked the files inside, it says 10.0.5.GM57BA, not 21. Not sure what that is about.

    Here is the reply anyway:

    "Hi (name omitted),

    This version is:
    10.0.5.GM21BA

    It's the only downgrade file we have available at the moment.

    1. Downgrading requires a brand new install of the OS. So a backup is needed before doing so.

    2. I have reported the bug to China. All devolopment is kept behind closed doors. Us in technical support hve no access or knowledge to the priority settings of bugs, improvements or tasks of the development team.

    3. When a newer update is available you can download it OTA. So wait downloading it automatically, before you can see a newer version - which hopefully have a fix for this issue.

    Best regard

    Jimmi
    OnePlus Danmark
    #NeverSettle"
     

    #16
  17. ZenBalancer
    Cupcake Aug 13, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 13, 2020 :
    I just found 2 more users on the update thread that have this issue. A moderator suggested the following steps:

    Moderator profile: https://forums.oneplus.com/members/cervantes.76118/

    Message permalink (click in browser to go to the message not the community app) : https://forums.oneplus.com/threads/...o-and-oneplus-7.1269796/page-54#post-21973335

    Message copy:
    "Hi
    try resetting networks
    settings, system, reset options

    the reports are not to ask for help for a bug
    Best regards, Cervantes, Forum Moderator"


    Update 1:

    I copied the following instructions from a different post, better explaining the steps suggested by this moderator:

    "they recomended wipe the cache in the recovery menu, and also reset the network settings in:

    Settings->System->Reset Options-> Reset Wi-Fi, mobile & Bluetooth"

    Those steps are meant to help with "Caller hears echo on calls" as well which is where it was posted: (click in browser or go to post #4) https://forums.oneplus.com/threads/caller-hears-echo-on-calls.790010/#post-20998783

    Update 2:

    I tried the above steps in that order and it didn't fix the issue for me.
     
    Last edited: Aug 13, 2020

    #17
  18. ZenBalancer
    Cupcake Aug 13, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 13, 2020 :
    The workaround to revert back means that the user has to start over after backing up and restoring whatever possible, and redo everything else manually again just like any phone migration. Which means quite some lost data and a lot of manual work and things will not be the same.
     

    #18
  19. ZenBalancer
    Cupcake Aug 13, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 13, 2020 :
    One of the additional users reporting the issue:

    Username: Z1597257986411

    User profile:
    https://forums.oneplus.com/members/z1597257986411.3279618/


    Message 1 permalink (click in browser):
    https://forums.oneplus.com/threads/...o-and-oneplus-7.1269796/page-54#post-21972891

    Message 1 copy:
    "Hi team , anyone can help me. My calls getting cut every after 2.5 minutes after updating the latest software update."


    Message 2 Permalink (click in browser):
    https://forums.oneplus.com/threads/...o-and-oneplus-7.1269796/page-55#post-21973363

    Message 2 copy:
    "Hi, anyone faces call muting after 2 to 3 minutes?"
     
    Last edited: Aug 13, 2020

    #19
  20. Swejuggalo
    Lollipop Aug 13, 2020

    Swejuggalo , Aug 13, 2020 :
    Any one with this bug tried a factory reset? And tried to replicate it before doing any type of recovery of data.
    That should rule out all kinds fixes other than a new update or rollback.

    Both 7 and 7t series has rollback files in first open beta thread. They can be used for rollback too.
    7 series falls back to Pie/9 with that method. If you don't get an OTA to 10.0.3 you may need to upgrade manually. Directly flashing 10.0.6 or 10.3.3 may not work.
    Rollbacks cn be used just the same way as normal manual upgrades. But with a wipe. Keep in mind that rollbacks on 7 series are International. If on EU you need to manually install a EU build afterwards.

    7 series
    https://forums.oneplus.com/threads/...-for-the-oneplus-7-and-oneplus-7-pro.1099154/

    7t series
    https://forums.oneplus.com/threads/...or-the-oneplus-7t-and-oneplus-7t-pro.1199654/

    Serveral info sources like XDA and Telegram channels offer direct links to specific updates. I can't directly link to the Telegram channels that links all the files since I got a warning for trying to help with giving the best up to date source of info for GCam once (but if you know how to use it it should not be hard to find)... So I'll post XDA. 7 Pro is not well maintained though.

    https://forum.xda-developers.com/oneplus-7/how-to/oneplus-7-repo-oxygen-os-builds-t3937152
    https://forum.xda-developers.com/oneplus-7-pro/how-to/oneplus-7-pro-global-repo-oxygen-os-t3930585

    I happen to have the 7 links as one of my saved notes so I'll post that.... I'm a bit uncertain if it's 10.0.3 or 10.0.2 you need on a EU device though.

    7 Pie International

    10.0.3

    https://otafsg1.h2os.com/patch/amaz....O.23_OTA_023_all_1912040005_24b70d4383fc.zip

    10.3.3

    https://otafsg1.h2os.com/patch/amaz....P.27_OTA_027_all_2005192126_848a3a15b592.zip

    7 Pie EU

    10.0.3

    https://otafsg1.h2os.com/patch/amaz...gen_14.E.23_OTA_023_all_1912061919_6b45e1.zip


    10.0.6

    https://otafsg1.h2os.com/patch/amaz...ygen_14.E.26_OTA_026_all_2005192136_1301c.zip
     

    #20