8
Call ends Automatically within 3 Minutes

  1. aDamianos
    Cupcake Aug 13, 2020

    aDamianos , via OnePlus 7 , Aug 13, 2020 :
    I had the same problem, I tried clear cache for the phone though I always clear cache after an update. But that didn't help. Cleared the phone app cache and change the default dialer still didn't help! and I tried to reset the network settings too!

    But, I did restart my phone again into recovery and cleared cache for the fourth time, but this time I entered safe mode (by pressing volume down while booting) and tried a call and it passed the 4 mins without any problem then I hanged up (I only called my operator's IVR so I can't confirm if my voice going through) , after restarting the phone into the normal mode tried the call again and it worked!

    I still need to confirm again tomorrow with a proper phone call!

    So what Is suggest that you try the following:
    Restart into recovery
    Clear cache
    Restart bootloader
    Restart into safe mode and try to do a phone call.
    Restart again into a normal mode and see if it works this time.

    update 1: the problem occurred again, I'll keep testing!

    Update 2: after extensive testing, I solved the problem by uninstalling my call recording app "Cube ACR", I managed to do to calls passing 6 mins without any issue.
     
    Last edited: Aug 14, 2020

    #21
    ZenBalancer likes this.
  2. aDamianos
    Cupcake Aug 14, 2020

    aDamianos , via OnePlus 7 , Aug 14, 2020 :
    Check my solution guys, it might help you!
     

    #22
    ZenBalancer likes this.
  3. ZenBalancer
    Cupcake Aug 14, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 14, 2020 :
    Awesome! It works for me too. Just uninstalling Cube ACR did the trick. Bummer though, because it's the only decent and working call recorder on this phone I could find prior to the incompatibility after the recent OxygenOS update.

    Could you PM me if you found a different one that works? That would be great!

    For everyone, this is the app that causes the issue in our case at least: https://play.google.com/store/apps/details?id=com.catalinagroup.callrecorder
     
    Last edited: Aug 14, 2020

    #23
  4. rinkimekari
    Gingerbread Aug 14, 2020


    #24
  5. aDamianos
    Cupcake Aug 15, 2020

    aDamianos , via OnePlus 7 , Aug 15, 2020 :
    Glad that helped with your problem!

    Call recording is not an essential app for me, so I don't really care if I don't have one, I don't even know why I installed it at the first place 😅, if you really need 1, I suggest that you wait for a newer version of the app to be released.

    Good luck!
     

    #25
    ZenBalancer likes this.
  6. K1583620983114
    Cupcake Aug 17, 2020


    #26
    ZenBalancer likes this.
  7. l00pback
    Cupcake Aug 18, 2020


    #27
  8. K1583620983114
    Cupcake Aug 19, 2020

    K1583620983114 , Aug 19, 2020 :
    Hi Y'all,

    Cube ACR team responded : Please disable ‘force in-communication mode’ in the app menu - recording - phone recording (under audio source selection).

    This solved this issue for me!
     

    #28
  9. ZenBalancer
    Cupcake Aug 19, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 19, 2020 :


    K1583620983114

    Hi Y'all,

    Cube ACR team responded : Please disable ‘force in-communication mode’ in the app menu - recording - phone recording (under audio source selection).

    This solved this issue for me!​


    I received the same advice, but "force in-communication mode" enabled or disabled, it doesn't fix the issue for me.

    On the other hand disabling recording works just as well instead of resorting to uninstalling it for good.
     

    #29
  10. ZenBalancer
    Cupcake Aug 19, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 19, 2020 :


    l00pback

    Hej,
    I solved uninstalling and reinstalling the Cube ACR.​


    Reinstalling cube acr didn't fix the issue for me.

    It's odd how different each one's situation is with the same OxygenOS version and cube acr app, but nice that it works for you.
     

    #30
  11. Swejuggalo , via OnePlus 8 Pro Ultramarine Blue , Aug 19, 2020 :
    Maybe some have Google backup on and some have it off? Parts of app data can automatically be restored after the reinstall if Google backup is on.
     

    #31
    ZenBalancer likes this.
  12. ZenBalancer
    Cupcake Aug 20, 2020

    ZenBalancer , via OnePlus 7 Pro , Aug 20, 2020 :
    So I disabled 'force-in-communication mode' in Cube ACR just to be sure and it worked to fix the issue.

    So the steps in my case was to enable then disable the setting. Despite that it was disabled to begin with.

    I don't know why these steps are necessary for the issue to be fixed on my phone.
     

    #32
  13. T1595511746279
    Cupcake Sep 29, 2020


    #33
  14. benley73
    Eclair Oct 3, 2020

    benley73 , Oct 3, 2020 :
    Got same problem since July update 10.0.12. 3mins then goes silent then person hangs up because they think you muted them.
    Also noticed my 4G has gone down slower than hsdp+ too
    I was told....
    For us to understand, it would be brilliant if you could give just a few more details on:
    1. IMEI number of the device?
    2. Build number of the device? Go to settings >> About hone >> Capture the screenshot of the page then share with us
    3. Are you using any thord party calling app? If yes please uninstall and use the native calling application.

    Also, please perform the below troubleshooting steps and advise us the outcome:
    App clear cache:
    Go to Settings >> Apps and notification >> Select the Call application >> Storage >> CLEAR CACHE / CLEAR STORAGE.

    Wipe cache through recovery menu:
    - Power Off the device
    - Long Press Volume down + Power button for 10 to 20 seconds
    - Choose the language as English
    - Select Wipe data and Cache
    - Select Wipe Cache
    - Select Yes
    - Select Reboot.

    I am sure the given information will help to resolve the issue, feel free to contact us for further assistance.

    Regards,
    Chris Murray
    OnePlus Customer Support.
    Non have helped fix the problem either.
    I have tried sim in older one plus it works fine, along with other devices,
    My biggest problem is ringing Dr's when you are 6th in que and only 3 mins means you never get to speak to Dr or to reorder medication making this phone totally useless at the moment and pretty dangerous since the phone function does not actually work properly which is critical
     

    #34
    blank98 likes this.
  15. Artemus.
    Nougat Oct 3, 2020

    Artemus. , Oct 3, 2020 :
    The solution has been posted already. Get rid of Cube ACR.
     

    #35