0
Call is enabled on speaker mode by default after update via OnePlus 7 Pro T-Mobile

  1. Chitresh_lN , via OnePlus 7 Pro T-Mobile , May 6, 2021 :
    My device was updated last week. I have been facing issues with the call, the call should be enabled on earpiece but it's getting enabled on loudspeaker which is really annoying. I don't think I would be buying another OnePlus device considering the updates and pricing which almost resembles with Samsung/Apple.
     

    #1
  2. danieldasilva
    Donut May 6, 2021

    danieldasilva , May 6, 2021 :
    This is an issue affecting many (not all) 7 Pro users that have upgraded to Oxygen OS 11. There is a workaround for this that is working for many users, but OP has so far not acknowledged the issue.

    Take a look at the workaround I have posted here https://forums.oneplus.com/threads/7-pro-call-audio-coming-out-speaker.1424882/#post-23138131

    Hopefully it works for you. Good luck.
     
    Last edited: May 6, 2021

    #2
    TheMystic likes this.
  3. TheMystic
    Lollipop May 6, 2021

    TheMystic , May 6, 2021 :
    Will the speaker work (when required) after enabling that setting?
     

    #3
  4. danieldasilva
    Donut May 6, 2021

    danieldasilva , May 6, 2021 :
    Yes. At least is has worked for me. The phone has been working normally with that setting on. Some people report that you can turn it on and then off and the workaround still works. I, however, have kept it on.
     

    #4
    TheMystic likes this.