0
Camera not working after OS 11 update via OnePlus Nord

  1. Benoy_Abraham1711 , via OnePlus Nord , Mar 3, 2021 :
    I had been using Lens cap app when my phone was on OS 10 but after OS 11 update lens cap isnt supported. Despite uninstalling lens cap app , I'm unable use camera on other app apart from the default camera app. Any solution?.
     

    #1
  2. Liehjan
    Marshmallow Mar 3, 2021

    Liehjan , Mar 3, 2021 :
    Could be that the apps are lacking A11 support... Check with app developer.
     

    #2
    Tobikage, Auristic and Bobbie63 like this.
  3. Bobbie63
    Marshmallow Mar 3, 2021

    Bobbie63 , Mar 3, 2021 :
    Screenshot_20210303-114905.jpg
    This kinda says it all I think
     

    #3

  4. #4
  5. Liehjan
    Marshmallow Mar 3, 2021

    Liehjan , Mar 3, 2021 :
    Have you given the apps permission to camera?
     

    #5
    Tobikage likes this.

  6. #6
  7. Liehjan
    Marshmallow Mar 3, 2021

    Liehjan , Mar 3, 2021 :
    What happens if you try to launch camera, do you get a error?
     

    #7
    Tobikage likes this.

  8. #8
  9. Liehjan
    Marshmallow Mar 3, 2021

    Liehjan , Mar 3, 2021 :
    I don't know how to fix that... Maybe try a factory reset or discuss your issue in the official thread. You may find a solution there.
     

    #9
    Tobikage likes this.
  10. Bobbie63
    Marshmallow Mar 3, 2021

    Bobbie63 , Mar 3, 2021 :
    Sorry I misread your first post, have you tried a qr scanner?
     

    #10
    Tobikage likes this.
  11. Benoy_Abraham1711 , via OnePlus Nord , Mar 3, 2021 :
    Any possible way to roll back to previous version.
     

    #11

  12. #12
    Bobbie63 likes this.
  13. Bobbie63
    Marshmallow Mar 3, 2021

    Bobbie63 , Mar 3, 2021 :
    Rolling back would mean wiping all your data, so why not perform a factory reset first and see if that works?
     

    #13
    Tobikage likes this.
  14. Bobbie63
    Marshmallow Mar 3, 2021

    Bobbie63 , Mar 3, 2021 :
    Weird you’re the first one I’ve seen having this issue tbh, have you tried clearing cache of the camera app?
     

    #14
    Auristic and Tobikage like this.
  15. Tobikage
    Nougat Mar 3, 2021

    Tobikage , Mar 3, 2021 :
    Have you manually updated the camera app ?
     

    #15
    Auristic and Bobbie63 like this.
  16. Bobbie63
    Marshmallow Mar 3, 2021

    Bobbie63 , Mar 3, 2021 :
    Another thing I just thought about (I don't know if it's even possible) could it be that yiu have set Gcam as default? I could be that if you did and Gcam isn't supported by A11 that that could be the culprit.

    Can't tell if all this is possible though as I'm not really a camera user.
     

    #16
  17. Benoy_Abraham1711 , via OnePlus Nord , Mar 3, 2021 :
    What about other apps like facebook, whatsapp, gpay etc
     

    #17
  18. Bobbie63
    Marshmallow Mar 3, 2021

    Bobbie63 , Mar 3, 2021 :
    If Gcam is set as default I guess these apps would try to use Gcam. Should Gcam not be supported under A11 it wouldn't open in other apps either was my thought. You could check what is set as default camera and if it's Gcam, change it to Oneplus camera and check if it works.
     

    #18
  19. Benoy_Abraham1711 , via OnePlus Nord , Mar 3, 2021 :
    Still no improvement
     

    #19
  20. Bobbie63
    Marshmallow Mar 3, 2021

    Bobbie63 , Mar 3, 2021 :
    I’m sorry, I kinda ran out if ideas besides reporting a bug in the feedback section

    https://forums.oneplus.com/feedback/

    the only option I can give is to try a factory reset as earlier mentioned, as I didn’t see anyone else having this issue yet.
     

    #20