0
Cannot connect to any VPNs.

  1. bowlesg
    Eclair Mar 24, 2016

    bowlesg , Mar 24, 2016 :
    Hi there,
    I was wondering if you could help.
    Before I begin my phone is rooted and is on Oxygen OS v2.2.1 (I flashed it a few days ago)

    Yesterday I installed the OpenVPN client for android, I had already been using CyberGhost with no problems and the OpenVPN app strangely wouldn't work. So I installed the 'OpenVPN for Android' app (another OpenVPN client) and that didn't work either however it gave me an error "VPN API permission dialog cancelled". I googled it and found that It is a fairly uncommon problem that mostly happens when ROMs dont have the VPNDialogs.apk installed in /system/priv-app. I looked and I found that in Oxygen OS it is installed. I then proceeded to install a Xposed module called "VPNDialog" but this did nothing. After reinstalling CyberGhost (which was working fine before) it is now not working and just glitches between the greeting screen and the "fetching server" screen.

    Edit: Just to add, the Screen that asks you if you trust the vpn doesn't apear and if it does its only for less than a second.

    Help is much apreciated.
    Thanks in advance. :)
     

    #1
  2. NaterTots
    Jelly Bean Mar 24, 2016

    NaterTots , Mar 24, 2016 :
    I think it's an issue in the Oxygen OS.

    The VPN client I use has an Android app.

    It worked on my Opo, works on my N5, N9.

    But doesn't work on the Op2.

    Once we get MM with the new firmware, in assuming we will, then I'm switching to CM if the VPN still doesn't work.


    Oh, do a search, I think there are some other threads about this.
     

    #2
    bowlesg likes this.
  3. anupritaisno1
    KitKat Mar 24, 2016

    anupritaisno1 , Mar 24, 2016 :
    Disable xposed
     

    #3
    kanagadeepan likes this.
  4. bowlesg
    Eclair Mar 24, 2016

    bowlesg , Mar 24, 2016 :
    By xposed do you mean the entire framework or just the module. If its the module I have alreday done that, It had no affect.

    Thanks :)
     

    #4
  5. MafiaTechTeam
    Jelly Bean Mar 24, 2016

    MafiaTechTeam , Mar 24, 2016 :
    Its works fine when I used openvpn
     

    #5
  6. anupritaisno1
    KitKat Mar 24, 2016

    anupritaisno1 , Mar 24, 2016 :
    The entire framework
     

    #6
  7. bowlesg
    Eclair Mar 24, 2016

    bowlesg , Mar 24, 2016 :
    Not that I don't trust that you are right. Can anyone else confirm that they also have this problem with xposed installed. Its only because I rely heavily on some of the modules I have installed so to remove it would be a bit of a pain. :)
     

    #7
  8. kanagadeepan
    KitKat Mar 24, 2016


    #8
  9. bowlesg
    Eclair Mar 25, 2016

    bowlesg , Mar 25, 2016 :
    So did I, but after backing up my phone I decided to do a clean wipe (without touching /data) because I was already having problems with boot-loops etc. and needed to update SuperSU, TWRP and Xposed. Anyway everything is now fine VPNs work, and no more bootloops!!:) Thank you and I am sorry for doubting.:)
     

    #9