2
Cannot force 120hz on Android 12

  1. Dfast
    Eclair Jan 26, 2022

    Dfast , Jan 26, 2022 :
    While i got the phone, i found that when opening any google app(youtube, keyboard, etc.), the phone forced itself to render on 60hz, causing the phone to feel laggy
    i found a solution, using adb to force the phone to 120hz, everything went smooth, there were absolutely no problems with that at all
    https://forum.xda-developers.com/t/does-forcing-max-refresh-rate-via-adb-works.4253871/
    since Android 12...
    the command "adb shell settings put global oneplus_screen_refresh_rate 0" when tried to be run, it shows an error
    [​IMG]
    also, there is ANOTHER that does the job, its called the jOnePlus Tools, it's doing the same job, but not trough a computer but locally, the app just needs to be given access via a computer
    [​IMG]
    but yeah... it shows strange error and cannot be installed at all

    Please help, i have searched throughout the internet and all i see are these two methods, who do NOT work :( any advice is welcome

     

    #1
    Naveenbubly and petiantal like this.
  2. G1636453389752
    Froyo Feb 6, 2022

    Best Answer

    #9
    Dfast likes this.
  3. Xcommunicad0
    Lollipop Jan 26, 2022


    #2
    Gor. likes this.
  4. Dfast
    Eclair Jan 26, 2022

    Attached Files:


    #3
  5. Dfast
    Eclair Jan 26, 2022

    Dfast , Jan 26, 2022 :
    Progress: found the "Disable Permission Monitoring" setting in developer options. After enabling, the commands were ran successfully, but this changes nothing. adb shell settings put global oneplus_screen_refresh_rate 0 changes nothing, the one about the jOnePlus Tools work, but the application itself does not change anything. Maybe the new android's screen settings variable is elsewhere :(
     

    #4
  6. Xcommunicad0
    Lollipop Jan 26, 2022

    Xcommunicad0 , via OnePlus 8T , Jan 26, 2022 :
    Seems like some specific root access has been explicitly restricted even in USB debugging mode in Android 12.
     

    #5
    Gor. likes this.
  7. Dfast
    Eclair Jan 26, 2022

    Dfast , via OnePlus 9 Pro , Jan 26, 2022 :
    with disable permission monitoring it's able to bypass it but the command about higher refresh does nothing, and the app does nothing :(
     
    Last edited: Jan 26, 2022

    #6
    Yinon12301 likes this.
  8. Yinon12301
    Cupcake Feb 2, 2022

    Yinon12301 , Feb 2, 2022 :
    stuck at the same point.
    I tried everything, is there any changes to the adb command that we need to apply? or maybe a different command to write?
    (maybe because we need to write it slightly different when dealing with android 12 - at oneplus 7 pro with android 11 it worked perfectly)
     

    #7
    Dfast likes this.
  9. Dfast
    Eclair Feb 6, 2022


    #8
  10. Dfast
    Eclair Feb 15, 2022


    #10
    G1636453389752 likes this.
  11. ascent
    Honeycomb Feb 25, 2022


    #11
    Dfast likes this.