1

Cannot read "ota.zip"

  1. kadiix Ice Cream Sandwich Aug 1, 2016

    kadiix, Aug 1, 2016 :
    Hi,
    I would like to do an sideload adb but when I start the command I have an error:
    Cannot read "ota.zip"
    But why ?
    How to resolve this problem ?
    Thank you.
     

    #1
    SatriaPerdana likes this.
  2. kadiix Ice Cream Sandwich Aug 1, 2016


    #2
  3. kryshnakishore Ice Cream Sandwich Aug 1, 2016


    #3
  4. ttwwbx Froyo Aug 1, 2016

    ttwwbx, Aug 1, 2016 :
    I had the same problem while I was trying to sideload the current OOS 3.2.2 zip via TWRP. If you have TWRP installed, you can transfer the zip with the windows file explorer to the OP3 and flash it with TWRP.
    Otherwise, check if you have the latest adb files, reboot your computer, check if you have the latest drivers for your devices (ADB & OP3 drivers) and than try it again.
     

    #4
    Kbrackson and jim262 like this.
  5. hawgwild Eclair Aug 2, 2016

    hawgwild, Aug 2, 2016 :
    Same problem here. I also tried to install the stock OOS 3.2.2 via sideload because I had the impression that it didn't install propoerly with TWRP. No chance to sideload it. Is there a file size limit for this?
     

    #5
  6. ungeeked Ice Cream Sandwich Aug 2, 2016

    ungeeked, Aug 2, 2016 :
    I've sideloaded 3.2.2 twice without issues. One was using old recovery by garak and other using official twrp.

    Pretty sure this has something to do with adb drivers on your computer. Clean install adb and device drivers using this
     

    #6
  7. pmdsp Honeycomb Jan 5, 2017

    pmdsp, Jan 5, 2017 :
    If anyone still facing this issue then try below.

    1, Make sure the device is detected as below if not install adb drivers and manually load drivers by > Update Driver Software > Browse my computer for Driver Software > Let me pick from the list of device drivers on my computer > Android ADB Interface.
    [​IMG]

    2, Copy the ROM file (zip file) to your C drive.
    upload_2017-1-5_19-22-51.png

    3, Run the comment and drag the .zip on CMD window.
    upload_2017-1-5_19-23-44.png
     

    Attached Files:

    • adb.png
      adb.png
      File size:
      5.8 KB
      Views:
      40,360

    #7
    tarun.konduri likes this.
  8. CaptainHaji Cupcake Jan 22, 2017

    CaptainHaji, Jan 22, 2017 :
    Far simpler solution for the above is to copy the file to your phone's storage, enable developer options, reboot into recovery and install the update from there.

    No need for extra drivers and forcing Windows to read unsigned drivers, etc.
     

    #8
    Sol_3 and otto2 like this.
  9. Organhaendler Cupcake Feb 15, 2017

    Organhaendler, Feb 15, 2017 :
    Hello guys!

    I hope that I am not too late on this, but i had the same problem and found a solution for this that worked for me :)

    The problem seems to be that the adb.exe (at least the one that is recommenden by funkwizard) seems to be unable to allocate more than 2gb of memory to the process of sideloading stuff (I am not exactly a professional, so the semantics on this one is problably not correct right now ^^)

    Solution is to add a largeaddressawareness flag to the .exe:
    https://forum.xda-developers.com/showpost.php?p=69648733&postcount=47
    --> this thread explains the solution along with a link to the application that will solve the problem.

    I found the solution on reddit, worked for a lot of people already.
     

    #9
    iamamit, kadaradam, aqd890 and 3 others like this.
  10. Nodrod Donut Mar 21, 2017

    Nodrod, Mar 21, 2017 :
    Thanks for this, used the large adrress aware app and it worked flawlessly.
     

    #10
  11. G_Alfonso_Pitarch_DazX Donut Mar 21, 2017


    #11
  12. F_Tony_DeMartino_hjHI Ice Cream Sandwich Mar 21, 2017


    #12
  13. despeh Froyo Mar 23, 2017

    despeh, Mar 23, 2017 :
    i find it due to the memory ran out due to too much application running at background. After restart the machine, and rerun back the ADB sideload, it will run successfully. Hope this will work for you.
     

    #13
  14. G_Mike_Lee_FKXR Donut Mar 23, 2017

    G_Mike_Lee_FKXR, Mar 23, 2017 :
    I had a issue which is related to this problem. I managed to fix it by dragging the file in to the terminal/command prompt. Hope this will work for you.
     

    #14
  15. ssalgooglass Cupcake Mar 31, 2017

    ssalgooglass, Mar 31, 2017 :
    same problem for me! but im windows 10 and 64bit. I found the solution by using 64bit ADB a download link is here to another site that helped.

    flashtools64
     

    #15
    prmcmanus, brunopkieffer and neisor like this.
  16. JorgeManuelSilva91 Ice Cream Sandwich Mar 31, 2017

    JorgeManuelSilva91, Mar 31, 2017 :
    I have lost count of the times I pointed users in the right direction to fix this problem.

    https://forums.oneplus.net/posts/15836034
     

    #16
    SatriaPerdana and Sun90 like this.
  17. ZeevoX Froyo Mar 31, 2017

    ZeevoX, Mar 31, 2017 :
    This is a known bug in the latest ADB and Fastboot from Google. Try downloading platform-tools v25.0 and try again. (I had the same issue)
     

    #17
    Sun90 likes this.
  18. Deniece611 Cupcake Mar 31, 2017

    Deniece611, Mar 31, 2017 :
    Thank you for the guide, works flawlessly as well. Those who still have problem just use this solution will do.
     

    #18
  19. SatriaPerdana Ice Cream Sandwich Apr 9, 2017

    Attached Files:


    #19
  20. JorgeManuelSilva91 Ice Cream Sandwich Apr 9, 2017

    JorgeManuelSilva91, Apr 9, 2017 :
    How much RAM does your computer have?

    The process itself consumes about 2 GB, so your computer needs to have at least 4 GB RAM installed and all unneeded applications closed.
     

    #20