0
Cannot send text message...

  1. bunheng
    Donut Sep 18, 2014

    bunheng , Sep 18, 2014 :
    I need help.
    After upgrading to 4.4.4, I just realize that I can't send text message.
    I'm using t-mobile and I can make call, receive text, use Internet, send MMS.
    THEORY ONLY PRO LET IS SENDING TEXT MESSAGE.

    I've tried reset, reinserted SIM card, and changed to other SIM card.
    After all, it still didn't work.
     

    #1
  2. DRCH
    Marshmallow Sep 18, 2014


    #2
    bunheng likes this.
  3. bhavsarrohit
    Ice Cream Sandwich Sep 18, 2014


    #3
    bunheng likes this.
  4. saminpgh
    KitKat Sep 18, 2014


    #4
    bunheng and GallantJR like this.
  5. Rajatbosch
    Honeycomb Sep 18, 2014

    Rajatbosch , Sep 18, 2014 :
    I think you need to kiss your phone ..:p
     

    #5
    bunheng likes this.
  6. amorosa
    Honeycomb Sep 18, 2014

    amorosa , Sep 18, 2014 :
    Make a factory reset ! Its the best way to get rid of these errors.

    Or just download the ( are we talking about the stock Cm11s rom ?? ) full stock cm11s 33R and you flash it via fastboot. Its the cleanest way.
     

    #6
    bunheng likes this.
  7. Hixxy
    Froyo Sep 18, 2014


    #7
    Linanc7 and bunheng like this.
  8. dbanez25
    KitKat Sep 18, 2014

    dbanez25 , Sep 18, 2014 :
    try hangout
     

    #8
    bunheng likes this.
  9. laloman18
    Ice Cream Sandwich Sep 18, 2014

    laloman18 , Sep 18, 2014 :
    Clear the cache & data cache of the messaging app via settings>apps.
     

    #9
    Linanc7 and bunheng like this.
  10. winnycarl
    Donut Sep 18, 2014


    #10
    bunheng, Alex_D8, Joey96 and 6 others like this.
  11. amorosa
    Honeycomb Sep 18, 2014

    amorosa , Sep 18, 2014 :
    Yes. Try all these solutions and the last way is a fresh install via fastboot.
     

    #11
    Linanc7 and bunheng like this.
  12. hazelkid
    Honeycomb Sep 18, 2014

    hazelkid , Sep 18, 2014 :
    *#*#4636#*#* and check the SMS gateway number. Might be the wrong one. Good Luck! ;)
     

    #12
    Linanc7 and bunheng like this.
  13. amorosa
    Honeycomb Sep 19, 2014

    amorosa , Sep 19, 2014 :
    Please report to us if some of the soloutions helped you. So you can help other people with your report :)
     

    #13
  14. DrJMun
    KitKat Sep 19, 2014

    DrJMun , Sep 19, 2014 :
    wow, i'm impressed with all the great suggestions in here. If all else fails take it to t-mobile and see what they can do.
     

    #14
    amorosa likes this.
  15. haastile
    Eclair Sep 27, 2014

    haastile , Sep 27, 2014 :
    I just got my OBO. Had the same problem. Turned out it was the Voice+ app. During setup, there's a prompt to allow Voice+ to authorize all SMS messages to be encrypted (and send through Google Voice.) That's what disabled outgoing text messages from Hangouts and Messages. Once you disable Voice+, texting works again. Go to: SETTINGS > WIRELESS & NETWORKS > MORE... > VOICE+
     

    #15
    darkstarchuck, pdsantos and zaidat20 like this.
  16. Deactivated User
    Sep 30, 2014


    #16
    davidtb and iikazi like this.
  17. omerpasa
    Eclair Oct 14, 2014

    omerpasa , Oct 14, 2014 :
    Where is voice+ icon I cannot see it? I went to setting/wireless/more/ there is no such thing voice
     

    #17
    ao7 likes this.
  18. ankit.bgp
    Cupcake Dec 15, 2014

    ankit.bgp , Dec 15, 2014 :
    I received my set two days back and I am facing the issue with sending text messages. On my Nexus 4, I was able to send text even at 2 or 3 signal bars but with One Plus I just can't. The problem maybe because of the use of LTE network, which is very poor on t-mobile, and Nexus 4 was not 4G/LTE enabled. But its a pain in the neck.
     

    #18
  19. Collarman
    Cupcake Dec 19, 2014

    Collarman , Dec 19, 2014 :
    I am having issues with the stock text messaging app so far, when I text someone from my contact list a few numbers only show up not the entire number. People can't seem to get my text message as a result. I love this phone with this exception.
     

    #19
  20. gillie2
    Donut Dec 22, 2014

    gillie2 , Dec 22, 2014 :
    i can confirm that "haastile's" solution of unsetting the voice+ option fixes the text message sending problem.

    really insane that something simple as text messaging doesnt work by default on the one plus one
     

    #20