0
Can't boot into recovery

  1. chris-red
    Gingerbread Mar 31, 2016

    chris-red , Mar 31, 2016 :
    Hi all, I thought it would try OOS3 and followed the guide to install it. I was running MM fine, but decided to go back to 2.2.1 using my TWRP backup. I booted into recovery executed the recovery successfully then rebooted. Now it just stays on the oneples loading screen and does nothing. I tried to go back to recovery (hold vol down while powering on) but nothing happens it just goes to the OP loading screen where it hangs. I can get into fast boot (Power + Vol up) but not recovery!

    HELP!
     

    #1
  2. Jitesh Saitawadekar
    KitKat Mar 31, 2016

  3. msmilkshake
    Honeycomb Apr 1, 2016

    msmilkshake , Apr 1, 2016 :
    I am having exact same issue. Tried installing recovery through fastboot and nothing. Stuck on 1+ logo when trying to boot into recovery.
     

    #3
  4. peppeuz
    Froyo Apr 4, 2016

    peppeuz , Apr 4, 2016 :
    Same here. I just wanted to do a full backup and I can't find the TWRP recovery.
    I tried re-flashing it from bootloader and it seems that everything is ok, but when i try to boot it from bootloader (with ./fastboot boot recoveryname.img) I get
    "FAILED (remote: dtb not found)"

    This happens whatever recovery I'm trying to flash.

    If I try to boot it with volume down+power or with the advanced reboot, I got stuck on OnePlus logo.
     

    #4
  5. aleguillou
    Cupcake Apr 4, 2016

  6. matt_simpson
    Ice Cream Sandwich Apr 4, 2016

    matt_simpson , Apr 4, 2016 :
    this is what you need
    http://forum.xda-developers.com/oneplus-2/general/firstaid-zip-revert-h2os-mm-beta-to-lp-t3306967
     

    #6
    dinjesk and peppeuz like this.
  7. peppeuz
    Froyo Apr 5, 2016

    peppeuz , Apr 5, 2016 :
    Yep, you're both right: i was able to flash that recovery without any problem.
    Thanks.
     

    #7
  8. sixthspeed
    Cupcake Oct 2, 2016

    sixthspeed , Oct 2, 2016 :
    anyone have an idea to implement this for OPX? I have the same issue after flashing 3.1.3 from 2.2.3
     

    #8
  9. Patil_Aakash
    Cupcake Oct 30, 2016


    #9
  10. Aditya.khan.delwal
    Cupcake Nov 29, 2016

    Aditya.khan.delwal , Nov 29, 2016 :
    i have hydrogen os installed but the device has lost its recovery...!!!
    i tried to install it with flashify or twrp manager and it shows installed but again stuck at 1+ logo while in recovery mode..!!
    plzzz help...!!!
     

    #10
  11. vishnukunnathully
    Cupcake Dec 2, 2016

    vishnukunnathully , Dec 2, 2016 :
    I too had the same situation. Accidentally my TWRP got replaced by Cyanogen recovery. And while trying to flash TWRP back my OP2's recovery got missing and had only the 1+ icon.
    Your phone is in a softbrick condition.

    TRY THE METHOD 1 FROM THE BELOW LINK, IT SURELY WORKS

    https://forums.oneplus.net/threads/...ck-guide-for-a-hard-bricked-oneplus-2.347607/

    If you don't have bootable OXYGEN OS in your phone, download latest Oxygen OS
    and do adb sideload as mentioned in the instructions.

    It fixed for me and will do for you too.
    :)
     

    #11
  12. G_Nafiz_Mustafa_lvXN
    Cupcake Dec 25, 2016

    G_Nafiz_Mustafa_lvXN , Dec 25, 2016 :
    that does not do anything. i am stuck in fastboot mode and there is no recovery it sayd dm-verity not enforced or something error. someone please help me this is the only phone i have and the sim card is nano and my old phones wont work!
    help!!
     

    #12
  13. rebellion786
    Cupcake Dec 25, 2016

    rebellion786 , Dec 25, 2016 :
    Guys , I tried to root my device on 3.5.5 so I can try the Network Guru option .. But now my device on stuck on boot screen the spinning rings. Unlocked bootloader, flashed TWRP and SuperSu .. and then device stuck on boot spinning rings. Any help would be appreciated.
     

    #13
  14. anish143
    Cupcake Feb 26, 2017

    anish143 , Feb 26, 2017 :
    I did have a similar issue when I was trying to flash back the oxygen ROM from RR on the OP2, I had issues installing the latest Oxygen ROM, even though the installation was successful the apps wouldn't load. I decided to flash the older version of the Oxygen ROM. Due to that I had the 1+ logo screen when i tried to access recovery. I installed the older version of TWRP recovery and it was fine.
     

    #14
  15. Arashsh2001
    Cupcake May 25, 2017

    Arashsh2001 , May 25, 2017 :
    guys just had a quick question! does this work for oneplus 1 as well? or is it just the oneplus 2?
     

    #15
  16. Tarun.venky
    Cupcake May 25, 2017

  17. robing7
    Cupcake Jul 19, 2017

    robing7 , Jul 19, 2017 :
    I have the same problem for the oneplus x.
    Do you know what the solution is? please
     

    #17
  18. dan50
    Gingerbread Jul 25, 2017

    dan50 , Jul 25, 2017 :
    Well, seems like this is similar to my problem, it just stays stuck at the opo logo, no twrp and not even recognised by the pc.

    What can I do to reverse it?
     

    #18