20
Can't enable Voice Match

  1. roel5684
    Cupcake Mar 2, 2019

    roel5684 , Mar 2, 2019 :
    @Selas:
    No, unfortunately still no access to VoiceMatch (still greyed out) and no response on "ok Google" voice command neither. I'm on OnePlus 6T Dutch as 1st language
     
    Last edited: Mar 2, 2019

    #81
  2. nojas
    Cupcake Mar 20, 2019

    nojas , Mar 20, 2019 :
    I found the solution that works for me on my 6T.
    I closed the setting app just after adding my voice sample(without hiting ok button).
    But itn turns off when I try to go yo this setting again.
     

    #82
  3. nojas
    Cupcake Mar 21, 2019

    nojas , Mar 21, 2019 :
    Finally solved the problem by enabling another language of device and switching it at my language again.
     

    #83
  4. Shpend.Mustafa
    Cupcake Apr 1, 2019

    Shpend.Mustafa , Apr 1, 2019 :

    Hi!

    i did the same and it work! but i got to stick to the English language. If i switch it back to swidish, then google assistent turn off as a result.
     

    #84
  5. frisoroel84
    Cupcake Apr 27, 2019

    frisoroel84 , Apr 27, 2019 :
    come on. It's just saying he's to blame. No evidence mentioned. This doesn't bring us further.
    Fact is that the same Google App version works on my son's Samsung Note 8 but neither on my OPO or Op6T.
    In my humble opinion OnePlus doesn't authorize Google Voice Match. If it is not authorized the app can not listen to an "hey google” request.
     

    #85
  6. M1541677725905
    Cupcake May 14, 2019

    M1541677725905 , May 14, 2019 :
    this fixed it for my op6t

    settings, apps, Google, storage, clear storage and clear cache

    then

    settings
    Google
    voice
    retrain voice

    magic , ok Google works again
     

    #86
  7. frisoroel84
    Cupcake May 14, 2019

    frisoroel84 , May 14, 2019 :
    @M154....
    This has been mentioned a dozen times and I've tried it multiple times but alas.
    Are you sure that your VoiceMatch was originally greyed out or was it active but training was impossible. In my case the VM is consequently greyed out so I don't have any permission to voice-train whether or not cleaning cache nor memory.
    Roel
     

    #87
  8. nathieman
    Ice Cream Sandwich Jun 12, 2019

    nathieman , Jun 12, 2019 :
    I have found the weirdest solution to this. With the voice model trained I open assistant and make sure it's not already listening for commands. So the little mic should be showing at the bottom of the screen. Then I just say hey google and it prompts me to enable the voice detection like it would when trying to enable it in the settings.

    Somehow this enables it, going back to the settings page where you can enable voice match will however disable it again! So I'm unable to unlock my phone with voice match since I can't toggle that setting.

    If it doesn't trigger, enable and disable Google assistant in the same place you can('t) enable voice match.
     

    #88
  9. Md Aquib Ansari
    Eclair Jun 13, 2019


    #89
  10. C1562309608262
    Cupcake Jul 5, 2019

    C1562309608262 , Jul 5, 2019 :
    Hi all,

    A new proud oneplus 7 owner, before that I always used Samsung and it was an old one. So I never used the assistant. I waited for my new phone. My native language is Dutch and I had the same problem as u guys explained as well. Also voice match was greyed out in my settings. My solution is:
    Set the phone language to English US and the second to Dutch, I did the same for the assistant (it works fine with two languages, I can speak Dutch and English to my assistant). And I could learn my voice to my assistant and the option voice match isn't greyed out anymore. I hope this solution can help u all.
     

    #90
  11. sonnyhaze
    Eclair Jul 10, 2019

    sonnyhaze , Jul 10, 2019 :
    Alright guys I've been wrestling with this mother of a problem since I bought my Oneplus 7 Pro. I have made headway though. For me it wouldn't let me click on voice match, i tried everything, or at least I thought. So I found a solution, and that's by Enabling Google Assitant with Beta Apps. Follow these steps and you'll be right as rain...
    1. We are going to start by signing to the beta versions. Go to Settings > Google.
      [​IMG]
    2. Now tap on the three-dot menu icon located in the top-right corner of the screen. Select Help & feedbackfrom the next menu.
      [​IMG]
    3. Once you’re on the Help page, tap the three-dot menu icon again and select View in Google Play Store.
      [​IMG]
    4. This will open up a new Google Play window with Google Play Services. Ignore the fact that it needs to update, we’ll deal with that later on.
      [​IMG]
    5. Scroll all the way down to the Beta program and tap on I’m in.
      [​IMG]
    6. After a while, you will be invited to complete the beta sign up. Do so by tapping on Join. After you hit Join, it will take at least 5 minutes until the sign up is complete. In my case, it took over 10 minutes.

    7. Now go to the home menu of Google Play Store and search for the “Google App”.
      [​IMG]
    8. Scroll all the way down to the beta program and tap on I’m in. Confirm again by tapping Join.
      [​IMG]
    9. Now, wait for a few good minutes to make sure the beta signup completes on both apps. After a while, tap the action button inside Google Play Store and go to My apps & games.
      [​IMG]
    10. From the following screen, expand the Beta tab and locate Google and Google Play Services.
      [​IMG]
    11. Tap on the Google app hit the Update button after making sure the beta signup is complete. You can for that by looking right under the Update tab. If it says “You’re a beta tester for this app“, then you’re good to go.
      [​IMG]Note: In the event that it says “Beta Sign up in progress” do NOT update the app yet. Instead, close Google Play Store and come back to this screen after a few minutes.
    12. After you’ve successfully updated the Google app, repeat the same procedure with Google Play services. Remember to make sure that the beta sign-up is complete before hitting Update.
      [​IMG]
    13. Once you got both apps updated, go to Settings > Apps (Applications) and make sure you select the All apps filter. Scroll down and tap on the Google entry.
      [​IMG]
    14. Go to Storage tap on Manage space and hit Clear All data.
      [​IMG]
    15. Now go back to Settings > Apps (Applications), enable the All apps filter again and tap on Google Play Services.
      [​IMG]
    16. Go to Storage > Manage Space and tap on Clear All Data.
      [​IMG]
    17. Now the setup is almost complete. You can finally open the Google app. You will be asked to insert your credentials straight away. After you insert them, tap on Get Started.
      [​IMG]
    18. Expand on the action menu (located in the top left corner) and tap on Settings.
      [​IMG]
    19. Now tap on Settings (under Google Assistant) and select Phone (under Devices).
      [​IMG]
    20. Now make sure Google Assistant is enabled. If it isn’t enabled, tap on the toggle next to it.
      [​IMG]
    21. That’s it. Google Assistant should now be enabled on your device. You can test it by saying “OK, Google” near the microphone. You don’t necessarily have to be in the Google app, it works in every screen.
      [​IMG]
     

    #91