0
Can't install custom recovery TWRP

  1. Castiel260
    Eclair May 8, 2015

    Castiel260 , May 8, 2015 :
    Hi,
    I have screen sensitivity issues and I heard that Exodus ROM solving this issues and I tried to install it yesterday I found some tutorials on Youtube I did everything exactly like in the tutorial but when I boot my OPO to TWRP it just booting to the default recovery mode
    what I did wrong?
    THANKS!!!!!
     
    Last edited: May 8, 2015

    #1
  2. Castiel260
    Eclair May 8, 2015

  3. MoDDe88
    Cupcake May 8, 2015


    #3
    paz660 and BiffTirkle like this.
  4. oneplemetoo
    Eclair May 8, 2015

    oneplemetoo , May 8, 2015 :
    Dont let your phone reboot after you flash recovery or it will go back to default recovery, after you flash custom recovery and phone starts to reboot switch it off by holding power button and then boot in recovery. I had the same issue and learned after 3 flashes you cant let the phone boot or its gone again.
     

    #4
  5. magiccube007
    Cupcake May 15, 2015

    magiccube007 , May 15, 2015 :
    I tried to install a new recovery on my phone but every time i boot in to the recovery of cm (im on cm12 on cm11 all worked like i did) I have turned update cm recovery off in the developer options
    would be ncie if somebody could help me with that problem
     

    #5
  6. magiccube007
    Cupcake May 15, 2015

    magiccube007 , May 15, 2015 :
    thx dude i was sitting there for like 2 houres thx
     

    #6
  7. Spannaa
    KitKat May 15, 2015

    Spannaa , May 15, 2015 :
    Try searching ;)

    Can't install custom recovery TWRP
     

    #7
    mcsememo likes this.
  8. tarana2000
    Froyo May 15, 2015

    tarana2000 , May 15, 2015 :
    I assume that you are using adb

    You install twrp using this command

    fastboot flash recovery twrp.img

    after it installs successfully, reboot using this command

    fastboot boot twrp.img

    This will work.

    OTA updates can overwrite the recovery partition and restore the stock CyanogenMod Simple Recovery. To avoid this, go to Developer options and make sure that Update CM recovery option is disabled.
     

    #8
  9. oneplemetoo
    Eclair May 16, 2015

    oneplemetoo , May 16, 2015 :

    No worries glad to help, Thats what i love about the oneplus if there's any little problem somebody is always around with an answer to solve it.
     

    #9
    Habib.khan316 likes this.
  10. JaimeSantos
    Eclair May 16, 2015

    JaimeSantos , May 16, 2015 :
    Thanks dude, I was really desperate about it. Literally, I've been here for 2 hours.
     

    #10
  11. qasimchadhar
    Cupcake Aug 14, 2015

    qasimchadhar , Aug 14, 2015 :
    Any reason why any of these steps wouldn't work? I've tried TWRP, Philz, CWM recoveries, "fastboot erase recovery" then "fastboot flas recovery twrp.img" then fastboot boot twrp.img with no success. Also tried following:
    • Press and hold volume down + power button quickly after running fastboot reboot.
    • After flashing recovery, don't run fastboot reboot, instead power down the phone using power button, unplug phone from USB, then power phone using volume down + power button
    • After flashing recovery, don't run fastboot reboot. Instead, power down the phone using volume down + power button then power it up using volume down + power button.
    I just got this phone yesterday and it keeps rebooting into stock recovery. I've tried OPO Toolbox and also entered commands in command prompt (with admin privileges on computer; although I find these privileges unnecessary for these steps).
     

    #11
  12. dewsy
    Cupcake Aug 26, 2015

    dewsy , Aug 26, 2015 :

    Hey!
    I was just like u. Got my opo 64 yesterday, tryed everithing you tryed without success. For me, Bacon root Toolkit solved the problem. Just follow the steps expect two. At the start choose opo 32/64 wich you have, and for the rom pick any rom method. Follow steps until you installed permanent twrp supersu and busybow from the non permanent twrp. !!! You need to check flash twrp beside the root checkbox in the program. The toolkit needs time to boot from fastboot to twrp during the proceess, so let it work for a minute at that point!! Bacon says reboot system. -instead of that i rebooted the recowery. And then from the fresh new permanent TWRP reboot system and follow the Bacon istructions again.

    here is the download, hope it works for you too:
    http://www.wugfresh.com/brt/
     
    Last edited: Aug 26, 2015

    #12
  13. dhaval.soneji
    Donut Nov 28, 2015

    dhaval.soneji , Nov 28, 2015 :
    THANK YOU SO MUCH [THIS WORKED FOR MY X]
     

    #13
  14. talboris
    Cupcake Jan 31, 2016

    talboris , Jan 31, 2016 :
    PLZ HELP! i
    cant install twrp for 2 days already, it installs well with flash recovery twrp.img , but this -->
    fastboot boot twrp.img
    doesnt work , it says failed remote dtb not found
    and after i flash twrp i cant log in to recovery, its boots and its overwrite the twrp recovery, i tried 20 times not to boot after flash, but its boot


     

    #14
  15. evertking
    Ice Cream Sandwich Apr 30, 2016

    evertking , Apr 30, 2016 :
    Did you solve this?
     

    #15
  16. Lordkay972
    Cupcake May 15, 2016

    Lordkay972 , May 15, 2016 :
    I'd also like to know. I think it has something to do with updating to Marshmallow before the OTA update. I'm having the same problem. "FAILED (remote: dtb not found)"
     

    #16
  17. Lordkay972
    Cupcake May 15, 2016

    Lordkay972 , May 15, 2016 :
    I've found the solution that someone else found in this thread http://forum.xda-developers.com/oneplus-2/help/unable-to-flash-twrp-remote-dtb-t3358566 which lead me to this thread http://forum.xda-developers.com/showpost.php?p=66336492&postcount=3 which told me to download and flash this https://www.androidfilehost.com/?fid=24459283995297945 Hope this helps!
     

    #17
    evertking likes this.
  18. binoyb9
    Eclair Apr 13, 2017

    binoyb9 , Apr 13, 2017 :
    This worked buddy...Thanks...:)
     

    #18