0
can't OEM unlock!

  1. mrhansenable
    Cupcake Sep 18, 2016

    mrhansenable , Sep 18, 2016 :
    hey everyone. trying to OEM unlock the TWRP bootloader. When I type "fastboot OEM unlock" it will reboot into TWRP bootloader, and nothing unlocks. I know this because when I type "fastboot oem device-info" it says "unlocked FALSE".

    I have OEM unlock and USB debugging enabled.

    This is a phone with previously successfully installed CM13, and now I'm trying to revert to stock/unrooted. I can't seem to flash the recovery at all here because I can't get the damn thing to unlock.

    Any ideas?
     

    #1
  2. Mr. BG
    Welcoming Expert, Community Hero 2020 Community Expert Sep 18, 2016

    Mr. BG , Sep 18, 2016 :
    It needs a newer version of TWRP if I'm not mistaken, you'll find it on XDA i think.
     

    #2
  3. orionaselite
    Gingerbread Sep 18, 2016

    orionaselite , Sep 18, 2016 :
    Just use the tool in this post.

    https://forums.oneplus.net/threads/guide-mega-unbrick-guide-for-a-hard-bricked-oneplus-x.417648/

    That's what I did when I had the same issue
     

    #3
  4. vickyy17
    Gingerbread Sep 18, 2016

    vickyy17 , Sep 18, 2016 :
    i tried the same but when i open MsmDownloadTool V2.0.exe it says no devices. i did all the steps in the thread but the software is still not detecting my phone. also i cannot find the qualcomn drivers in device manager even though i disabled driver signature enforcement
     

    #4
  5. orionaselite
    Gingerbread Sep 18, 2016

    orionaselite , Sep 18, 2016 :
    You need to be in fastboot mode for the device to be detected. If you can open twrp boot into bootloader then try again or with keys do something like the below although I don't remember the sequence 100%

    1. Turn off the device
    2. Press and hold Volume Down key + Power Key about 10 seconds
    3. Release Power key only when device vibrates
    4. Release Volume down key when you see the recovery
    5. You should get to twrp
    Remember you actually want fastboot not recovery so select bootloader for twrp
     
    Last edited: Sep 18, 2016

    #5
  6. Papuni7
    Gingerbread Sep 18, 2016