1
Can't Receive/Answer Phone Calls

  1. poxopox
    Cupcake Mar 24, 2021

    poxopox , Mar 24, 2021 :
    I have Google Fi. Before this 11 update, everything worked fine. I could make and receive calls. Voice over wifi and LTE worked. Now I can make outbound calls but I can't answer phone calls. When I try and answer, the app just freezes and goes back to the screen telling me to answer or decline. I've even tried different phone apps, turning off wifi calls, restarted my phone, reset network settings.

    How do I revert to the old version?
     

    #1
    G1558571319861 likes this.
  2. poxopox
    Cupcake Mar 24, 2021

    poxopox , Mar 24, 2021 :
    UPDATE: I just restarted into safe mode and calls were able to be answered. Im going to try and see if restarting after that works

    UPDATE 2: Restarting doesn't solve the issue after safe mode. I think there's a way to clear cache or something in recovery mode so Ill try that next

    UPDATE 3: Going into recovery mode and clearing cache didn't fix it. I think Im going to have to go with a factory reset
     
    Last edited: Mar 24, 2021

    #2
  3. Niko Pappas
    Cupcake Mar 24, 2021

    Niko Pappas , Mar 24, 2021 :
    I am having a similar problem but in reverse. I have an unlocked Tmo Version of the OnePlus 7T Pro Mclaren and I cannot make outgoing calls. (This is still on Android 10)

    The only work around I have found is to switch my cellular network to 2G only.

    NOTE: I previously had an international version of this same phone and never had this issue.
     

    #3
  4. poxopox
    Cupcake Mar 24, 2021

    poxopox , Mar 24, 2021 :
    One thing I noticed was in Safe Mode, where every thing works, VoLTE was turned off and it only went through VoWiFi. Currently to turn off VoLTE is to go into the SIM settings and toggle it off there, but every time I do that, navigate out and back again, the setting is back on. I can't seem to actually turn off VoLTE
     

    #4
  5. poxopox
    Cupcake Mar 24, 2021

    poxopox , Mar 24, 2021 :
    I just did a factory reset and now calls work. As expected the VoLTE is gone and calls are received just fine.

    The VoLTE switch needs to be fixed or provide some feedback to why it can't be switched off.

    UPDATE: After installing the Google Fi App, it switched VoLTE back on.... this broke it again.
     
    Last edited: Mar 24, 2021

    #5
  6. Niko Pappas
    Cupcake Mar 29, 2021

    Niko Pappas , Mar 29, 2021 :

    I manually changed my APN to Google Fi to Project Fi (They were listed and selectable) and I manually set my network to google and that solved my issue (So far)
     

    #6
  7. G1558571319861
    Cupcake Mar 30, 2021


    #7
    poxopox likes this.
  8. McLarenMania
    Gingerbread Mar 31, 2021

    McLarenMania , via OnePlus 7T Pro 5G , Mar 31, 2021 :
    How did you manage to get Android 11. I am still on 10 with Tmo
     

    #8
  9. McLarenMania
    Gingerbread Mar 31, 2021


    #9
  10. nerdam
    Donut Apr 5, 2021

    nerdam , Apr 5, 2021 :
    I have the same problem, this is a major defect, please fix asap, Google Fi, 7tpro
     

    #10
    G1558571319861 and poxopox like this.
  11. McLarenMania
    Gingerbread Apr 6, 2021


    #11
  12. Niko Pappas
    Cupcake Apr 21, 2021

    Niko Pappas , Apr 21, 2021 :
    That appears to have worked.... I will have to test it and make sure it stays stable.

    Is the DNS issue because it is routing calls through the LTE Data?
     

    #12
    McLarenMania likes this.
  13. McLarenMania
    Gingerbread Apr 21, 2021

    McLarenMania , via OnePlus 7T Pro 5G , Apr 21, 2021 :
    Yes that's right. Glad it worked 🙂
     

    #13