0
[Submitted] Cant send a Premium SMS

Thread Status:
Not open for further replies.
  1. suneeet
    Cupcake Jan 21, 2017

    suneeet , Jan 21, 2017 :
    Im using the OP3, latest 4.0.2 OTA update (stock).

    Im unable to send Premium SMS using any app. That includes the stock app and anything decently rated on Google Play.

    In the settings menu, No app has requested for Premium SMS Access. Please help as this is a deal breaker for me.
     

    #1
  2. suneeet
    Cupcake Jan 21, 2017


    #2
  3. Kristijan Puljek
    Gingerbread Jan 25, 2017

    Kristijan Puljek , Jan 25, 2017 :
    Similar problem, but only in Signal. It's not on the Premium SMS app list at all and doesn't ask for permissions when trying to send the message. The same version of Signal worked before the Nougat upgrade. Other SMS apps can send premium SMS just fine.
     

    #3
  4. Samliganda
    Cupcake Feb 15, 2017

    Samliganda , Feb 15, 2017 :
    Same here. It says Hi. "No installed apps have requested Premium SMS Access". Why is this so? In Samsung it asks ASK, NEVER ALLOW, ALWAYS ALLOW.

    I'm dying to get this, since I pay my parking through special number.
     

    #4
  5. toomuchshashi
    Eclair Apr 26, 2017


    #5
  6. me_nirlal
    Gingerbread Apr 27, 2017

    me_nirlal , Apr 27, 2017 :
    R u trying to send Premium SMS through Jio SIM??
     

    #6
  7. pankaj.1207
    Donut May 9, 2017

    pankaj.1207 , May 9, 2017 :
    I have the same issue. I am able to send to the premium numbers as well if i am using different mobile. This is the issue only with the oneplus 3t. Please help if someone has any idea to resolve it.

    Thanks.
     

    #7
  8. reydernation
    Cupcake May 15, 2017

    reydernation , May 15, 2017 :
    I too am having this issue. Any solution? How do I turn on premium SMS access on my 3t device?
     

    #8
  9. pankaj.1207
    Donut May 31, 2017

    pankaj.1207 , May 31, 2017 :
    Ok Guys have got the solution for this finally .. phewww. I had opened a Bug with Oneplus and they helped me on this. Follow the below steps
    Just goto Settings->Apps->Click on the gear symbol(top right)->Special Access->Draw over the apps->Click on the three-dot menu(top right)->Show system->scroll down and find "Phone Services"->Turn it on, that's it. Now go to your sms app and try sending any sms to the premium number. You will be prompted to with an alert box to send it or not. check the box with "Remember my choice". Now when you go and check Settings->Apps->Click on the gear symbol(top right)->Special Access->Premium SMS acess, you can find your sms app listed there.

    Cheers!!
     

    #9
  10. F_Sourabh_Pathak_Bittu_a
    Eclair Oct 2, 2017

    F_Sourabh_Pathak_Bittu_a , Oct 2, 2017 :
    Thanx a ton brother....
     

    #10
  11. Mich O.
    Ice Cream Sandwich Jul 2, 2018

    Mich O. , Jul 2, 2018 :
    Hello @suneeet,

    This is from the OnePlus Bug Hunters.

    If this issue persists on the latest build, please raise a new bug report so that we will look into it again. This thread will now be closed.

    Thank you and have a great one.
     

    #11