0
[Submitted] Can't turn off color correction

  1. Ahlad V K
    Cupcake Aug 8, 2020

    Ahlad V K , Aug 8, 2020 :
    Color correction in the accessibility settings keeps turning on automatically. When it is turned off it automatically turns back on as soon as the settings is closed. This is very annoying because while color correction is turned on the color temperature of the screen is little warm, also I can't use other display settings like screen calibration, night mode and reading mode. I have attached screenshot please look into this issue.
     

    #1
  2. MDMujtaba999
    OnePlus Bug Hunter Staff Member Aug 9, 2020

    MDMujtaba999 , Aug 9, 2020 :
    We would like to have this checked further. We have got in touch with you via personal conversation and would request you to respond to the same.

    Regards,
    Mujtaba
     

    #2
  3. Nik.all4u22
    Donut Sep 6, 2020


    #3
  4. sonnyhaze
    Gingerbread Sep 17, 2020

    sonnyhaze , Sep 17, 2020 :
    Topic: Android setting from hell.

    I've been plagued by random black & white "spells" I guess you'd call it. Everytime I entered settings everything goes black and white. And sometimes ill pick up my phone to use it and it wont be in color. I'd have to restart Then i found the solution. Just turn off color correction.

    Well, that works for about 1 minute and suddenly its forced back on. I tried sneaking into settings right after so i could tweak it, but. Bam, color corrections back on again. A friggin nightmare.

    I finally figured it out what kept re-enabling color correction. I went to settings and just searched "color correction" (sometimes it takes a few seconds to populate). Well when i click on color correction in the accessibility settings you will see that its enabled obv. Well when I clicked on it, it told me color reduction overridden by Simulate color space right below the on/off switch.

    So, i backed out into settings where I could search and I typed "simulate color". It brought me to, "Simulate color space" in developer options. There you can disable it.

    DIRECTIONS:
    1.Go to developer options>simulate color space, then choose disable.
    2.Your done. Now go back into display settings and all settings will be restored.
     
    Last edited: Sep 17, 2020

    #4
    Ahlad V K and Nik.all4u22 like this.
  5. sonnyhaze
    Gingerbread Sep 17, 2020


    #5
  6. Nik.all4u22
    Donut Sep 26, 2020

    Nik.all4u22 , via OnePlus 8 Pro , Sep 26, 2020 :
    I checked the "simulate color space" option, and it was already disabled. But somehow when i disabled "color Correction" this time, it didn't turn back on automatically. So far, it's working fine.

    Maybe OP fixed it, or maybe the "simulate color space" option needed to be checked once. Either way, my problem seems to be solved.

    A very big thanks to you man... :)
     

    #6