18
Can't turn WiFi on...

  1. tyler138
    Eclair May 11, 2018

    tyler138 , May 11, 2018 :
    I can't seem to turn my WiFi on. Pulling down on the notification bar and clicking the WiFi tile does nothing.

    Going into settings, click on and goes straight onto off.

    Rebooting makes it work but only for a short amount time and then back off...

    On the lastest firmware and no updates.

    Any fixes, is it the software or hardware that's broken?


    1526030249494.jpg
     

    #1
  2. srachlinski
    Cupcake May 11, 2018

    srachlinski , May 11, 2018 :
    I have the same problem. I notice that, when the phone comes back from sleep, the WiFi is turned off and won't come back on. pressing the on button does nothing.
     

    #2
  3. wilski
    Froyo May 11, 2018

    wilski , May 11, 2018 :
    I have exactly the same problem. It only occurred over the last week. Following advice on this forum I have deleted recent apps, cleared caches and restarted numerous times. As commented above, once the phone has rebooted it connects via wifi within 5-10 seconds and works fine but as soon as the phone goes to sleep and disconnects from the network it struggles to automatically turn back on. Sometimes it can take 30-40 seconds to reconnect but usually doesn't. I've never had any issues with wifi previously. What's concerning is why the Wifi Settings 'page' crashes. Is the issue with the settings function, effectively preventing the wifi from turning on, and not actually the wifi adapter etc? This issue has literally bricked my phone as almost everything I do on it requires wifi....
     

    #3
  4. tyler138
    Eclair May 11, 2018

    tyler138 , May 11, 2018 :
    yes, the WiFi page is very kaggy for me and often crashes
     

    #4
    Nikhil Rahate likes this.
  5. Petjitsu
    KitKat May 11, 2018

    Petjitsu , May 11, 2018 :
    what kind of OxygenOS do you have installed?
    root device?
    magisk?
    I'm trying to figure out what the problem is
     

    #5
  6. Swatan
    Froyo May 11, 2018

    Swatan , May 11, 2018 :
    had the same problem... reset the network settings ..in backup and reset menu .. reset both carrier's... then go to recovery mode and wipe cache ... solved the problem for me .. try it ..
     

    #6
    Nikhil Rahate and G_mircea_ibAs like this.
  7. wilski
    Froyo May 11, 2018

    wilski , May 11, 2018 :
    OP3 64GB
    OS 5.0.1
    Android version 8.0.0
    Security Patch 1 December 2017
    Not rooted
    Not sure how to ascertain the other info
    Has anything been updated within the last 5-7 days that could have started the issue? I'm frequently receiving app updates and some system things automatically update. I'm wondering if something has a bug in it. My wife has exactly the same phone, bought at the same time and regularly updated (software), but she's not experiencing any issues whatsoever....
     

    #7
  8. PTuT
    Jelly Bean May 11, 2018

    PTuT , May 11, 2018 :
    Same issue I have and reported it. I found out that clearing the cache or force stop system application 'com.oneplus.wifiapsettings' will sometimes work but not all the time. As you mentioned, rebooting will do the job, temporarily. I am hoping this will get sorted out as this started with the last OOS update.
     

    #8
  9. wilski
    Froyo May 11, 2018

    wilski , May 11, 2018 :
    Sounds positive. Will try that later. It still doesn't explain why it's suddenly happening after months/years of working perfectly....
     

    #9
  10. elanglois
    Lollipop May 11, 2018

    elanglois , May 11, 2018 :
    Send feedback to OnePlus and stop clearing caches
     

    #10
  11. tyler138
    Eclair May 11, 2018

    tyler138 , May 11, 2018 :
    Not been rooted, version info in the pic.
    1526036210146.jpg
     

    #11
  12. Petjitsu
    KitKat May 11, 2018

    Petjitsu , May 11, 2018 :
    Screenshot_20180511-125737.jpg
    try:
    turn on all options
    sleep mode
    wait 10 minutes
    turn on the phone
    turn off all options

    improvement - wifi turns on in about 5 - 15 seconds
     
    Last edited: May 11, 2018

    #12
    raguram_official and PTuT like this.
  13. tyler138
    Eclair May 11, 2018

    tyler138 , May 11, 2018 :
    Reply from one plus. Told me the following. Just tried and WiFi is back, but does that after a reboot anyway. Will have to see if it stays on.

    OnePlus
    "
    This problem can probably be fixed by wiping cache in Recovery Mode on your phone, we’d recommend you to try this if convenient.

    a. Power off your phone.
    b. Press Power switch while pressing Volume Down button for four seconds.
    c. Choose language and tap "Wipe data and cache".
    d. Tap "Wipe cache" and reboot.
    "
     

    #13
  14. Petjitsu
    KitKat May 11, 2018

    Petjitsu , May 11, 2018 :
    it's not working
     

    #14
    Nikhil Rahate likes this.
  15. BooBzi
    Gingerbread May 11, 2018

    BooBzi , May 11, 2018 :
    Same problem for me too. I am on latest Open Beta 9 for OnePlus 5.
    Problem started just yesterday, so could be due to some updated apps (google services?)

    So wifi wont turn on after phone was sleeping (dont keep wifi during sleep setting is on). Phone starts sleeping, then disconnects from network and after waking up the phone, wifi is stuck and cant be turned in manually. Restart always helps till the next time when phone will sleep with turned on wifi.
    I have already tried deleting cache from recovery, will not help.
    Tried to get some logs on this, but I am no pro on this, and just found out that phone is trying to "disconnect from network" whole that time when the menu is stuck.. Will make some experiments more.
     
    Last edited: May 11, 2018

    #15
  16. G_mohammad_sharafi_qMRT
    Froyo May 11, 2018


    #16
  17. wilski
    Froyo May 11, 2018

    wilski , May 11, 2018 :
    What I don't understand is why my wife hasn't experienced any issues with her OP3. I'm begining to believe it's software corruption. Not finding a wifi signal is one thing but when the Wifi Settings 'page' crashes surely something's been corrupted somewhere. Two questions here: what is causing this and why does the issue get cleared when restarting the phone?
    Have all of you who are experiencing this issue got your wifi set to disconnect from wifi shortly after entering 'sleep mode'? Is anyone experiencing issues with this if they've selected 'Keep WiFi on during sleep'?
     

    #17
  18. DMBP
    Cupcake May 11, 2018

    DMBP , May 11, 2018 :
    i have the same problem and started yesterday too. Wait One Plus send a hotfix or something like that. My device is OP 5.
     

    #18
  19. BooBzi
    Gingerbread May 11, 2018

    BooBzi , May 11, 2018 :
    I am using Keep WiFi on during sleep mode, WiFi always hangs up!
     

    #19
    DMBP and G_mohammad_sharafi_qMRT like this.
  20. G_mohammad_sharafi_qMRT
    Froyo May 11, 2018

    G_mohammad_sharafi_qMRT , May 11, 2018 :
    me 2 it's start yesterday on my op5 I don't know whats wrong
     

    #20