0
Can't upgrade to LineageOS: zip signature verification failed or error 7

  1. smartmouse
    Eclair Apr 1, 2017

    smartmouse , Apr 1, 2017 :
    Hello,
    I have OnePlus One with Cyanogen OS v13.1.2 (Android 6.0.1) and TWRP v.3.0.2-0.
    I have tried to install LineageOS v14.1 (lineage-14.1-20170327-nightly-bacon-signed.zip) but TWRP says zip signature verification failed.
    So I disabled the zip verification and I get the following error:

    Can't install this package on top of incompatible data. Please try another package or run a factory reset and then Updater process ended with ERROR: 7.

    According to this post I tried to install the experimental version (lineage-14.1-20170123-experimental-bacon-signed.zip) but I get the same errors.

    What could I do to install Lineage on my OPO?
     

    #1
  2. Mykson
    Ice Cream Sandwich Apr 1, 2017

    Mykson , Apr 1, 2017 :
    You wiped everything except internal storage?
    Why don't you use the latest TWRP version if you have problems?
     

    #2
    smartmouse likes this.
  3. Pedro Santos Sobral
    Eclair Apr 1, 2017


    #3
    Dunnow likes this.
  4. Mykson
    Ice Cream Sandwich Apr 1, 2017

    Mykson , Apr 1, 2017 :
    He just did that and it doesn't work either.
     

    #4
  5. Murman
    Jelly Bean Apr 1, 2017

    Murman , Apr 1, 2017 :
    You might have a corrupted download. Delete and download again.
     

    #5
    Siddhesh Sakpal 15 and remedy like this.
  6. smartmouse
    Eclair Apr 1, 2017

    smartmouse , Apr 1, 2017 :
    I checked both experimental and nightly with md5sum. They are ok.

    I wiped nothing. I just press on Install. Isn't enough?
    What is the easiest way to update TWRP?
     
    Last edited: Apr 1, 2017

    #6
  7. Mykson
    Ice Cream Sandwich Apr 1, 2017

    Mykson , Apr 1, 2017 :
    You can't dirty flash from COS to LineageOS.
    You have to wipe system, data, cache and dalvik cache, that's called a clean flash.
    After that all your app data and settings will be deleted (and of course your whole operating system).
    Make sure to backup everything.

    For TWRP you can use these methods: https://twrp.me/devices/oneplusone.html
     

    #7
    freddyabbes and smartmouse like this.
  8. pritster5
    Froyo Apr 1, 2017

    pritster5 , Apr 1, 2017 :
    GUYS.The fix for error 7 is simple. Error 7 ALWAYS comes when you have the wrong firmware installed. Make sure you have the right firmware and then try flashing.
     

    #8
    jensgilde likes this.
  9. smartmouse
    Eclair Apr 1, 2017

    smartmouse , Apr 1, 2017 :
    I was sure I could dirty flash from Android to LineageOS because a friend of mine did it.
    Anyway I wiped the following:

    Dalvik / ART cache
    system
    Data
    Cache

    and the flash completed with no problem (except a couple of command errors about "log"...)

    Thank you so much for your help!
     

    #9
    Mykson likes this.
  10. akssmax
    Donut Apr 1, 2017

    akssmax , Apr 1, 2017 :
    Just flash the new firmware before flashing lineage os zip. The link is mentioned inside the xda thread.
    It will resolve your problem.
     

    #10
  11. laguiam
    Donut Apr 1, 2017

    laguiam , Apr 1, 2017 :
    I had the same problem first update your recovery then do a full wipe then flash and thats how it worked for me
     

    #11
  12. smartmouse
    Eclair Apr 1, 2017

    smartmouse , Apr 1, 2017 :
    5 users replied to this thread... 4 replies are non-sense!
    Thanks to Mykson that is a very legit user.
     

    #12
    Mykson likes this.
  13. Habib.khan316
    Honeycomb Apr 2, 2017

    Habib.khan316 , Apr 2, 2017 :
    This makes you the 5th nonsense and me the 6th
     

    #13
    remedy likes this.
  14. remedy
    KitKat Apr 2, 2017

    remedy , Apr 2, 2017 :
    And me the 7th non-sense. You're very ungrateful.
     

    #14
    Habib.khan316 likes this.
  15. Murman
    Jelly Bean Apr 2, 2017

    Murman , Apr 2, 2017 :
    What a pompous, entitled thing to say. I will admit I assumed you knew what you were doing and clean flashed prior to creating this thread. My bad. But for you to call my response nonsense, when corrupt downloads actually happen is really lame and ungrateful.
     

    #15
    remedy likes this.
  16. konathala
    Cupcake Apr 5, 2017

    konathala , Apr 5, 2017 :
    First of all, I tried the same and got the same error. Experimental build will not work.
    Step 1. You have to wipe system, data, dalvik, cache.
    2. Flash CM14.1 and then flash lineage os 14.1 nightly build.
    3. Flash opengapps nano build.

    It has to work as it did for me.
     

    #16
  17. oneplus59
    Cupcake Apr 6, 2017

    oneplus59 , Apr 6, 2017 :
    I have a similar upgrade problem - I want go direct from cm11.0,nonrooted , factory reset, on Oneplus One to lineage 14.1. Is it possible? When flashing 2 different lineage builds
    I get the same error 7 something.like "MD5 could not verified"
    Im used to linux, but this is my first flash. I want a clean install. Do I format or wipe ? Install : what comes first: gaarp or lineage 14.1 help is very mush appreciated.
     

    #17
  18. Mykson
    Ice Cream Sandwich Apr 6, 2017

    Mykson , Apr 6, 2017 :
    Have you already unlocked your bootloader and installed TWRP? Have you unticked the "zip signature verification" in TWRP settings?
    If yes then:
    • Make a backup of all your data
    • Download the latest LineageOS build (0403) and the latest GApps package
    • Boot into recovery mode and wipe everything except internal storage (system, data, dalvik cache and normal cache)
    • Go to install and choose the LineageOS ZIP, after that you can add the GApps ZIP
    • Swipe to flash, wipe cache and reboot into your system
    This should work fine, if you're facing any problems feel free to ask.
     

    #18
    Habib.khan316 likes this.
  19. jcagara08
    Gingerbread Apr 6, 2017


    #19
  20. Dunnow
    The Lab - OnePlus 6 Reviewer Apr 6, 2017

    Dunnow , Apr 6, 2017 :
    Make sure you have latest twrp, proper downloaded rom and disable signature check, should be fine
     

    #20