9
Clock alarm no longer showing on lockscreen via OnePlus 9 Pro

  1. thexchosenone
    Eclair Dec 14, 2021

    thexchosenone , via OnePlus 9 Pro , Dec 14, 2021 :
    Ever since the update I've been running into a series of bugs like many others. Right now one of my concerns is that I can no longer snooze or dismiss alarms from the lockscreen.

    I have to turn on the phone, unlock the phone pull down the notification tray, find the alarm (because a firing alarm isn't moved to the top for some reason) and then I can expand that notification to dismiss it snooze.

    Anyone else with this issue. Anyone no how to fix/return to normal function.
    1639496534816.jpg

    1639496534855.jpg
     
    Last edited: Dec 15, 2021

    #1
  2. Aaron2017
    General Support Expert Award 2021 Dec 14, 2021

    Best Answer
    Aaron2017 , Dec 14, 2021 :
    The oxygen OS 12 update has proven to be very buggy, not for all but for most. This might be one of those bugs. Have you tried clearing cache and data of the clock app? You also may want to consider a factory reset for the rest of the problems, several users have said it helped them clear some bugs in the main update thread and the guys from XDA said the same in an article here (no guarantees though)
    https://www.xda-developers.com/factory-reset-oneplus-9-series-improve-experience-oxygenos-12/
    If you see no improvement there's always the option to roll back to Oxygen OS 11, you can find how to do so in the second pinned post of the main update thread here (post by swejuggalo)
    https://forums.oneplus.com/threads/oxygenos-12-for-the-oneplus-9-and-oneplus-9-pro.1524378/
    You can also send bug reports to OnePlus here if you want
    https://forums.oneplus.com/feedback
     
    Last edited: Dec 14, 2021

    #2
    Gor. and Caomhin like this.
  3. Nipu_1998
    The Lab Reviewer - OnePlus Nord 2T Dec 14, 2021


    #3
  4. E1639510215341
    Cupcake Dec 14, 2021

    E1639510215341 , Dec 14, 2021 :
    Have same issue as described in this post. Already wasted so much time thinking that my settings have messed up until doing search today. Why so many bugs are released to frustrate users and now what is the fix?

    I cannot get alarm on my lock screen to snooze or stop ,early morning and it is so tough to unlock phone then delete alarm and then create another one.

    Please help!
     

    #4
    G_reas_rith_yEHG and jagro2 like this.
  5. Aaron2017
    General Support Expert Award 2021 Dec 14, 2021

    Aaron2017 , Dec 14, 2021 :
    As i said in my first comment, Oxygen OS12 can be buggy for a lot af people.
    You can try Google's clock, as mentioned by another user above to see if that does work as it should, if not you can also give a factory reset a try. If a factory reset doesn't bring any improvement (should you wish to try a factory reset) you can roll back to Oxygen OS 11 until they release another version. Not an ideal solution i know, but many have already done so from what i can read in the main update thread. According to following article OnePlus stopped the roll out so they are aware of the bugs and are working on a new and hopefully improved version
    https://www.androidpolice.com/oneplus-is-pulling-its-oxygenos-12-update-for-the-op-9-and-9-pro/
     

    #5
    Gor. and E1639510215341 like this.
  6. E1639510215341
    Cupcake Dec 14, 2021

    E1639510215341 , Dec 14, 2021 :
    Ok thank you, will wait for the fix in that case. Glad that there is someone listening to us :)

    Meanwhile I will try to rollback


    Thank you so much for your prompt reply. I am sure help is on the way :)
     

    #6
    Aaron2017 likes this.
  7. Aaron2017
    General Support Expert Award 2021 Dec 14, 2021

    Aaron2017 , Dec 14, 2021 :
    You're welcome 👍
    Yeah, the main update thread is riddled with post about bugs, some major some small, but certainly enough for them to notice something was really wrong. Reviews from the tech sites weren't all that great either so it's in their best interest to come back with a seriously improved version. Let's hope it'll be sooner rather than later but they do need to take their time to make sure it's a worthy version to release. It isn't all bad though, there are several users who don't have bugs, at least no major ones, so there's definitely hope.🙂
     

    #7
    Gor. likes this.
  8. thexchosenone
    Eclair Dec 14, 2021

    thexchosenone , via OnePlus 9 Pro , Dec 14, 2021 :
    The issue is with the Google clock app.
     

    #8
    akhridian likes this.
  9. quini
    Eclair Dec 14, 2021

    quini , Dec 14, 2021 :
    Hi,
    I'm facing the same problem on both Oneplus and google clock after upgrading from OOS11... but I've tried Alarm clock Xtreme and it seems to work.
    Also tried deleting clock's app data with no luck... and am lazy to factory reset for now.
    Hope that helps.
     

    #9
  10. thexchosenone
    Eclair Dec 20, 2021


    #10
    Anzik likes this.
  11. Insane_Butcher
    Ice Cream Sandwich Dec 21, 2021


    #11
    Woodae likes this.
  12. Insane_Butcher
    Ice Cream Sandwich Dec 23, 2021

    Insane_Butcher , via OnePlus 9 Pro , Dec 23, 2021 :
    After doing all tricks it still doesn't work as intended. The clock app gets killed overnight I don't know but I did everything I could. Factory reset, cleared cache, turned off optimization in the battery settings... If it has something to do with AOD everything was literally turned on to make the clock display alarm options in the morning.
     

    #12
  13. Insane_Butcher
    Ice Cream Sandwich Dec 23, 2021


    #13
  14. thexchosenone
    Eclair Dec 27, 2021


    #14
    jagro2, Anzik and Helder_DAlmeida like this.
  15. Helder_DAlmeida
    Marshmallow Dec 27, 2021


    #15
    Gor. likes this.
  16. A1638947194414
    Cupcake Jan 7, 2022

    A1638947194414 , via OnePlus 9 , Jan 7, 2022 :
    I've noticed this happens whenever you charge the phone when the phone is locked. The charging animation shows up and after that, apps are unable to wake the screen.
     

    #16
    akhridian, Rodo20 and Anzik like this.
  17. Davidemuraro98
    Cupcake Jan 14, 2022

    Davidemuraro98 , Jan 14, 2022 :
    The problem also happens with the phone not charging. I do a full wipe, reflash os, wipe data/cache from the clock app, change all the settings, remove sleep optimization. Bug still here and not any new update release. This is ridiculous, i don't have time to do another full wipe to downgrade to os11.
     

    #17
    Rodo20 and jagro2 like this.
  18. thexchosenone
    Eclair Jan 19, 2022

    thexchosenone , Jan 19, 2022 :
    Not sure if it was the latest update or an update to the app itself but the alarms have returned to showing on my lock screen and i'm able to swipe them away or snooze them.
     

    #18
    fadthemisss likes this.
  19. lzs
    Gingerbread Jan 23, 2022

    lzs , Jan 23, 2022 :
    Did it continue to stay working after a day? I found, the alarms work after a reboot, but eventually (e.g. a day), the problem is back.
     

    #19
    ZordiaC, jagro2 and fadthemisss like this.
  20. weyyau
    Cupcake Jan 24, 2022

    weyyau , Jan 24, 2022 :
    I've managed to fix this by rebooting the phone and will further monitor for a day at least
     

    #20