207
[CLOSED][GUIDE] How to Unroot your OnePlus 3 / 3T and go back completely to stock

Thread Status:
Not open for further replies.
  1. calvinistmac Jelly Bean Nov 4, 2017

    calvinistmac, Nov 4, 2017 :
    To all:

    The guide is updated to version 3.0.4. The reason for the minor update is to reflect the new Open Beta versions.
     

    BillGoss and dsac23 like this.
  2. V1510932323610 Cupcake Nov 17, 2017


    G_Manohar_Tumbre_eewC likes this.
  3. pojr Jelly Bean Nov 17, 2017

    pojr, Nov 17, 2017 :
    You didn't finish your sentence


    When oneplus 3t will get oreo update, I will be very happy
     

  4. Bartnl Lollipop Nov 17, 2017


    remedy, pa5t1s, pojr and 1 other person like this.
  5. iafk_ Cupcake Nov 17, 2017

    iafk_, Nov 17, 2017 :
    Hi, I'm new to OnePlus devices. I've got a used OP3T A3010, and I understand that it's a China model. I flashed a ROM and TWRP on it, now I want to revert back completely to stock, with the stock recovery. I read that the other variants of the OP3T's recovery won't work and will brick the phone. Can I use the links in the OP?
    Cheers
     

  6. dhiresh_mehta Cupcake Nov 17, 2017

    dhiresh_mehta, Nov 17, 2017 :
    Hi

    I followed this guide word to word and was successfully able to get back to stock rom and recovery .
    I had unlocked bootloader previously and installed supersu. This was causing the safetynet test to fail, so I needed to go back

    Just a few observations I had along the way with regards to SafetyNet.

    1. When i had superSu installed - Safety net failed with response signature validation
    2. When i removed SUperSU - safetynet failed with basic integrity and cts profile mismatch
    3. When i removed SUperSU and flashed stock boot image (this option comes while doing full unroot) - Safetynet failed with only cts profile mismatch

    After that I tried flashin stock rom and stock recovery and data wipe, still safetynet would trip on cts profile.

    Only after I relocked bootloader SafetyNet tests passed.
    Hence I can say that unlocking bootloader will cause safetynet to trip.
     

    calvinistmac likes this.
  7. calvinistmac Jelly Bean Nov 19, 2017

    calvinistmac, Nov 19, 2017 :
    ANNOUNCEMENT:

    Before anyone asks me, this should work with the new stable Oreo update. I'll be updating the guide sometime within the next week.
     

  8. Disturber Honeycomb Nov 20, 2017

    Disturber, Nov 20, 2017 :
    Hey guys, didn't know unrooting is so popular! :)

    As a satisfied owner of 3T, i bought one for my girlfriend today as well. Only after performing factory reset, i noticed a pre-loading screen saying phone is unlocked, which led me to come here. While I'm not complete noob to PCs, I've never really messed with phones, thus I'm unsure about doing this unroot thingy. Instructions are very clear here(thanks for that) and i just need someone to take at picture of About phone, saying it's alright to start the process. I see there's a lot of warnings about bricking it etc, and I just want to make sure it is suitable for the process.
    [​IMG] [​IMG]
    Thanks for the help guys!
     

    calvinistmac and BeingIncog like this.
  9. calvinistmac Jelly Bean Nov 20, 2017

    calvinistmac, Nov 20, 2017 :
    Hey, glad you stopped by! You're on OOS 4.5.1 so you're safe to do the process. It's very hard to actually brick these devices so don't worry. The guide has been super refined since I first wrote it over a year ago and the process is much better now. If you run into any issues feel free to PM me on here. I may not get to you right away but I will get back to you. Have a good one!
     

  10. Toxic17 Honeycomb Nov 20, 2017

    Toxic17, Nov 20, 2017 :
    Thanks for the instructions. Worked straight away.
     

    calvinistmac likes this.
  11. calvinistmac Jelly Bean Nov 20, 2017

    calvinistmac, Nov 20, 2017 :
    Did you do my steps with the latest Oreo?
     

  12. Rednasnamsob Cupcake Nov 21, 2017

    Rednasnamsob, Nov 21, 2017 :
    Okay. Your guide is pretty straight forward. Thanks for that! But with step 7 when I boot into recovery it freezes when decrypting.... Any idea? Or should I tick forgot password before decrypting?
     
    Last edited: Nov 21, 2017

  13. midhunmurali007 Cupcake Nov 22, 2017

    midhunmurali007, Nov 22, 2017 :
    I flashed stock recovery image and then sideloaded the 4.5.1 stable rom for oneplus 3. I was earlier running paranoid android 7.3.1 . When rebooting after sideloading, it keeps on showing oxygen os boot animation logo. It ain't booting up. What should I do?
     

  14. wii747 Eclair Nov 25, 2017

    wii747, Nov 25, 2017 :
    What an excellent guide!


    Went back to stock to Oreo version of Oneplus image from Linageos.


    Taken lest then 30 minutes to get phone back to stock :)
     

    calvinistmac likes this.
  15. calvinistmac Jelly Bean Nov 26, 2017

    calvinistmac, Nov 26, 2017 :
    Ok great! We have 2 confirmations of it working fine with Oreo. I'll go ahead and update the guide! Thanks for your input and I'm glad it worked for you!
     

  16. calvinistmac Jelly Bean Nov 26, 2017


  17. calvinistmac Jelly Bean Nov 26, 2017

    calvinistmac, Nov 26, 2017 :
    Sorry for the long wait on a reply. You can tick forgot password, that should do it, but you'll lose your data. You can also do the following command from fastboot:

    fastboot format userdata

    That will nuke everything except /system.
     

  18. calvinistmac Jelly Bean Nov 26, 2017

    calvinistmac, Nov 26, 2017 :
    If you followed all of my steps to the letter it should be working for you. Can you detail out what you did before the phone just sat in an endless boot?
     

  19. Rednasnamsob Cupcake Nov 27, 2017

    Rednasnamsob, Nov 27, 2017 :
    No problem! already read in the OP that you have limited time... and I wasn't in any rush. Will give this a go tonight.
     

  20. iDLe76 Donut Nov 28, 2017

    iDLe76, Nov 28, 2017 :
    Thanks for the guide.

    I was looking to move my 3T back to stock OOS from Lineage 14.1. I was able to flash the stock recovery but I came across issues whilst trying to sort out the adb sideload. I could see my phone in the device manager on my Win PC but it had the exclamation mark so I suspect it was a driver issue. I messed with various drivers and tried to get it connected but I failed.

    I decided to gamble and did a local install from the stock recovery as I had a copy of the OS on the phone. The install was all good but my phone got stuck in a boot loop and failed to start up! I went back to recovery and did a factory reset and cleared all data and cache and it booted straight up without an issue. I locked the bootloader and got it all setup again and everything is good.

    Please follow the original guide and don't go rogue unless you are OK to deal with any resulting problems.
     
    Last edited: Nov 28, 2017