0

[CLOSED] Oxygen os 9.0.4 camera focus issue

Thread Status:
Not open for further replies.
  1. G_Aditya_G_evPB Froyo Jul 16, 2019

    G_Aditya_G_evPB, Jul 16, 2019 :
    My camera was working fine till the Oreo update, after upgrading to Pie, I'm having the focus issue. Since the camera unit was working fine till date before update to pie,I guess this isn't the issue with hardware. Anyone else having this issue? Please help me on this
     

    #1
  2. Paschfire KitKat Jul 18, 2019

    Paschfire, Jul 18, 2019 :
    It is a HW issue, it has nothing to do with the update.

    This is a commonly known and widely reported HW defect of 3/3T devices, the rear camera looses the ability to focus.

    Take or send your device into a OnePlus service center to have the rear camera module replaced.

    In the future pls use the forums search before creating unnecessary threads like this one.
     

    #2
  3. F1563694199852 Cupcake Jul 21, 2019

    F1563694199852, Jul 21, 2019 :
    How can it be a Hardware issue if it correlates with the Software? I have the same problem. The Hardware itself was working fine (since over 2 years) until a few days ago when I did the update to Pie.
    I really dont believe its a hardware Problem...
     

    #3
  4. Paschfire KitKat Jul 21, 2019

    Paschfire, Jul 21, 2019 :
    So you downgraded to OOS 5.0.8 to confirm this assumption? As I can almost guarantee the issue will still be present.

    As I've already stated this is a widely reported problem on these devices, OnePlus has also been aware of the issue for a very long time and at one point was replacing rear camera module on the 3/3T free of charge regardless of warranties.

    It becoming apparent to you only after upgrading to OOS 9.0.X, is nothing more than a unfortunate coincidence.
     

    #4
  5. Paschfire KitKat Jul 21, 2019

    Paschfire, Jul 21, 2019 :
    This is a confirmed HW related issue, has been for yrs now.
    Try using the forums search in the topic and you'd see this for yourself, SW has nothing to do with it.

    Here's an example, with a OnePlus Bug Hunter addressing the exact same issue.
    https://forums.oneplus.com/threads/closed-camera-issue.929489/
     

    #5
  6. Snodlander Cupcake Jul 22, 2019

    Snodlander, Jul 22, 2019 :
    Whilst there may have been a hardware issue with the camera itself that does not mean that there cannot be a later software issue too. Your logic and reasoning should extend at least that far.
    As it happens I too have experienced issues with delayed camera focussing as a result of upgrading my OP3 to Pie.
    My problem is not a HW issue.
    I can evidence this by simply installing Google Lens (other camera apps are available) Using the camera via Google Lens results in super fast focussing. Using the camera via the native Camera app results in very delayed focussing.
    Ergo the issue is with how the native camera app interacts with Android Pie.
     

    #6
  7. Paschfire KitKat Jul 22, 2019

    Paschfire, Jul 22, 2019 :
    Unfortunately you're still incorrect.

    This has also been confirmed previously, that GCam in some cases had slightly improved the focusing issue(s). It's still a HW related problem though.

    The focusing on my 3T you running OOS 9.0.4 is just as responsive as it was previously running OOS 5.0.8. If it was software related, every 3/3T running OOS 9 Pie would be affected and that's simply not the case.
     

    #7
  8. pablofg1978 Spanish POC Assistant Head Moderator Jul 22, 2019

    pablofg1978, Jul 22, 2019 :
    Indeed
    Please use the search before creating a new thread.
    Redundant thread closed
     

    #8
    Paschfire likes this.