Network/Connectivity [CLOSED][SOLVED]No Internet access over Tethering (wifi)

Thread Status:
Not open for further replies.
  1. megone90
    Donut Apr 27, 2017

    megone90 , Apr 27, 2017 :
    I open this thread because I found no solution in any other.

    From my OnePlus 3T (Oxygen 4.1.3 - Android 7.1.1) I connect to mobile network (4G), create my wifi hotspot with name and password, then I connect my laptop (with Windows 7 Enterprise sp1), it connects to wifi network but with the yellow "warning" triangle saying "No internet access" and I can't understand why!
    In the mobile connection profile I use, APN TYPE is set to "default,supl,dun".

    This is the first time it happens to me, never had such problem with other smartphones.
    So I made some trials:
    - change hotspot name, set open network (no pwd);
    - set only 2.4 GHz band;
    - connect to my hotspot from another smartphone;
    - set static DNS (Google DNS and OpenDNS;
    - ping from Prompt
    - installed every kind of android driver

    none of these trials worked. Result is always "connected but no internet".

    Considering that:
    My mobile sees my laptop in "connected devices (so prob. is not device manager), my laptop gains IP and subnet mask, my laptop goes on the internet with hotspots from other mobiles (so prob is not in laptop), USB tethering works (so prob. is not in mobile network)...so...
    what could be the problem? How to solve this? I'm sure is some config mistake on the mobile side.
    Is there someone who doesn't have this problem? (So we can exclude a bug in the OS).
    Please help me with this, I need wifi tethering so bad!

    Last edited: Apr 27, 2017

  2. megone90
    Donut May 4, 2017

    Best Answer
    megone90 , May 4, 2017 :
    @stevex I made not a stupid question, I was very specific on my problem and I argued with details technical trials and results, in order to point in the right direction. Other ways to perform this task (USB and BT tethering) are NOT like WIFI, cause they need drivers, cables, free USB port or BT device on laptop,...and then they are AD HOC (or Peer-to-peer) connections, while wi-fi is an Infrastructure connection. So you are off-topic too.

    By the way, I finally SOLVED the problem!!! :D:D
    After trying every kind of RNDIS driver and APN settings...I found the cause of the problem.
    Vodafone Italy does not include tethering in flat subscription (even if I have 3GB LTE data every month, I can't use mobile data for tethering and if I want to, I need to pay extra fees). That's why I changed APN settings (so I can make tethering using default APN for mobile data instead of APN for tethering, and Vodafone doesn't charge me).
    But it still didn't work because I needed to unlock this function through ADB shell.
    - Make sure you have installed USB and ADB drivers;

    - Activate Debug USB mode in developer settings and connect you OP3 to your pc with USB cable;

    - Open command prompt on windows and type " adb devices -l ".If it's the first time you do it, you should see your device with "unauthorized" attribute. Now on your mobile you should see a notification asking you to give permission to your PC for debugging, click YES. If you repeat the command "adb devices -l" now you should see something like:
    device product:OnePlus3 model:ONEPLUS_A3003 device:OnePlus3T

    - Type the following commands in command prompt:
    • adb shell (to enter in your mobile's shell)
    • settings get global tether_dun_required
    this command gives you the actual status of this setting (null, 1 or 0); (mine was null = never set)
    now you need to set this value to 0 (= don't notify tethering to provider) by typing:
    • settings put global tether_dun_required 0
    after this, reboot your phone and you're done.
    Now my tethering is working like a charm. This method is useful If you have, like me, a provider that prevents tethering service unless you pay extra fees.
    Hope this will help other ones.

    STAFF: please rename this thread adding the [SOLVED] tag. Thanks.

  3. Ramdinpuia
    Honeycomb Apr 27, 2017

  4. danellisuk
    Eclair Apr 27, 2017

    danellisuk , Apr 27, 2017 :
    After seeing your message, I realized this is something I occasionally rely on and have not tested yet. So I preceded to test this, and like you I noticed I could not access the internet. I then noticed the 4G icon was showing an exclamation mark. After this I disabled the wifi tethering and I had lost data access altogether. Rebooting the device did not get data back.
    Anyway, it turned out it was a service provider issue (EE in the UK), and I had not noticed this due to being connected to wifi. (When connected to wifi, the exclamation mark is not displayed on the 4G icon).
    Now I have 4G data working again (after raising a case with EE). I have tested wifi tethering and it is working for me.
    I am running OxygenOS 4.1.3.

    megone90 likes this.
  5. Damian_Larkin
    Honeycomb Apr 27, 2017

  6. megone90
    Donut Apr 27, 2017

    megone90 , Apr 27, 2017 :
    @danellisuk Thanks for you try! Ok, now we can be sure it's not a "universal" bug, maybe it depends on your provider/region.
    Could you tell me your APN profile settings?

    I did not specify in my post, my provider is Vodafone IT.

  7. whodatboi
    KitKat Apr 27, 2017

    whodatboi , Apr 27, 2017 :
    why not USB tethering so u can charge while sharing data?

    I do that and it works fine. haven't done it tho in 5/6 months

  8. danellisuk
    Eclair Apr 27, 2017

    danellisuk , Apr 27, 2017 :
    Under APNs, there are two selectable options on my phone. "EE Internet (everywhere)" and "Orange Internet (orangeinternet)".
    My phone has "Orange Internet" selected by default, and I have never touched these settings.

  9. megone90
    Donut Apr 27, 2017

    megone90 , Apr 27, 2017 :
    Why you guys keep replying a thread with other stupid questions?!
    - I don't like cables
    - I want to share internet access with more than one device
    - I have a high level mobile and just want it to make things that every other mobile can make!

    Hope this is enough. Now please, try to be helpful.

    Could you tell me what you have as "APN Type" in your "Orange Internet" profile?

    mkplus3t and Sergej.Nishpal like this.
  10. whodatboi
    KitKat Apr 27, 2017

    whodatboi , Apr 27, 2017 :
    dude it should be automatic. If anything messing with the APN could fck you deeper than you already are

  11. whodatboi
    KitKat Apr 27, 2017

    whodatboi , Apr 27, 2017 :
    that came out wrong. messing with the APN could dig u a deeper hole than your already in.

    backup your data, factory reset, and then try again. don't touch a damn thing. I bet you it'll work.

  12. danellisuk
    Eclair Apr 27, 2017

    danellisuk , Apr 27, 2017 :
    My APN type is default. I have never touched these settings. But just for completeness (and a chance to test the new scrolling screen shot feature), here are the full details:


    Someshwar_Guru likes this.
  13. Mathieu_DELPIERRE
    Cupcake Apr 28, 2017

    Mathieu_DELPIERRE , Apr 28, 2017 :
    Hi !
    I have quite the same issue (I cannot post by myself, I'm a new user, and i don't find an other appropriate conversation).

    Since the passage at OOS 4.1.3. I cannot use my tethering properly anymore. I have the warning triangle too in the notification zone.
    But, when I change the parameters in the tethering mode, from open network to passeword, or from passeword to open network, it work again, I don't have the warning triangle anymore and I can access to the internet...

    (I change my apn, but i don't think it is the source of the problem, because it worked before the update...)

    I don't know what to do me either (and i don't like cables too ! :) )

  14. megone90
    Donut May 3, 2017

    megone90 , May 3, 2017 :
    I tried changing from open to protected... Still nothing!
    It's frustrating :(

  15. stevex
    Eclair May 4, 2017

    stevex , May 4, 2017 :
    They might have been a bit out of theme but they were polite, and IMHO they might willing to help suggesting alternative ways to perform same task. I think you would have not take it so nicely if someone told you made a stupid question for a no problem...

  16. kirtiraj123
    Cupcake Jul 17, 2017

  17. xer0w
    Froyo Jul 29, 2017

  18. Jellyssimo
    Cupcake Sep 8, 2017

    Jellyssimo , Sep 8, 2017 :
    You're a living legend, sir!
    Though, I had a problem doing it through command prompt, as it didn't want to recognize adb.
    In my case what I had to do is go to where adb is located (Generally C:\Users\<User Name>\AppData\Local\Android\sdk\platform-tools\), open PowerShell right in the folder with Shift + Right Click and follow your steps from there. I had to use ".\adb *** " instead of just "adb *** ".

  19. Tiwi1990
    Ice Cream Sandwich Nov 5, 2017

  20. Tiwi1990
    Ice Cream Sandwich Nov 5, 2017

    Tiwi1990 , Nov 5, 2017 :
    this is a different problem; this thread is about phone hotspost issue and not about problem with wifi connection :D