Network/Connectivity [CLOSED][SOLVED]No Internet access over Tethering (wifi)

Thread Status:
Not open for further replies.
  1. U1510949384766
    Cupcake Nov 17, 2017

    U1510949384766 , Nov 17, 2017 :
    Normally we use APN type blank. It should be default for proper tethering & portable hotspot.
    Just need a little change in APN settings.
    Open APN and find field APN type.
    Write "default"
    Save your APN setting. Then reconnect other devices it will work.

  2. Enoch4asem
    Cupcake Jan 26, 2018

    Enoch4asem , Jan 26, 2018 :
    Simple netsh cmd command on your computer and it solves it. Visit the wordpress below for the steps.


  3. dlogictech
    Donut Jan 26, 2018

    dlogictech , Jan 26, 2018 :
    I Recently upgraded OTA to this release OnePlus 3T OxygenOS 5.0.1
    Ver 5.0.1 (2018-01-11)
    however I later found out that the WiFi Tethering didn't work.
    I tried the beta that was released after and it was not fixed.
    so I decided to go back to an earlier release to version OnePlus 3T OxygenOS Open beta 18 (2017-11-11) and WiFi Tethering worked.
    if OnePlus Software Developers are reading this post, please make this a higher priority, as I believe Tethering is a critical part of any android phone, especially if you have children or other devices that rely on WiFi Tethering. ( tablets, laptops, etc)
    I have tried all the latest releases and performed a factory reset on each release just to test the WiFi Tethering and all failed.
    See the below list and results:

    OnePlus3TOxygen_28_OTA_041_all_1801122317_b062313d22ec457f Open beta 21 ( FAILED )
    OnePlus3TOxygen_28_OTA_039_all_1712281506_cf0a07d83a1b4839 Open beta 20 ( FAILED )
    OnePlus3TOxygen_28_OTA_062_all_1712272248_d28093577f324959 Release 5.0.1 ( FAILED )
    OnePlus3TOxygen_28_OTA_060_all_1711160447_ac836d401bb44fe0 Release 5.0 ( FAILED )
    ??OnePlus3TOxygen_28_OTA_038_all_1711272148_5e0ea1454e8f4f0f Open beta 19 ( FAILED )

    OnePlus3TOxygen_28_OTA_037_all_1711111155_02782e159cb1402a Open beta 18 ( PASSED )

  4. McMilkeh
    Cupcake Jan 31, 2018

    McMilkeh , Jan 31, 2018 :
    Thank you! This fixed my issue!

  5. dlogictech
    Donut Jan 31, 2018

    dlogictech , Jan 31, 2018 :
    This is NOT solved for me. My Service Provider has NOT blocked tethering and the solution does not apply in my case.
    I have provided detailed steps to reproduce this issue and still there has been little or no response from OnePlus support.

    In any case, using adb shell to change the internal configuration of any phone is not a solution for most people. This should be done by OnePlus Software Developers.

  6. dlogictech
    Donut Feb 5, 2018

    dlogictech , Feb 5, 2018 :
    Hey Guys, Does anyone else have this problem? Please let OnePlus developers know about this bug otherwise it will not be fixed.

  7. Alessio Rosiello
    Cupcake Feb 15, 2018

    Alessio Rosiello , Feb 15, 2018 :
    Grazie davvero, stavo diventando matto con questo problema!

  8. G_Travis_Terrell_KRDg
    Donut Feb 15, 2018

    G_Travis_Terrell_KRDg , Feb 15, 2018 :
    Over in the Oneplus 3 thread, you'll find a post complaining of a very similar problem, except under Oreo. I've had terrible luck with my 3T's hotspot since upgrading to Oreo. I've tried every version released thus far. It always connects, but when it does, it sometimes doesn't have internet. When it does have internet, speeds max out at 0.5Mbps. I downgraded to Nougat, as none of the oreo versions have fixed the issue, and making a thorough bug report request, and explaining that I had flashed multiple versions of Oreo, as well as returning to Nougat and having success, I was told to try "clearing the cache." (Which I clearly had done--I'd reimaged the entire phone! Multiple times.)

    For me, USB tethering does work, and at normal speeds. (Update: It worked once. Speeds are slow again, now.)

    For what it's worth, I have tried non OxygenOS roms too, but all of the ones based on OxygenOS had the slow speed problem, and those not based on OxygenOS had the no connectivity problem.

    I do hope that we do not continue to get neglected. It seems clear that this is a software-related problem (at least in my case) FWIW, my carrier is T-Mobile. 20+Mbps consistently with Wifi on the old Nougat install. I also find myself wondering if Oreo on the 1+ 5 and/or 5T are plagued with this same problem. A 5T has been on my list to upgrade to for a while now, but I cannot upgrade to it if it does not have wifi hotspot, as I use it every day, multiple times a day. Heh.
    Last edited: Feb 16, 2018

  9. Rccrail
    Cupcake Jun 2, 2018

    Rccrail , Jun 2, 2018 :

    danellisuk likes this.
  10. F_Karl_Koza_NiZW
    Froyo Jun 2, 2018

    F_Karl_Koza_NiZW , Jun 2, 2018 :
    GREAT!!! I got this issue on my new OP6! Checking your advice I found APN Type was set to "default,supl". I changed it to "default" as you said, reboot and it WORKS! Ty for that :)

    mkplus3t likes this.
  11. Saurabh biyani
    Cupcake Aug 1, 2018

    Saurabh biyani , Aug 1, 2018 :
    try connect it to phone your mobile hotspot and see the result . I use my mobile hotspot everyday with my laptop (windows 10 ) .

  12. G_vamos_alania_TioS
    Cupcake Dec 9, 2018

    G_vamos_alania_TioS , Dec 9, 2018 :
    you are great. I had the same problem with vodafone sim(greece) but not with Cosmote sim (greece). I had searched everthing. My devices would connect to smartphone via usb tethering, bluetooth tethering and wifi tethering, but Vodafone would not share the connection through none of these ways, while cosmote did. Some complain it is for people to buy extra packages and pay for things that should be free. Same logic as blackberry OS, which resulted in its disappearance.
    Thank you very much again!!

  13. elanglois
    Lollipop Dec 21, 2018

    elanglois , Dec 21, 2018 :
    APN doesn't matter. If the phone has data, APN is fine.

    What IP does your laptop get? What ip does the phone get? Can you ping from the laptop (rules out a DNS issue)

    I'm guessing IP forwarding is not on, but you'll need root or someone from OnePlus to fix it.

  14. S1564819312070
    Cupcake Aug 3, 2019

    S1564819312070 , Aug 3, 2019 :
    Me too faced the same problem with my OP3T, and I started googling and followed as many mentioned but damn it didn't works.
    I started some research my on my phone and at last I found the solution and it's working now!!!!
    Goto Wi-Fi & internet select Private DNS and select Automatic option.... it works!!!

  15. Deactivated User
    Aug 18, 2019

  16. superplus
    Head Moderator Head Moderator Nov 9, 2020

    superplus , Nov 9, 2020 :
    Since the most recent person facing any issues has managed to resolve it well over a year ago, and there are plenty of helpful replies already, and this thread is mainly attracting spammers these days, I'll close the thread.

    Should you be facing this issue, and require more help than the posts currently listed, or require further help with any of them, please send a PM (e.g. using a (mobile) browser at https://forums.oneplus.com/conversations/add?to=superplus) and I can re-open the thread for this.