1
CM 12.* No Audio and Extreme Lag [Fix for a rare issue].

  1. aheuser
    Froyo Jun 23, 2015

    aheuser , Jun 23, 2015 :
    I have had an issue with my OPO for last few months, for which I could find zero help when searching the internet. Since I fixed it yesterday, in case anyone else is experiencing the same, I thought that I would share.

    The Issue: I could flash Oxygen OS with no issues, it would run smooth, but in my opinion, if I am going to run Android, it should be on an open source ROM, with minimal Google interference (not trying to start a debate, and am completely happy to accept that other's may feel differently). The problem is that when I tried to flash COS12 or CM 12.0 nightlies, the phone would boot up with little issue (other than taking a long time), but when I would try to adjust the volume, everything would slow to a crawl for a few seconds. If I tried to change a ringtone or notification sound, the phone would completely freeze, until I would force a reboot. In addition, if I tried a standard reboot (pressing the button and choosing "reboot") the phone would completely freeze, requiring a forced reboot. I tried wiping multiple times, fixing my file system, formatting /data, flashing again, trying different Gapps, and regardless, the result was always the same. After flashing the Oxygen OS ROM, things would again work, so I assumed this to be an issue with CM, albeit, one that only affects my phone. I decided to give CM 12.1 nightlies a try, and to my amazement, the sound worked, and I could select new ringtones, but after a reboot, the audio had disappeared. The funny thing was, after another reboot, it would return, and this behavior was consistent, each reboot required a second reboot for audio to return. Moreover, the boot time was very long, and the logcat had repeated messages about audio diver issues.

    The Fix [This will erase EVERYTHING on your phone]: I admit that if I did not work 70 hours a week, I probably would have come to this sooner, but it finally clicked that the phone worked with CM11S, and then I flashed Oxygen OS, which would not allow me to return to CM*. The problem was with Oxygen, and affected a programming layer lower than that of the ROM, which is why wiping, even from fastboot, was doing nothing. To fix this, I downloaded the CM11S ROM meant to be flashed from fastboot, extracted each file (except the recovery), and flashed manually (fastboot flash ...). After this, I booted to CM11S, had no issues, and so flashed CM12.1 nightly, and everything is working perfectly.

    If anyone else if having the same issues, I hope this helps.
     

    #1
    Majamulli likes this.
  2. Majamulli
    KitKat Jun 23, 2015


    #2
    aheuser likes this.