0
CM optimization for Asphalt 8

  1. heidou007
    Gingerbread Nov 21, 2014

    heidou007 , Nov 21, 2014 :
    Asphalt 8 doesn't run smoothly on my OPO, which is very weird because hardware-wise for OPO Asphalt 8 should not be a challenge at all. So I suspect the problem is the imperfect optimization of CM11S for games. Any other OPO owners experience lags in the game (or any other big games)?
     

    #1
  2. Craeshe
    Honeycomb Nov 21, 2014

    Craeshe , Nov 21, 2014 :
    Runs great on mine! But play with the detail settings within the game.
     

    #2
    aaron.hossain75 likes this.
  3. heidou007
    Gingerbread Nov 21, 2014

    heidou007 , Nov 21, 2014 :
    Did you mean that you lowered the quality in the settings?
     

    #3
  4. heidou007
    Gingerbread Nov 21, 2014


    #4
  5. kiranbandre
    Froyo Dec 9, 2014

    kiranbandre , Dec 9, 2014 :
    i am having same issue. its not playing smooth as i was expecting and i tried to compare it with lenovo vibe x2 which is playing it very smooth like 60fps and OPO is playing like 20-25fps

    Also same with video playback, video playback is also not that good when i compare it with Vibe X2 which i can accept but asphalt 8 should work perfectly.

    I am having another issue with camera, rear camera image size is around 1mb -2mb max which is very low, photos from front camera are more in size.


    Please fix this
     
    Last edited: Dec 9, 2014

    #5
  6. Carlosfer
    Ice Cream Sandwich Dec 9, 2014

    Carlosfer , Dec 9, 2014 :
    But is it running at 1080p? That's a lot to ask for any device.
     

    #6
  7. tttl
    Ice Cream Sandwich Dec 10, 2014

    tttl , Dec 10, 2014 :
    Asphalt 8 is running smoothly on mine. I haven't touched the settings at all.
     

    #7
  8. kiranbandre
    Froyo Dec 10, 2014

    kiranbandre , Dec 10, 2014 :
    Lenovo Vibe X2 also has 5inch 1080p screen which comes around 441ppi.

    i changed the governor and now its working perfectly smooth....got the answer for the camera also
     

    #8
  9. Hatha807
    Honeycomb Dec 10, 2014


    #9
  10. lassmat
    Jelly Bean Dec 10, 2014

    lassmat , Dec 10, 2014 :
    Whats ia Aspalt 8?
     

    #10
  11. kiranbandre
    Froyo Dec 10, 2014

    kiranbandre , Dec 10, 2014 :

    change the governor setting to conservative ..which is will improve gaming and battery backup also.
     

    #11
  12. tEf0o
    Jelly Bean Dec 10, 2014

    tEf0o , Dec 10, 2014 :
    I run nfs without any problems on 1920*1080.
    Game is old so...

    Do that game run ok on g3?
     

    #12
  13. jrgalang
    Froyo Dec 10, 2014


    #13
  14. heidou007
    Gingerbread Dec 19, 2014

    heidou007 , Dec 19, 2014 :
    I figured it out myself. First you need to turn on "developer" mode by pressing Build number in About phone for 7-10 times. Then go back 1 level, Performance -- Profile -- change from balanced to performance. This way the cpu clock is locked to the max and Asphalt 8 runs very smoothly for me.
     

    #14
  15. heidou007
    Gingerbread Dec 19, 2014

    heidou007 , Dec 19, 2014 :
    Could you elaborate on where the "governor settings" are? Thanks in advance!
     

    #15
  16. heidou007
    Gingerbread Dec 19, 2014

    heidou007 , Dec 19, 2014 :
    You are so lucky! The so-called "balanced" profile should have been smart enough to automatically bump up cpu clock frequency in games. Hope they fix this soon.
     

    #16
  17. DrRelik
    Cupcake Dec 19, 2014


    #17
  18. gam4rlucifer
    Cupcake Jul 4, 2015

    gam4rlucifer , Jul 4, 2015 :
    Okay.. I applied this trick... now game runs fine...
    1)Close the game
    2)Enable developer options
    3)Click on Enable 4x MSAA
    4)Go to performance settings and disable per app profile
    5)Now before starting the game change your profile to "performance"
    6)Start the game..
    I faced those minor lag issues in asphalt 8.. but now it plays perfectly fine. But ur fone may become a bit hotter and battery may drain a tad bit faster
     

    #18
    heidou007 likes this.
  19. Sunny-dk
    Cupcake Jul 4, 2015

    Sunny-dk , Jul 4, 2015 :
    Use ur processor at balanced to performance..may be it works
     

    #19
  20. 1ikhan
    Ice Cream Sandwich Jul 4, 2015

    1ikhan , Jul 4, 2015 :
    Forcing 4x msaa is a bad idea...
     

    #20