CM12S Lock Screen

  1. vuvuxela
    Gingerbread Apr 16, 2015

    vuvuxela , Apr 16, 2015 :
    Just from 11s to 12s and noted the first change is the lock screen.
    I used the pattern lock, in 11s, screen on and you can draw the pattern to unlock instantly.
    However in 12s, screen on and widget screen come first, you have to swipe upward and then see the 3x3 dots and unlock.
    One more step but really annoying.......

    Is there any way to disable that widget screen? thanks!

    Tricia24 likes this.
  2. CMYK
    Honeycomb Apr 16, 2015

    CMYK , Apr 16, 2015 :
    try and disable the lock screen widgets.

    i would try it but my phone doesnt lock until 30 minutes after sleep. hah

  3. tacticalpete
    Froyo Apr 19, 2015

    tacticalpete , Apr 19, 2015 :
    Hi, I am still waiting for the OTA update and I was wondering if CM12S has a lock screen similar to CM11S with all the shortcuts.

  4. jankarl
    Donut Apr 19, 2015

  5. matskb
    Honeycomb Apr 22, 2015

    matskb , Apr 22, 2015 :
    Plus you cannot disable it if you need PIN/pattern protection (e.g. due to Exchange security policies).

    So you will need to go through 2 lock screens instead of 1 in CM12s. I'm considering going back to CM11 because of the annoyance this causes, but before I do i'm hoping someone has a clever workaround.

    Tricia24 likes this.
  6. matskb
    Honeycomb Apr 22, 2015

    matskb , Apr 22, 2015 :
    Sadly, no... doesn't work! Only result is that the lockscreen only contains the unlock-widget (mid-bottom of screen), but you still have to make the extra swype before you can actually get to the PIN/pattern unlock screen.

  7. Cooklung
    Honeycomb Apr 22, 2015

    Cooklung , Apr 22, 2015 :
    I turned off the pattern lock because I found the two step process super annoying. Sucks. I hope they change this.

  8. matskb
    Honeycomb Apr 22, 2015

    matskb , Apr 22, 2015 :
    That is the fix of course, if you can. I can't due to Exchange security policy...

    It is really annoying indeed, the only relief I found so far is the fact that at least 3 other people on this forum found the same thing annoying.
    Oh, and 441 people on Google Code: https://code.google.com/p/android/i...=ID Type Status Owner Summary Stars&start=200

  9. Deactivated User
    Apr 22, 2015

  10. matskb
    Honeycomb Apr 22, 2015

    matskb , Apr 22, 2015 :
    This does not work for me if I want to maintain the Android PIN system (which is required by the Exchange security policy). The lock screen simply comes 'on top' of that (i.e. is displayed first, then followed by the empty Lollipop lockscreen, then followed by the PIN lock screen), so that brings the number of screens to work through up to 3.

    Of course such custom lock screen would work if you do not require the Android PIN security system!

  11. vuvuxela
    Gingerbread Apr 22, 2015

    vuvuxela , Apr 22, 2015 :
    Too bad to hear it's unable to fix....
    However after few days usage, i'm starting used to that one more swipe.....
    Anyway, hope CM can add an option for disable it.

  12. Deactivated User
    Apr 22, 2015

  13. CMYK
    Honeycomb Apr 24, 2015

    CMYK , Apr 24, 2015 :
    the recent OTA 17L update will update google play services to version 7.3.29 which is supposed to fix the smart lock trusted locations.

  14. CMYK
    Honeycomb Apr 24, 2015

    CMYK , Apr 24, 2015 :
    still didnt work with the latest google play services update.

    BUT i just did a "clear all data" for google play services, restarted my phone, and added my work location, force locked (except when kept unlocked by smart lock) and turned the display back on, and it worked!

    lets see how long this will work for!

  15. mrVazil
    Gingerbread Apr 25, 2015

    mrVazil , Apr 25, 2015 :
    I have smart lock disabled and I still have the two ******* lock screens, it is annoying as hell. I'm sad there isn't a solution yet :(

    Tricia24 likes this.
  16. matskb
    Honeycomb Apr 28, 2015

    matskb , Apr 28, 2015 :
    This is not seen as a 'problem', but as a 'function'. So I'm afraid there will not be any solution.
    I just downgraded (downdated? or whatever the opposite of updating is called:rolleyes:) to CM11, which felt like a bless.
    Granted, having to enter my PIN on every unlock is already annoying (no choice there unfortunately), but the extra swipe really messed it up for me.

  17. jayace
    Cupcake May 1, 2015

    jayace , May 1, 2015 :
    I'm using Smart Lock and added home and work as trusted locations so it won't lock if I'm at either of those locations. Works great so far.

    Also turned on on body detection, we'll see how that works. A little more risky so not sure about it yet.

  18. Laura_HH
    Cupcake May 1, 2015

    Laura_HH , May 1, 2015 :
    This may be a bit unrelated but is it me or is the 'insecure lockscreen' gone in CM12?

    I really liked that on my home profile i wouldn't have to put in the pattern code, and would only double tap, then see the clock and blurred wallpaper, and then i would swipe down to go to the homescreen.

    Now in my profiles i can only turn lockscreen totally off, or 'don't ask for pin or password' - which still asks for the pattern! Is there really no 'insecure lockscreen' anymore? :(

  19. atailmail
    Cupcake May 2, 2015

    atailmail , May 2, 2015 :
    The lock screen is a huge disappointment. We now have an extra annoying step, I don't want to swipe an extra time to get to the pattern screen. To make matters worse apps like Pandora do not display the playback controls on the lock screen like it did on CM11. Wasted three hours looking for a solution...

    Tricia24 likes this.
  20. unity_one
    Ice Cream Sandwich May 2, 2015

    unity_one , May 2, 2015 :
    Interestingly, I cannot set pin or pattern on my COS12 Lock screen. Only swipe is set even after I select and set pin, pattern or password. I didn't see this listed by @Indesit in his thread. Anyone come across this /have a solution?