22

CM13 bugs and annoyances

  1. xeind20 Donut Jan 3, 2016

    xeind20, Jan 3, 2016 :
    I didn't use PC to install it.

    Just download the .IMG file to your phone, go into Install in TWRP and install it. Reboot phone. Easy peasy.

    Edit: you'll have to hit images under install.
     
    Last edited: Jan 3, 2016

  2. doxter Cupcake Jan 3, 2016

    doxter, Jan 3, 2016 :
    I'm on 3012 build, downloaded latest nightly today (0301) but the system doesn't install it, gets stuck on 1+ logo screen at the beginning of the boot and does nothing (I waited there like 5 mins).

    Force Rebooted and phone starts up normally again. Re attempted update, same problem on every version I can download.

    Then I attempted to just boot into Recovery but again the same problem, phone stuck at 1+ logo screen. So I can't go into Recovery anymore now.

    Am I missing something here that changed while I was away on holidays....

    Oh, Happy New Year everyone!
     

  3. bikas Ice Cream Sandwich Jan 4, 2016

    bikas, Jan 4, 2016 :
    Seems that the zip you're using to flash was faulty. Try with the fresh zip file.
     

  4. saar_netzer Donut Jan 4, 2016

    saar_netzer, Jan 4, 2016 :
    with 20160104 loaded with TWRP 2.8.7.0.5 materialised (downloaded from here)
    Uptime 6hrs so far
    No GPS location issues
    No SIM issues
    I did flash the reboot fix though.

    .
     

  5. bikas Ice Cream Sandwich Jan 5, 2016

    bikas, Jan 5, 2016 :
    Good to know. Unfortunately, I cannot even flash this zip, don't know why
     

  6. Blenderite Cupcake Jan 5, 2016

    Blenderite, Jan 5, 2016 :
    On the latest (nightly from the 4th of January), data connection isn't working on mine.
     

  7. saar_netzer Donut Jan 5, 2016

    saar_netzer, Jan 5, 2016 :
    Which TWRP version are you using?
     

  8. bikas Ice Cream Sandwich Jan 5, 2016

    bikas, Jan 5, 2016 :
    It works fine for me at least for 5th Jan build.
     

  9. rkiwtir Ice Cream Sandwich Jan 5, 2016

    rkiwtir, Jan 5, 2016 :
    Reboot isn't fixed, I'm on today's build (5th) had two reboots so far
     

  10. bikas Ice Cream Sandwich Jan 5, 2016

    bikas, Jan 5, 2016 :
    I think it's because of faulty Gapps or some app, because I've 0 reboots since 20160101
     

  11. bikas Ice Cream Sandwich Jan 5, 2016

    bikas, Jan 5, 2016 :
    I've updated the list with new sections. As of now there are 4 open and major issues, out of which I don't know if sync works now as I cannot test it.

    If I left out any open bugs, let me know.
     

  12. matssa Ice Cream Sandwich Jan 5, 2016

    matssa, Jan 5, 2016 :
    Thanks for the update. For the fourth issue (quick unlock), they won't bring it back since they have security issues.

    GravityBox for MM (Xposed) has this option for those who need it.
     

    rkiwtir and bikas like this.
  13. bikas Ice Cream Sandwich Jan 5, 2016

    bikas, Jan 5, 2016 :
    I'll then update op accordingly.
     

    matssa likes this.
  14. kakarotoks Donut Jan 5, 2016

    kakarotoks, Jan 5, 2016 :
    Yes, I know, I just didn't want to risk having more issues (due to new image having new bugs). Either way, glad to hear it's finally fixed. I'm going to try latest nightly, and I'll confirm whether or not the issues I mentionned (wifi forget+proxy issues) are fixed now or not.

    EDIT: The "forget wifi" is fixed in 0105 but editing proxy settings are still an annoyance.
    If I edit network to set proxy from None to Manual, the Save button is disabled and it doesn't get enabled again even if I set the proxy settings. If I set the wifi password, the save button gets re-enabled though. I tried also setting proxy from Manual to None, and it also disables the save button.

    Thanks
     
    Last edited: Jan 5, 2016

  15. rkiwtir Ice Cream Sandwich Jan 5, 2016

    rkiwtir, Jan 5, 2016 :
    Faulty gapps? Which gapps did you use? o_O
     

  16. bikas Ice Cream Sandwich Jan 5, 2016

    bikas, Jan 5, 2016 :
    I used SLIM. But at the end of the day, I'm just guessing
     

  17. absolem Eclair Jan 5, 2016

    absolem, Jan 5, 2016 :
    Anyone knows if there is any way (xposed module maybe) to bring back the quick access ring with the three shortcuts which showed up when pressing the center navigation button and dragging it? it's been replaced with the long press now on tap which is a shame
     

  18. giaur500 Jelly Bean Jan 6, 2016

    giaur500, Jan 6, 2016 :
    There is simple fix, delete cm setup wizard.

    NOT TRUE. GPS is working. Only high accuracy mode is broken. Most important - don't mess your config with FasterGps. It won't help!

    Dude, please be serious. This is twrp bug, not CM.
     

  19. ivana90 Cupcake Jan 6, 2016

    ivana90, Jan 6, 2016 :
    i hate one plus x already
     

  20. bikas Ice Cream Sandwich Jan 6, 2016

    bikas, Jan 6, 2016 :
    That's very definition of being broken. You cannot say it's working if most effective part is broken. Btw out of 3, only one mode is working properly for people -either battery saving or device only. It'll be pain, if some app depends on High Accuracy GPS (Navigation, Ola, etc.)

    Also, if you know you're reported in wrong NTP by your phone, FasterGPS or manual method will most certainly help, and there's no side-effect to that as well.

    It's still an issue associated with CM and TWRP and I've never mentioned it as a CM bug. It has every right to be here, and btw people are still getting lost signal even with correct twrp. Where else do you like to put this issue anyway?
     
    Last edited: Jan 6, 2016