3
Network/Connectivity Constantly losing data connection

  1. fabfaw
    Cupcake Jan 1, 2017

    fabfaw , Jan 1, 2017 :
    I have been experiencing this same issue. I am on Cyanogen 13.1.2 which I updated back in October. However the problem only started a few weeks ago. I have previously tried selecting "Mobile data always active" in developer options but this made no difference. I have just tried the suggestion from G_Tunay so hopefully this will do the trick. I was hoping for a fix but now that Cyanogen has been discontinued I am not optimistic.
     

    #61
  2. fabfaw
    Cupcake Jan 11, 2017

    fabfaw , Jan 11, 2017 :
    This has made no difference. Any other suggestions... anyone???
     

    #62
  3. AkhilVaja
    Froyo Jan 11, 2017


    #63
  4. laurentperroteau
    Cupcake Jan 13, 2017


    #64
  5. Mykson
    Ice Cream Sandwich Jan 14, 2017

    Mykson , Jan 14, 2017 :
    I am on CM 14.1 on my One and that solution from the dev options helped me. Maybe you have to change to another ROM than COS 13.
     

    #65
  6. chaenel
    Cupcake Jan 15, 2017

    chaenel , Jan 15, 2017 :
    Same problem here, in France, with Free mobile operator.
    1.5 year ago, under CM12, I installed TWRP and rooted my phone. Thus my phone never had any OTA update. Everything was perfect, until 3 week ago. Same problem, phone is constantly loosing data connection. The only way to get it working again is to reboot the phone. Use the plane mode doesn't work, set the mobile data OFF/ON doesn't work, only reboot works.
    It's extremely irritating !!!
    Maybe is there a log file somewhere to try to understand what happen exactly !??

    I downloaded the full CM13 and installed it with TWRP (no need to wipe data, great !), hoping it would solve the problem, BUT IT DOESN'T SOLVE THE PROBLEM !!
    I wait the end of the last CM14.1 nighly build download to try (9 min left !), but I am 100% sure it will not solve the problem. Because the problem appeared without any update !! Maybe an hardware problem !? I don't think, because a simple reboot and connection works again for some time !?

    Was really happy with my OPO, but now this is no longer the case :(
     

    #66
    phb_fr likes this.
  7. chaenel
    Cupcake Jan 15, 2017

    chaenel , Jan 15, 2017 :
    With fastboot I flashed the modem firmare from message #20 of this topic. The base band version passed from di3.0.c6-00241... to .4.0.1.c7-00011...
    Before to update to CM14.1, I will see tomorrow if the problem is already here with this modem firmware
     

    #67
  8. MatDam
    Lollipop Jan 16, 2017

    MatDam , Jan 16, 2017 :
    Just did it! I cross my fingers! :)
     

    #68
  9. F_Vikrant_Singh_gUqY
    Cupcake Jan 16, 2017


    #69
  10. MatDam
    Lollipop Jan 16, 2017

    MatDam , Jan 16, 2017 :
    the work around suggested by @G_Tunay_Eren_Uyar_EUKy don't work with me.. neither fly mode or change LTE/3G/2G mode..

    ps. latest COS13.1 on board
     

    #70
  11. chaenel
    Cupcake Jan 17, 2017

    chaenel , Jan 17, 2017 :
    Some news from my side :

    - Tested the "Dial *#*#4636#*#*" solution, with COS13.0, no effect, same problem

    - Tested the radio firmware .4.0.1.c7-00011 from hydrogen OS, seems better, yesterday I had only one data loss / reboot. But I needed to reboot 5 times because no possibility to wake up the phone, double tap, power button, connect power supply, nothing ! And the phone rebooted by itself 2 times...
    Don't know if theses freeze and spontaneous reboot come from the radio firmware or from COS13.0, but the phone is still unusable

    - Yesterday evening, I formatted the system partition, and flashed Cyanogen Mod 14.1-20161225-NIGHLY-bacon, the radio modem firmware came back to DI3.0.c6-00241-M8974AAAAANAZM-1.
    For now (middle of the day), everyting is OK, I cross my fingers too....
    And Android 7.1.1 is great ! :)
     

    #71
  12. chaenel
    Cupcake Jan 17, 2017

    chaenel , Jan 17, 2017 :
    F**K !!!!! Same problem !!!!!! :mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad::mad:
    Is OnePlus have an official explanation about this problem !? Would be great !! OnePlus, are you here !? :confused:
     

    #72
  13. erwann.jeanneau
    Eclair Jan 17, 2017

    erwann.jeanneau , Jan 17, 2017 :
    I have nearly the same problem since a few weeks. I'm on Oxygen 3.1.4 and also have a a SIM card from the operator "Free". I keep on loosing the data connection. The signal strentgh is good but it does not display LTE, 3G or H besides it (I can receive/make calls but whenever I try to connect to the internet it says that I have no connection).
    In order to fix the issue I have to reboot to recovery and wipe cache. A simple reboot won't solve the issue.
    It's VERY annoying !!
     

    #73
    phb_fr likes this.
  14. louchoff
    Cupcake Jan 17, 2017

    louchoff , Jan 17, 2017 :

    Hi chaenel, i have the same strange problem as you (no firmware update and bug appeared with the new year, data connections lost and only reboot to get it back), i called Free mobile today they will send me a new sim card cause mine is old. I keep you informed... May be this is the problem... A defective sim card....
     

    #74
  15. TinouFR
    Cupcake Jan 18, 2017


    #75
  16. MatDam
    Lollipop Jan 18, 2017

    MatDam , Jan 18, 2017 :
    After two day i can say that the work around "enable mobile data always active" under developer options works.. (cross fingers!)
     

    #76
  17. Henri OnePlusOne
    Donut Jan 19, 2017

    Henri OnePlusOne , Jan 19, 2017 :
    Hi,

    Same problem here (like @chaenel), once more on french Free operator network, with my one running cyanogen OS 13.1
    I noticed something however :
    -> loosing data connection appends very most often when the phone is moving (on a long distance). When i take the train, it happends every 5 minutes ! It's like the phone can keep a connection open but can't catch a new one when the signal is comming from another antenna.

    Would be so great if OnePlus answer this !
     

    #77
    fabfaw likes this.
  18. Giuseppeb
    Cupcake Jan 19, 2017

    Giuseppeb , Jan 19, 2017 :
    same problem for me (in France with Free mobile, CM13.1) , I have tried different modems but it didn't' help. I have spent one week in Italy few weeks back and data connection over there was pretty stable ...
     

    #78
  19. smidge
    Cupcake Jan 20, 2017

    smidge , Jan 20, 2017 :
    I have had this problem during several periods with my OP1 since I got it (two-three years ago?). Also had the same problem with my previous Huawei so I'm thinking OnePlus are not the only ones to blame.

    Edit: Ok, so I googled some more and found very similar problems with both Nexus and iPhone. I'm going to try switching carrier for a while. I think there's a problem with some carrier's base station handovers.

    Historical fixes:
    I have never reinstalled/changed/bricked/geeked with the phone's OS. I have always used the latest update available from the phones automatic update. Used to be able to fix the problem by toggling Airplane mode, but now only reboot works. Problem used to seem to appear only on some base station handovers, but now it happens all the time with no apparent cause. Used to be able to fix it by setting the phone to use 3G only, but then the problem started coming up with the 3G setting too. So then I set it to LTE, and the problem disappeared for a while but now it has come back again. Problem has always seem to appear more often when wifi is active, so I almost always have wifi deactivated. Now I can't find any more setting combinations that work around the problem, so... I'm thinking I'll probably ditch OP/Android for a while and go Apple until I hear good news. Too bad.. I don't want an iPhone, but I really want a functioning data connection. Rebooting the phone several times a day sucks :(
     
    Last edited: Jan 20, 2017

    #79
  20. louchoff
    Cupcake Jan 21, 2017

    louchoff , Jan 21, 2017 :
    Hi all

    @chaenel @TinouFR @erwann.jeanneau ... and all other free mobile / OPO user i received yesterday a new sim card from free and (my old one was from 2012) that is the first time in 2 weeks that my phone keep 3G all the night.
    I keep you inform if this is a long term solution to the problem.
     

    #80