44
COS 12.1 YOG4PAS2QL Official Download Links (updated 28/10/2015)

  1. Tsugaru87
    Gingerbread Oct 28, 2015

    Tsugaru87 , Oct 28, 2015 :
    I read them.
    Just confirm if it is safe to flash via TWRP please.
    I'm on this version:
    Screenshot_2015-10-28-13-34-39.png
     

  2. Red_M
    Froyo Oct 28, 2015

    Red_M , Oct 28, 2015 :
    Then please read the thread properly. It may be advisable to use a translator if english is not your primary language.
     

  3. ronaksworld
    Jelly Bean Oct 28, 2015


  4. Vijit Nair
    Cupcake Oct 28, 2015

    Vijit Nair , Oct 28, 2015 :
    just a warning to everyone, do not download any zip files by MetalMask from android file host. He's the same guy who uploaded the fake 'signed' full zip file mentioned earlier in this post. I tried his fastboot zip and it crashed my os and i was stuck in bootloop with all my data and system files gone. I had to fastboot the previous OS to get it to work.

    The only silver lining is once you fastboot an OS it updates the system files, so you will not get the 'mismatched keys' error which some of you got while trying to flash the incremental ota through stock cyanogen recovery or twrp.

    The reason that some of you are not able to flash the ota as pointed out earlier, is that twrp does not update the system files when you flash a new rom , so when you try to flash an ota through twrp or stock cyanogen recovery it still considers the system as much older version and gives the mismatched keys error.

    so either wait for a full zip, or try flashing the ota through stock cyanogen recovery. if you get the mismatched keys error you will have to try and fastboot the prev OSin this case YOG4PAS1N0 (you will lose your data in the process so you will have to backup your files to a pc) and then flash the ota.

    hope this helps
     
    Last edited: Oct 28, 2015

    orange808 and mrsurehsisha like this.
  5. mrsurehsisha
    Honeycomb Oct 28, 2015

    mrsurehsisha , Oct 28, 2015 :
    Could you please elaborate "fastboot" step.:)
     

  6. Vijit Nair
    Cupcake Oct 28, 2015

    Vijit Nair , Oct 28, 2015 :
    it would be too long for me to explain it you properly and i don't want to make any mistakes and risk you bricking your phone but i can point you to the sources i used to do mine.

    download the required fastboot zip from here
    https://forums.oneplus.net/threads/mirrors-for-official-cyanogen-roms-ota-updates.141825/

    and then follow the instructions from here for fastbooting custom rom.
    http://forum.xda-developers.com/showthread.php?t=2788632

    the above link also has guides for fastbooting custom recovery like twrp or clockwork.

    hope this is useful
     

    johnkops and mrsurehsisha like this.
  7. ronaksworld
    Jelly Bean Oct 28, 2015

    ronaksworld , Oct 28, 2015 :
    Are you using Global device?


    Could it be due to difference in version as i seen two version of updates around.
     

  8. ronaksworld
    Jelly Bean Oct 28, 2015

    ronaksworld , Oct 28, 2015 :
    Step 1 :START+R
    Step 2: Type Notepad

    Step 3: Copy and paste the fallowing in it mentioned below,

    fastboot flash modem NON-HLOS.bin
    fastboot flash sbl1 sbl1.mbn
    fastboot flash dbi sdi.mbn
    fastboot flash aboot emmc_appsboot.mbn
    fastboot flash rpm rpm.mbn
    fastboot flash tz tz.mbn
    fastboot flash LOGO logo.bin
    fastboot flash oppostanvbk static_nvbk.bin
    fastboot flash recovery recovery.img
    fastboot flash system system.img
    fastboot flash boot boot.img
    fastboot flash cache cache.img
    fastboot flash userdata userdata_64G.img
    fastboot reboot

    Step 4: save the file as "fullflashopo.bat"
    Step 5: Right click and run as Admin or Simply run it

    Edit: Also you need to manually enter into fastboot for that turn off the phone then press Vol Up + Power and you can see fastboot on your screen., connect the phone before you run "fullflashopo.bat"
     
    Last edited: Oct 28, 2015

    mrsurehsisha and Vijit Nair like this.
  9. Nooblit
    Gingerbread Oct 28, 2015


    Red_M likes this.
  10. vkzod
    Eclair Oct 28, 2015


  11. Spannaa
    KitKat Oct 28, 2015

    Spannaa , Oct 28, 2015 :
    I did check my facts - maybe you should too!

    You're right that /system needs to be stock for the OTA to install but the bootloader DOES NOT need to be re-locked.
     

  12. Red_M
    Froyo Oct 28, 2015

    Red_M , Oct 28, 2015 :
    Please actually read the thread. I will NOT tell you why you're wrong but you are so, so, so wrong.


    Also, does it not make sense to any of you to NOT flash a ROM from a place that is literally just a file host. I have to say from a security stand point you've made a terrible choice and you should only install ROMs from trusted sources such as cyanogenOS or from the cyanogenmod team. Nothing that does not have the google approval should not be installed on your phone as it could contain ANYTHING including keyloggers (kiss those passwords goodbye), cookie stealers, MITM attacks or bad SSL certs.
     
    Last edited: Oct 28, 2015

  13. ronaksworld
    Jelly Bean Oct 28, 2015

    ronaksworld , Oct 28, 2015 :
    well not going through it going to busy again giving away invites :p btw thanks your link worked ;)
     

  14. Red_M
    Froyo Oct 28, 2015

    Red_M , Oct 28, 2015 :
    Then don't post.
     

  15. ronaksworld
    Jelly Bean Oct 28, 2015

    ronaksworld , Oct 28, 2015 :
    Well ye its true, about the edited part but does but sometimes people do make mirror of genuine links for faster download and the official links were down., and my guess it that some of us were desperate to get it.


    P.S: Also i did read about your post in page 13 when you posted the link and on page 14 you mentioned about xposed and how to track the zip path by replacing old to current.etc etc etc, so when i mentioned "not going through it as am busy" i ment about something i missed something you were trying to point about.

    and my message for you was about "Could it be due to difference in version as i seen two version of updates around." as there are two OTA's Update i had seen around., which gave me a conclusion that maybe CM started Region based OTA now.
     

  16. jedi.hung
    Cupcake Oct 28, 2015

    jedi.hung , Oct 28, 2015 :
    The full 2QL zip of your link works for me. Thanks.
    However, when I flashed xposed-v74-sdk22-arm.zip which was working before I flashed 2QL full zip, I failed to reboot the system. In other words, I got a softbrick. I had to go back to TWRP and install xposed-uninstaller-20150831-arm.zip to undo the xposed installation. Why?
    Which latest xposed do you install?
     
    Last edited: Oct 28, 2015

  17. Red_M
    Froyo Oct 28, 2015

    Red_M , Oct 28, 2015 :
    They released a slightly different version for the previous update. So there was 2 versions of the same ROM. The OTAs for either one do the same thing. there is no difference between ROMs for the Indian version of the OPO and global one. THEY BOTH FLASH THE SAME THING.

    Also those reasons are horrible, never flash something to your phone that you can't trust the source of.

    Please read the xposed threads on XDA from rovo89. When flashing a new ROM it is recommended to flash the uninstall then wipe DALVIK then the new ROM. I just allow it to boot for the first time to make sure the device boots at all. Once I have confirmed it has booted I reboot into recovery to then flash xposed again.

    http://forum.xda-developers.com/showthread.php?t=3034811

    But for you it looks like you might need to try the uninstaller for xposed again I guess then flash the newer version (v75-sdk22)
     

  18. anoopss
    Cupcake Oct 28, 2015

    anoopss , Oct 28, 2015 :
    Anyone have any idea why the Incremental OTA Zip is failing to install??
     

  19. Red_M
    Froyo Oct 28, 2015

    Red_M , Oct 28, 2015 :
    Maybe read the entire thread.
     

    Sambya Samanta and Spannaa like this.
  20. csathish33
    Cupcake Oct 28, 2015