177
COS 12 Master Fix Thread

  1. Porsse
    Cupcake May 4, 2015


  2. bklyn000
    Gingerbread May 4, 2015

    bklyn000 , May 4, 2015 :
    Thanks, this is great. I received the ota update for cm12s and ever since I've had wifi issues, it comes on and off all the time, the thing is, I don't know how to flash. Hopefully they would have an ota fix soon or like you said here, wait for instructions on static ip. Thanks
     

  3. urbantinhorn
    Cupcake May 4, 2015

    urbantinhorn , May 4, 2015 :
    Any updates from Cyanogen nutjobs for the DHCP issues? My phone cant connect to my office wifi and it eats up my mobile data all day! This is quite serious to me and wasn't having this issue in CM11S.
     

  4. alexfa13
    Cupcake May 5, 2015

    alexfa13 , May 5, 2015 :
    Sorry for bringing up this topic here but I'm an android noob, since I updated my OS to cyanogenmod 12 I noticed my battery drains fast and screen or google apps are the last concern, looks like the android OS and system are draining my battery so fast, what can I do?
     

    Attached Files:


  5. rochagam
    Honeycomb May 5, 2015

    rochagam , May 5, 2015 :
    I've been having the same issue... And there is a Bluetooth playback bug as well, it's like 2x as fast...it also happened when I had cm12 nightlies installed
     

  6. uawan
    Ice Cream Sandwich May 5, 2015

    uawan , May 5, 2015 :
    How can I go back to 11s without losing my data and everything ??
     

  7. soriful
    Gingerbread May 5, 2015


  8. soriful
    Gingerbread May 5, 2015


  9. drjs001
    Donut May 5, 2015

    drjs001 , May 5, 2015 :
    Creating a connection with a static IP is simple, as long as you are in a network that allows you to do so.
    In my network I have configure my router to reserve as specific IP for the MAC address of my OPO.
    Assume you are allowed to use a static IP .
    Go to Setting, select WiFi, pick the SSID of the network allowing staticIP. Type the pass phrase and tick "Advanced options". Now you get a few more lines. One says "IP settings" showing DHCP as default value. Tick the small triangle and select "Static". Now you have to fill a few fields.
    IP address: type the reserved IP address
    Gateway: auto filled, you may have to change if it is not .1
    Network prefix length: keep it (except you have configure your private network with a subnetmask different of 255.255.255.0)
    DNS 1: I changed it to the value of my gateway, because it is configure as the primary DNS server in my local network
    DNS 2: left as is, since DNS 1 will always answer
    Then tick connect.

    I don't know yet if these values are really presistent but at least it works for me as long as I'm in my home network.
     

    bklyn000 likes this.
  10. ExarEric
    Froyo May 5, 2015

    ExarEric , May 5, 2015 :
    I still suffer the WiFi issue, I've flashed both the WiFi fix and the modem fix. Although when flashing the WiFi fix TWRP doesn't like finish the install, but rather restarts TWRP. Nothing like the install of the modem-fix

    I'm quite new to flashing, but have unlocked bootloader, have rooted. Tried clearing both cache and Dalvik.
    As I'm on the university WiFi I can't go for the static fix.

    Any idea what to try?
    Any news on CM when they'll fix it?
    @indest

    Edit: I may have found a temporary fix, since it's most likely the 5GHz Band that causes the trouble you can chose to only connect using 2,4 in the WiFi>Advanced>Chose Band.
    It lowers my speed, but so far no connection issues.

    Edit 2: Nope, it's back. Disabling 5GHz did **** all to help. Still problem here :(.
     
    Last edited: May 5, 2015

  11. XMS3D0
    Eclair May 5, 2015

    XMS3D0 , May 5, 2015 :
    i must get my phone to work, no network, and the fixes rasrely help, i have been trying with the fix described for about since yesterday, all the time, i need my calls to work, i have important calls! is there a fix any soon or not ?
     

  12. lokesh3440
    Honeycomb May 5, 2015


  13. Dr. Indest
    Lollipop May 5, 2015

    Dr. Indest , May 5, 2015 :
    Since you are rooted:

     

  14. Dr. Indest
    Lollipop May 5, 2015

    Dr. Indest , May 5, 2015 :
    Did you reset your sim pin?
     

  15. slowhand
    Gingerbread May 5, 2015

    slowhand , May 5, 2015 :
    Yes, as I posted, the I've resorted to toggling the airplane mode to re-acquire wi-fi. I know it's not the most severe glitch experienced by OPO owners on this forum, but it's annoying that a phone as advanced as this one has a problem automatically connecting to saved wi-fi networks the same way every other wi-fi device I've ever owned has been able to do.
     

    bklyn000 likes this.
  16. drjs001
    Donut May 5, 2015

    drjs001 , May 5, 2015 :
    Hi indest,

    That is intersting: I can't find dhcpd at /system/bin .
     

  17. Dr. Indest
    Lollipop May 5, 2015

    Dr. Indest , May 5, 2015 :
    Cause by default, it does not go all the way down to /.... If you are using es explorer, you need to go to the root and not the sdcard folder.
     

  18. drjs001
    Donut May 5, 2015

    drjs001 , May 5, 2015 :
    Well, I'm using "Root Browser" and can see everything in the Linux based filesystem. I'm going to install a terminal app to run some find to see where it is located.
     

  19. XMS3D0
    Eclair May 5, 2015

    XMS3D0 , May 5, 2015 :
    how to reset it? you mean turn off and take it off and in again ?
     

  20. lparihar9
    Honeycomb May 5, 2015

    lparihar9 , May 5, 2015 :
    anyone checked slow motion video recording on CM12 ?

    I tried and there's no Voice in recording, also the video appears to be only in half screen.

    right now in office, will upload the video on reaching home to make the issue more clear.