14
COS12 and Exchange

  1. tobes
    Ice Cream Sandwich Apr 21, 2015

    tobes , Apr 21, 2015 :
    Possibly a server side policy? In my case it is not required. You may want to check with the administrator of your email server.
     
    Last edited: Apr 21, 2015

    #21
  2. jferraz
    Ice Cream Sandwich Apr 21, 2015

    jferraz , Apr 21, 2015 :
    I wasn't talking about email syncing. With email I have no problem, but the calendar only syncs 30 days back or so and there's no option to sync all the events. As far as I know that's a exhange/google problem.
     

    #22
  3. tobes
    Ice Cream Sandwich Apr 21, 2015

    tobes , Apr 21, 2015 :
    Sorry misread your message. You are right, there are no settings to control calendar sync afaik and events don't get synced if they are older than 30 days. Has anyone managed to do this with gmail or boxer?
     

    #23
    jferraz likes this.
  4. jferraz
    Ice Cream Sandwich Apr 21, 2015

    jferraz , Apr 21, 2015 :
    Using Nine I'm able to sync the whole calendar. Using Boxer or Gmail, no luck though...

    In the JIRA issue i mentioned above (https://jira.cyanogenmod.org/plugins/servlet/mobile#issue/BACON-3313) the assignee said this is a Microsoft/Google limitation (2 weeks or 30 days). Despite this, in 05Q I was able to sync the whole calendar using the default exchange account in CM11...
     

    #24
  5. blackscorpio
    Froyo Apr 23, 2015

  6. mikev717
    Cupcake Apr 24, 2015

    mikev717 , Apr 24, 2015 :
    I was having issues and downloaded the Outlook app in the play store and that worked. Also if you can log into your account on a pc check this area
    Outlook web app > options > see all options > phone > mobile phone

    Delete any listings of devices that you no longer use.
     

    #26
  7. loboent
    Cupcake Apr 30, 2015

    loboent , Apr 30, 2015 :
    I had no issues with the BOX powered email. It syncs email, calendar and contacts and no battery issue over the few days I have used it. I use google Inbox so the exchange/gmail was not an option for me.
     

    #27
  8. justinwen
    Cupcake May 1, 2015

    justinwen , May 1, 2015 :
    I did the same thing. You clicked on "Install Client Certificate" instead of "Next" button at the bottom of the screen. You don't have to install client certificate.
     

    #28
  9. tjb50
    Ice Cream Sandwich May 1, 2015

    tjb50 , May 1, 2015 :
    Under general setting of account.
     

    #29
  10. WXB
    Gingerbread May 1, 2015

    WXB , May 1, 2015 :
    Thanks!! with the apk file and gmail it worked!
     

    #30
  11. hohreinm
    Cupcake May 1, 2015

    hohreinm , May 1, 2015 :
    When adding a new Exchange Account, I have to provide a user certificate for authentication.
    This works fine in CM11.
    But now with CM12 I am not able to use my user certificate any more.
    I can install it, I can select it when the app ask for it (no matter if its Gmail or Boxer), but then I see a white screen and nothing happens.
    Someone with the same problem or any ideas how to solve this ?
     

    #31
  12. jamielennox
    Cupcake May 3, 2015

    jamielennox , May 3, 2015 :
    @hohreinm I'm having the exact same issue, as soon as i select a client cert i get directed to a blank white screen. If i press back it goes back to the settings page - with no cert selected.
     

    #32
  13. danzhu_woo
    Cupcake May 3, 2015

    danzhu_woo , May 3, 2015 :
    My boxer keeps saying the username or password incorrect when I try to setup a office365 business account. Anyone has the same problem?
     

    #33
  14. slockhart
    Cupcake May 3, 2015

    slockhart , May 3, 2015 :
    Great post, thank you. I tied both Nine and MailWise. I ended up going with MailWise. Nine looked nice, but it ONLY supports ActiveSync accounts. I have Hotmail (ActiveSync) and IMAP accounts that I would like to access from the same App.
     

    #34
  15. nandak
    Cupcake May 4, 2015

    nandak , May 4, 2015 :
    @hohreinm & @jamielennox I am having the exact same issue of white screen when trying to select a certificate. i have tried all clients (nine, mailwise, gmail) and still have this issue.
     

    #35
  16. hohreinm
    Cupcake May 4, 2015

    hohreinm , May 4, 2015 :
    @jamielennox & @nandak
    This makes the OPO useless for me. In first place I use it at work with Exchange.
    Is there already a bug report for this ? Anyone knows ?
    Maybe we should open a new thread for this ? Don´t want to highjack the great inital post.
     

    #36
  17. AndyNe
    Cupcake May 4, 2015

    AndyNe , May 4, 2015 :
    I have exactly the same issue with my OnePlus One A0001!
    I setting my corporate Exchange Server 2010 account and All boxes and sub-folders works fine, BUT since OTA Update to CM12.0-YNG1TAS17L I am unable to display the Calendar.
    On the previous version CM11 this worked fine.
     

    #37
  18. Wendal
    Cupcake May 4, 2015

    Wendal , May 4, 2015 :
    I am a total noob to the entire Android ecosystem, defecting from Windows Phone. However, this is a dealbreaker if I can't sync my contacts and calendar to my new phone. Can someone tell me how to install the APK to the phone, or point me to an existing link? Again, I'm a total noob and don't know anything about the rooting, wiping the memory, and all the other stuff I've seen. But I HAVE to have my hotmail calendar and contacts on this phone. Moving to a google account is NOT an option. Please help. Thanks!
     

    #38
  19. nandak
    Cupcake May 4, 2015

    nandak , May 4, 2015 :
    I got mine working finally with the native email. Try this... look for an app called 'Key Chain'... force stop it and then try to get your certificate. Hope this works.
     

    #39
  20. hohreinm
    Cupcake May 5, 2015

    hohreinm , May 5, 2015 :
    That did not work.
    As soon as I select to add my certificate, the com.android.keychain process starts again.
     

    #40