0
COS12, screen doesn't turn on with incoming calls

  1. kill3r_tadej
    Froyo May 5, 2015

    kill3r_tadej , May 5, 2015 :
    I just install the factory image for COS12. My screen doesn't turn on when I receive incoming calls. The ring tone will play but the screen remain turned off. I want the screen to turn on automatically with the incoming call dialer like kitkat or any other android version. so I can pick up the call. Any one else with this issue? How did you fix it?
     

    #1
  2. SomeSayImHandSome
    May 5, 2015

    SomeSayImHandSome , May 5, 2015 :
    uncheck proximity sensor check in settings
     

    #2
  3. Maquuuu
    Gingerbread May 5, 2015

    Maquuuu , May 5, 2015 :
    I have the same issue and this doesn't fix it. This only leaves the screen on when holding it next to your ear which is a really bad idea.
    It doesn't matter if it's on the table or in my pocket, it never turns on when receiving a call >.<
     

    #3
  4. SomeSayImHandSome
    May 5, 2015

    SomeSayImHandSome , May 5, 2015 :
    start from scratch. is all i could tell you
     

    #4
  5. Maquuuu
    Gingerbread May 5, 2015

    Maquuuu , May 5, 2015 :
    Thats not an option for me, I rather settle with having to wake the phone up then :(
     

    #5
  6. SomeSayImHandSome
    May 5, 2015

    SomeSayImHandSome , May 5, 2015 :
    why what is the big deal? i don't understand people and phones. they never want to wipe them lol
     

    #6
    Maquuuu likes this.
  7. Deactivated User
    May 5, 2015


    #7
  8. kill3r_tadej
    Froyo May 5, 2015

    kill3r_tadej , May 5, 2015 :
    I did same.
     

    #8
  9. return.of.octobot
    Jelly Bean May 5, 2015

    return.of.octobot , May 5, 2015 :
    Can you elaborate on why it's not an option? If you managed to manually install the factory image, than reflashing shouldn't be too much of a hassle.

    Also, when you say factory image, that implies that you flashed the system files via fastboot, did you wipe your previous OS before doing so?

    I believe the problem you're describing occurs when CM11S modem/radio files are paired with CM12/COS12 operating systems. Is it possible that you didn't flash the COS12 radio files?

    Yeah, exactly what I thought. You can't dirty flash COS12 over CM11 without performing a proper wipe first. The CM11S modem does not play nicely with others, this is what's causing your problems. It's not a bug, you just have remnants of CM11S interfering with the functionality of 12.
     

    #9
    TMess likes this.
  10. Deactivated User
    May 5, 2015


    #10
  11. return.of.octobot
    Jelly Bean May 5, 2015

    return.of.octobot , May 5, 2015 :
    Read my updated post above, the other two I quoted are experiencing the same issues as you because they tried to dirty flash COS12 on top of CM11S without first performing a wipe. You most likely did the same thing.
     

    #11
  12. xtenpeben
    Froyo May 5, 2015

    xtenpeben , May 5, 2015 :
    I find that it takes a while for the screen to turn on. There's got to be a setting somewhere that does this lol.

    I pull it out of my pocket and then 2 seconds later the screen turns on.

    It might not be recognizing that it's already out of the pocket?
     

    #12
  13. blikie
    Gingerbread May 5, 2015

    blikie , May 5, 2015 :
    Yes u can dirty flash over cm11s.
    i have done it and went flawlessly till the battery drain came up recently.
    that bug is probably twrp which steve mentioned about long ago.
     

    #13
  14. SomeSayImHandSome
    May 5, 2015

    SomeSayImHandSome , May 5, 2015 :
    oh you dirty flashersssssss. to truth comes out. this is why people have issues ALL the time. WIPE your damn phone lazy bastards
     

    #14
    pbergonzi and return.of.octobot like this.
  15. blikie
    Gingerbread May 5, 2015

    blikie , May 5, 2015 :
    the only issue i have is how Google cant fix a stupid play service drain.
    don't know what ur blabbing about.
     

    #15
  16. SomeSayImHandSome
    May 5, 2015

    SomeSayImHandSome , May 5, 2015 :
    that's good for you. go to 5.1.1 nightly and your problem will be fixed. bc google did fix it. idiot
     

    #16
  17. locklear308
    Ice Cream Sandwich May 5, 2015

    locklear308 , May 5, 2015 :
    Well it isn't like windows where you can just move it all to your 2nd SSD :cool:
     

    #17
  18. blikie
    Gingerbread May 5, 2015

    blikie , May 5, 2015 :
    i bet u think of urself as a proud and arrogant ***** *********.
    idiot what if i dont want to go nightlies. thats my choice to make.
    also what if i want to experiment with it. idiot. i have it flashed nandroid but i dont want to go there. idiot.
     

    #18
  19. return.of.octobot
    Jelly Bean May 5, 2015

    return.of.octobot , May 5, 2015 :
    I'm saying dude, not to get into another debate with you, but this is what I mean when I say that a lot of the 'bugs' people are experiencing with COS12 are a result of shoddy flashing.
     

    #19
  20. SomeSayImHandSome
    May 5, 2015

    SomeSayImHandSome , May 5, 2015 :
    but people tell me i am an idiot :D
     

    #20