4
COS13 update does not work for encrypted phones

  1. franman77
    Eclair Apr 12, 2016

    franman77 , Apr 12, 2016 :
    Hi,

    it's Groundhog Day again :confused:

    As various posts in this forum confirm updating an encrypted device to COS13 does not work. We already had this problem with older Cyanogen updates. People from Cyanogen what are you going to do about this?

    Please share your feelings and thoughts concerning this issue here.

    Krgds,
    franman77
     

    #1
  2. anbog
    Donut Apr 12, 2016

    anbog , Apr 12, 2016 :
    What happens when you try to install the update on an encrypted phone? My OPO is encrypted but I didn't get the update yet - would like to know if I should just leave it alone to avoid messing everything up or if it's safe to try installing it.
     

    #2
  3. rarog
    Lollipop Senior Moderator Apr 27, 2016

    rarog , Apr 27, 2016 :
    No problems on my phone. But it was encrypted under COS12.1 (2K1) lately. Did you encrypt your OPO using CM11S or COS12? There were similar problems, when COS12 came out.
     

    #3
    OALEXANDER likes this.
  4. Othz
    Cupcake Apr 27, 2016

    Othz , Apr 27, 2016 :
    Wish I read this post before I did the update I just did... Anyone found a way to get into the phone again?
    Mine says wrong pin code...
     

    #4
  5. ninjasumit
    Ice Cream Sandwich Apr 27, 2016

    ninjasumit , Apr 27, 2016 :
    @cyanogen
     

    #5
  6. rarog
    Lollipop Senior Moderator Apr 27, 2016

    rarog , Apr 27, 2016 :
    Flash COS 12.1 via Full OTA in recovery. Had you encrypted your phone back with CM11S?

    I fear it is a regression of this bug: https://jira.cyanogenmod.org/browse/BACON-3346
     

    #6
  7. Othz
    Cupcake Apr 28, 2016

    Othz , Apr 28, 2016 :
    Thanks rarog,
    Anywhere I could find a step by step guide to do this?
     

    #7
  8. rarog
    Lollipop Senior Moderator Apr 28, 2016

    rarog , Apr 28, 2016 :
    I don't know of a general guide.

    Get this: http://builds.cyngn.com/factory/bacon/cm-12.1-YOG7DAS2K1-bacon-signed-d347503447.zip
    This is the full OTA of the latest COS12.1.

    If you don't have adb on your system yet, get this package: http://forum.xda-developers.com/showthread.php?t=2317790
    It installs adb and fastboot tools and is so far the mos easy tool to use, you don't have to install full Android SDK, to have the same tools then.

    Boot to recovery, go to "Apply update" and then to "ADB sideload".
    On your computer start the adb console (it's the normal Windows cmd but with paths set, so you can run adb from anywhere, while in console), navigate to the folder, where you have downloaded the file or just use the full path to the file.
    Start this command: adb sideload cm-12.1-YOG7DAS2K1-bacon-signed-d347503447.zip

    This will push COS12.1 to your phone, the recovery will apply it and you will have a running system for now.


    P.S.
    You still didn't answer my question, when you did your encryption, was it, when you had CM11S installed yet or with COS12?
     

    #8
  9. rarog
    Lollipop Senior Moderator Apr 28, 2016


    #9
  10. Othz
    Cupcake Apr 28, 2016

    Othz , Apr 28, 2016 :
    I did it sometime in Dec-15 I think, I've been updating whenever updates has been available. So not sure which version that would be.
    Also I'm not sure about what you're after with the question above, all I know is I used a 4 digit pin for the encryption.
    Thanks again for your help.
     

    #10
  11. rarog
    Lollipop Senior Moderator Apr 28, 2016

    rarog , Apr 28, 2016 :
    In that case you were on COS12 all along, my first assumption of the root of the problem was wrong. There seem to be several problems with encryption, unfortunately Cyanogen's JIRA site doesn't load properly currently, so I can't read all comments of the bug report.

    You're welcome anyway!
     

    #11
  12. Othz
    Cupcake Apr 28, 2016

    Othz , Apr 28, 2016 :
    Bit of an update from my side, not sure I had the USB Debugging enabled before, either way My phone is not showing up as anything but "Marshall London bootloader interface" in the control panel. No mass storage device.
    An other question, will this way save the encrypted data on the phone? Otherwise I guess I could just go with a factory reset...
     

    #12
  13. rarog
    Lollipop Senior Moderator Apr 28, 2016

    rarog , Apr 28, 2016 :
    Uninstall the Marshall drivers and install those of OP2, then it should work with ADB. Factory Reset would also make your device work, but all data will be lost. If ADB works and you sideload COS12.1 again, you should be able to access all the data.
     

    #13
  14. Othz
    Cupcake May 1, 2016

    Othz , May 1, 2016 :
    Thanks again, now it works fine again with just like before! Tricky part for me was to find and install the drivers, they were not listed under google as in the "Howtos" I've seen but under google-something.
    Just one final question, is it now safe to update from this version? Or would the same thing happen again?
     

    #14
  15. rarog
    Lollipop Senior Moderator May 1, 2016

    rarog , May 1, 2016 :
    I'm not sure. You could just try. If it's booked again journey can always go back to COS12.1 again.
     

    #15
  16. Cypherdiaz
    Cupcake May 1, 2016

    Cypherdiaz , May 1, 2016 :
    I did the above to restore back to 12.1 but when the adb is updating the image, it stops at 47%. Is this normal or should it process 100%. ADB does report total xfer: 1.00x.
     

    #16
  17. maclag
    Froyo May 1, 2016

    maclag , May 1, 2016 :
    I didn't watch the progression when I did it, but it ended sooner than I thought, so maybe it's fine, or you can try again to be sure.
    Please come back and report, even (especially!!) if it ended up being fine!
     

    #17
  18. Cypherdiaz
    Cupcake May 1, 2016

    Cypherdiaz , May 1, 2016 :
    I tried it a number of times and even downloaded the 12.1 OTA zip again but no good. Kept stopping at 47%. I decided to do a fastboot reinstall and start again with 12.1.

    Are there fixes for the issues in v13 yet as I did see something about a small OTA update?

    For reference my original issue was that due to privacy settings Google Play requested phone call access and this hung the phone. On reboot the phone would hang within 5 seconds of getting onto the "desktop". Lesson learned for me, backup your phone!
     

    #18
  19. rarog
    Lollipop Senior Moderator May 2, 2016

    rarog , May 2, 2016 :
    It is normal. Because the system partition is only filled by 47%. So the rest is just empty and not transferred.
     

    #19
  20. Cypherdiaz
    Cupcake May 2, 2016

    Cypherdiaz , May 2, 2016 :
    Thanks for the confirmation. So it must have been something else causing the boot to fail.
     

    #20
    rarog likes this.