3
Delayed Notifications

  1. Davedam
    Cupcake Jan 19, 2018

    Davedam , Jan 19, 2018 :
    Hello everyone. First of all I'm not sure if this is a common problem or if it's just me.
    When I open whats app for example I get my notifications when opening, not when they actually arive.
    Is there any setting that influences the notifications?

    Greetings
     

    #1
    superchris72, Jassijee and adi_tanwar like this.
  2. joshi.rohya
    Donut Jan 19, 2018

    joshi.rohya , Jan 19, 2018 :
    Hello,

    yes I've got the same issue. I don't see any notifications from WhatsApp till I open it and then all of em start popping in respective chats.
    I checked if it's notifications are blocked, and it's permissions but all seems good. NOT clearing it from recent apps doesn't help as well.

    RJ
     

    #2
    Davedam likes this.
  3. Davedam
    Cupcake Jan 19, 2018

    Davedam , Jan 19, 2018 :
    @RJ Okay that kind of calms me down in terms of maybe my phone is broken or smth. Looks like it's a software problem or setting then.
     

    #3
  4. pimmytizzle
    Cupcake Jan 19, 2018

    pimmytizzle , Jan 19, 2018 :
    is battery optimization enabled for those apps? Could be stopping notifications coming though?
     

    #4
  5. SoraFire
    Donut Jan 19, 2018


    #5
  6. Oscar_hey
    Eclair Jan 19, 2018


    #6
  7. Davedam
    Cupcake Jan 20, 2018

    Davedam , Jan 20, 2018 :
    Okay so i turned off the battery optimization for WhatsApp, let's see if that will fix the problem. I will report.

    I couldn't find any settings for the game mode. I didn't turn it on in the first way so I think that should be disabled.

    And the DND mode isn't activated either.

    When that problem occured I didn't even get push notifications. Messages would load up when I opened WhatsApp. They didn't inform me by tone or vibrations.

    Dave
     

    #7
  8. Gaurav7
    Cupcake Mar 26, 2018

    Gaurav7 , Mar 26, 2018 :
    Okay , I was experiencing the same problem with Snapchat and Instagram . I think I have found the solution for it

    Go to Settings->Notifications->That particular app-> and tick the Override do not disturb option .

    This solved my issue , hope it solves yours as well!!
     

    #8
  9. G_Andrei_Podgornai_TMPe
    Cupcake Oct 29, 2018

    G_Andrei_Podgornai_TMPe , Oct 29, 2018 :
    My problem was that i had some delayed notification on the eartquake warning system that is using telegram. After some tests, i found out 2 causes/solutions (On android 9):
    - settings > battery > battery optimisations > disable optimisations for that app
    - settings > battery > battery optimisations > 3dots button on top > advanced optimisations > sleep standby optimisations = disabled

    Before i got my messages between 5sec and 2mins...now it's instant. The problem was only on wifi.
     

    #9
    harnbak likes this.
  10. anasanrodri
    Cupcake Nov 6, 2018

    anasanrodri , Nov 6, 2018 :
    Hello everyone. I have the same issue here, and I have already disabled all the "optimization battery options" both in the specific app and in general. I'm still not receiving my notifications until I open the app. Any other tips??

    Thanks,
    Ana.
     

    #10
  11. Cannothas
    Froyo Mar 8, 2019

    Cannothas , Mar 8, 2019 :
    I'm having the same issue, except the problem is in Gmail. Besides the issue where Gmail's setting keeps being ticked back to fetch every 30 mins on my exchange accounts, Gmail's notifications are delayed, where (when it's working) my exchange notifications are not. I use a gmail account for an emergency VM response system at work, and the 2-5 minute delay is unacceptable. I don't want to have to use a 3rd party email app because Gmail's integration in Android is best, but when I'm on call, a 5 minute delay for being notified is too long. Gmail is a system app, and none of the battery optimization settings are available on it.
     

    #11
  12. Maninder Sareen
    Donut May 1, 2019

    Maninder Sareen , May 1, 2019 :
    I have this problem for one third party app, if s reen is on I get instant notifications . Else delayed I have have kept all battery settings as per above threads
     

    #12
  13. ibuksh
    Cupcake Aug 6, 2019

    ibuksh , Aug 6, 2019 :
    I have had this issue with 6T with Viber. Have to open the app and then the notifications start coming up. Until then, no idea how many messages have come.
    I have changed the Wifi sleep policy to always keep Wifi On. Also turned off Battery Optimisation for Viber. Turned on Unrestricted Data usage for the app in the app settings. Still to no avail. Has OnePlus or anyone else been able to resolve this issue?
    Sometimes also doesnt connect to my car's bluetooth automatically. I have to double tap to wake up the phone and then can see the connected icon on my car's stereo in a few seconds.
    Seems like a deep sleep mode when phone isnt used for a specific period of timeSeems like a deep sleep mode when phone isnt used for a specific period of time.
     

    #13
    Maninder Sareen likes this.