2
Guide Detect OnePlus2 in Ubuntu in MTP mode

?

Did this method work for you?

  1. Yes

    43.8%
  2. No

    25.0%
  3. Partially

    31.3%
  1. nirmik379kale
    Gingerbread Sep 14, 2015

    nirmik379kale , Sep 14, 2015 :
    So if you have connected OnePlus 2 to Ubuntu, you will notice that you can only see "OnePlus Drivers" as mounted but you cannot access the internal memory using MTP, although ptp works!

    So here is what you need to do to make it possible

    1. Enable Developer options in Settings
    2. Enable ADB ( this needs to be enabled else, mtp doesnt work )
    3. Open a terminal window and follow this :
    - we will edit 2 files and add some lines in them. My preferred editor is vim. you may use nano / emacs etc.

    COMMAND :

    sudo vim /lib/udev/rules.d/69-mtp.rules

    ADD LINE :

    ATTR{idVendor}=="2a70", ATTR{idProduct}=="9011", SYMLINK+="libmtp-%k", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

    save and exit

    COMMAND :

    sudo vim /etc/udev/rules.d/51-android.rules

    ADD LINE :

    ATTR{idVendor}=="2a70", ATTR{idProduct}=="9011", MODE=”0666"

    save and exit

    COMMAND :

    sudo service udev restart

    Now disconnect and reconnect your phone, you will have "Android Device" as the mtp device.

    If you still cannot see, reboot and try to see if the device is now visible!

    Also, Thakyou to @Alvie for pointing me to the right direction!

    Thankyou!
     
    Last edited: Sep 14, 2015

    #1
    aenews and Seferi like this.
  2. ppod
    Jelly Bean Sep 14, 2015


    #2
  3. nirmik379kale
    Gingerbread Sep 14, 2015

    nirmik379kale , Sep 14, 2015 :
    coz its not the preferred os for a lot of people! Like me, who hate windows!
    anyways, its personal choice! :D
     

    #3
    aroblu94 and otto2 like this.
  4. ppod
    Jelly Bean Sep 14, 2015

    ppod , Sep 14, 2015 :
    Why do you hate windows, are you one of those OSists?
     

    #4
  5. nirmik379kale
    Gingerbread Sep 14, 2015

    nirmik379kale , Sep 14, 2015 :
    i would rather prefer to not have a debate about it here... to keep the thread clean you know.. :p
    but in short, ive tried a lot of times, to use windows, but the i just hate the UI ( vista / 7 / 8 / 10 ). and i like opensource, linux, comandline ;)
     

    #5
  6. ppod
    Jelly Bean Sep 14, 2015

    ppod , Sep 14, 2015 :
    I'd love to see you edit a photo on the commandline, can you do a video and show me. :)
     

    #6
    nirmik379kale likes this.
  7. nirmik379kale
    Gingerbread Sep 14, 2015

    nirmik379kale , Sep 14, 2015 :
    Linux is much more than command line! had decided to not reply, but just so that you dont remain deprived of knowledge, i decided to, There is GIMP, Inkscape, and a lot of other tools to do this. I think people who dont know stuff, shouldn't really comment on stuff like this.
    Wishing you a happy life with windows! :D

    And lets stop this childish feud here :)
     

    #7
  8. Alvie
    The Lab - OnePlus 5T Reviewer Sep 14, 2015

    Alvie , Sep 14, 2015 :
    Hey! Linux / Ubuntu are proper OSes! They are free and open source so many feel it is better. Also they are less likely to have viruses and privacy issues. I am not a fan boy of Linux, I have actually never used it and I always recommend Windows, but I never say Linux is bad.
     

    #8
    aroblu94 likes this.
  9. mwayner
    Lollipop Sep 14, 2015

    mwayner , Sep 14, 2015 :
    Gotta check this in a bit. Was using Windows when I first connected the phone. The Oneplus setup ran automatically, so I unlocked and whatnot with Windows. Didn't think there'd be anything special to do for Ubuntu and now I've read two threads with setup info. With the OPO, I just connected and away we went without doing anything special.
     

    #9
    otto2 likes this.
  10. Potti5
    Eclair Oct 10, 2015


    #10
    nirmik379kale likes this.
  11. nirmik379kale
    Gingerbread Oct 12, 2015


    #11
  12. arif-ali
    Froyo Oct 16, 2015


    #12
    nirmik379kale likes this.
  13. nirmik379kale
    Gingerbread Oct 16, 2015

    nirmik379kale , Oct 16, 2015 :
    Glad this helped!
    happy to see all Linux users around! :D;)
     

    #13
    arif-ali likes this.
  14. enea.parimbelli
    Cupcake Oct 19, 2015

    enea.parimbelli , Oct 19, 2015 :
    Works just fine. Thanks a lot :)

    BTW why did you linux-is-not-a-proper-OS guys get a linux-based phone (i.e. android)?
    Better go to mobile version of win then.. or am I wrong? ;)
     

    #14
  15. nirmik379kale
    Gingerbread Oct 19, 2015

    nirmik379kale , Oct 19, 2015 :
    Glad it worked...

    About the PC guys... They are mostly incapable of understanding all this HIGH level stuff... All they know is hitting NEXT :p
    Only we'll know the joy of make and makeinstall :cool:

    P.S : i don't mean all windows users... Just few who make unnecessary comments ;)
     

    #15
    sakivg likes this.
  16. bowlesg
    Eclair Oct 27, 2015

    bowlesg , Oct 27, 2015 :
    [strike]It works! but only partially i still see the Oneplus drivers mounted but there is also an 'Android' however 'Android' has nothing inside it. any help?[/strike]

    EDIT: I was being dumb dumb! :) rebooted linux solved it!
     
    Last edited: Oct 27, 2015

    #16
    m.fencer and nirmik379kale like this.
  17. nirmik379kale
    Gingerbread Oct 29, 2015

    nirmik379kale , Oct 29, 2015 :
    Lol... no issues :p
    happens :D
    restarting udev service would have done the trick too i think!
    anyways, enjoy ;)
     

    #17
  18. bowlesg
    Eclair Oct 29, 2015


    #18
  19. nukeon
    Eclair Oct 30, 2015


    #19
  20. sagar@oneplus
    Cupcake Nov 12, 2015

    sagar@oneplus , Nov 12, 2015 :
    helpfull..!Thanx..!it worked..!i can see my files.
    but..i still cant see my device using command "adb devices"
    i have tried using commands "sudo adb kill-server" and "sudo adb start-server"
     

    #20