1
Device is not certified on Play store

  1. bhatti1014
    Cupcake Feb 12, 2020

    bhatti1014 , Feb 12, 2020 :
    I have done everything i.e. clearing data of playstore, clearing cache...
    Nothing worked!
    I havent rooted my device either and I just install updates from OxygenOS Updater WhatsApp Image 2020-02-12 at 1.50.26 PM.jpeg
     

    #1
    laurenzo87 likes this.
  2. drl431
    Marshmallow Feb 12, 2020

    drl431 , Feb 12, 2020 :
    Do you have a converted OP6T from T-Mobile?
    Also, I notice on my OP6 with 10.3.1 that the version is 18.7.18.
     

    #2
    Kytharsis and Caomhin like this.
  3. bhatti1014
    Cupcake Feb 12, 2020

    bhatti1014 , Feb 12, 2020 :
    I dont think so... Is there any way to check whether my phone is converted or not?
     

    #3
  4. Kytharsis
    Nougat Feb 12, 2020

    Kytharsis , Feb 12, 2020 :
    Did you buy it from the US T-Mobile store?
     

    #4
    drl431 and Caomhin like this.
  5. bhatti1014
    Cupcake Feb 12, 2020

    bhatti1014 , Feb 12, 2020 :
    No... I bought it from Pakistan in used condition
     

    #5
    Caomhin likes this.
  6. Kytharsis
    Nougat Feb 12, 2020

    Kytharsis , Feb 12, 2020 :
    So it's not a converted phone.
     

    #6
    Caomhin likes this.
  7. bhatti1014
    Cupcake Feb 12, 2020

    bhatti1014 , Feb 12, 2020 :
    Then how to counter the problem... Any idea?
    Please help me out
     

    #7
  8. Kytharsis
    Nougat Feb 12, 2020

    Kytharsis , Feb 12, 2020 :
    "Also, I notice on my OP6 with 10.3.1 that the version is 18.7.18.". There was more to his post.
     

    #8
    drl431 likes this.
  9. Liehjan
    Lollipop Feb 12, 2020

    Liehjan , Feb 12, 2020 :
    What oxygen OS version?
     

    #9
  10. bhatti1014
    Cupcake Feb 12, 2020


    #10
  11. Liehjan
    Lollipop Feb 12, 2020

    Liehjan , Feb 12, 2020 :
    Just saw that you had used OxygenUpdater to install software... I don't know from where the app downloads the updates, but the app isn't a official Oneplus app so I never use that app... Might be that you got a update from a region that wasn't meant for Pakistan.
     

    #11
  12. karna23
    Froyo Feb 12, 2020


    #12
    Caomhin likes this.
  13. drl431
    Marshmallow Feb 12, 2020

    drl431 , Feb 12, 2020 :
    Which model is it, A6010 or A6013?
     

    #13
  14. Caomhin
    KitKat Feb 12, 2020

    Caomhin , via OnePlus 6T , Feb 12, 2020 :
    It's still possible that your phone is an imported second hand US TMobile variant. If it is the steps below won't fix it., however try them anyway to see if they relive the issue

    Try the following,

    Clear the App info Cache and App info Storage for all 3 items

    Google Playstore
    Google Play services
    Google Services Framework (Search in Setting for this)

    See if this rectifies the issue.

    You can then try to update your Google Play System Update if there is one available in Settings, Security and Lockscreen


    1581516931279.jpg
     

    #14
    drl431 likes this.
  15. bhatti1014
    Cupcake Feb 18, 2020

    bhatti1014 , Feb 18, 2020 :
    No, this didn't help!
    BTW, my google play system update and security update are same as yours!
     

    #15
  16. bhatti1014
    Cupcake Feb 18, 2020


    #16
  17. narceoneplus2
    Ice Cream Sandwich Feb 18, 2020

    narceoneplus2 , Feb 18, 2020 :
    Even with a locked booloader, this is a well known issue with the T-Mobile variant of the OnePlus 6T (A6013). Supposedly, a quick fix is in the works from OnePlus. But who knows when that will be resolved. We have had that issue since the first OTA update of Android 10 and it continues on. We have no choice but to be patient. If it does not get resolved then I will just root my device.

    You can follow this thread here just in case someone figures out how to resolve it before OnePlus does: https://forum.xda-developers.com/oneplus-6t/how-to/android-10-update-oneplus-6t-t-mobile-t4051003.
     

    #17
    keithnyc likes this.
  18. kjjm
    Froyo Feb 18, 2020

    kjjm , Feb 18, 2020 :
    Go to settings>about phone>status and look at the IMEI numbers (don't post them). Are they the same? If so, you were sold a converted T-Mobile phone. A6013 is the model number for the non-China variant, not just T-Mobile.
     
    Last edited: Feb 18, 2020

    #18
    Caomhin likes this.
  19. bhatti1014
    Cupcake Feb 18, 2020

    bhatti1014 , Feb 18, 2020 :
    No, they are different from the end! last 2 digits
     

    #19
  20. kjjm
    Froyo Feb 18, 2020

    kjjm , Feb 18, 2020 :
    Interesting. So it would seem that you do not have a converted T-mo phone - which is good but doesn't explain or solve your problem. Have you done a full data wipe and factory reset since you bought the phone?
     

    #20
    Caomhin likes this.