6
Device temperature too low

  1. hvq2 Donut Jan 25, 2019

    hvq2, Jan 25, 2019 :
    What do you mean by the battery connector? Is it the connector top right? So what did you do to fix it? Unfortunately I have the same issue...
    [​IMG]
     

    #21
  2. oisingrehan Cupcake Jan 25, 2019

    oisingrehan, Jan 25, 2019 :
    I had the same problem with my plus 5. I suspected either the battery connector had jarred loose, the battery sensor itself was damaged/blown or the mother board was done. I opened it up, took the battery out and re-sat all the ribbon cables and it had still the same problem.

    I replaced the battery with a new one (genuine oneplus batteries are available on ebay, for about $15-$20 - and they come with tooling to open the device.) and it worked for about two days before hitting the same problem. Now I suspected my replacement unbranded dash charger (I lost my original) was causing problems though it had worked fine for over a year. So I replaced the battery again, and again it's fine. It's been two days now using a regular usb-c charger and everything is working still.

    Fingers crossed.
     

    #22
  3. Macjars Cupcake Feb 23, 2019

    Macjars, Feb 23, 2019 :
    There are 3 possible solutions for this issue.
    1: replace battery.
    2: change the ROM for one that changes the Kernel for a version without this temperature protection.
    3: fix or replace the main board.
    To fix the main board you need to check 2 things on it.
    On the left side of the battery conector (under a double sided glue tape foam), there are some SMD.
    The lowest two are related with this problem.
    I fix my board resoldering the one on the right (nearest to the conector).
    Be aware that the SMD is small and when are desoldered, it gets sticked on the double sided glue tape foam.
    In Yellow is the SMD.
    In Green is the location where it should be.
    In Blue is another part that went missing in another user's phone.
     

    Attached Files:


    #23
  4. themiguelxis Cupcake Mar 4, 2019

    themiguelxis, Mar 4, 2019 :
    I had the same problem, battery always on 50% and when in charge the warning of the "temperature device too low, cannot charge". I could only turn it on when it was charging.
    I already send it to the customer service, to repair. Has anyone ever done the same, who knows the price of the repair?
     

    #24
  5. s4mo Cupcake Mar 10, 2019

    s4mo, Mar 10, 2019 :
    Hello, can you please provide some link for the ROM you are talking about ? Thanks
     

    #25
  6. Macjars Cupcake Mar 10, 2019

    Macjars, Mar 10, 2019 :
    Sorry.
    I've just read this information on Reddit or XDA but, since i solve it resoldering the SMD, i didn't save it.
     

    #26
  7. SHWETA.SHENOY.2504 Cupcake Apr 15, 2019

    SHWETA.SHENOY.2504, Apr 15, 2019 :
    I am recently facing the same issue, phone gets off due to low battery and when I try to charge it wont.. pops an error, Device Temperature too Low. since a day i m trying to put it on charge and use it while i m charging. but as soon as i unplug it drains off or gets switched off on it own. Then again it shows the error device temp low and battery is not able to charge when put on for charging please help and the battery is stuck at 50%.


    please help me..!
     

    #27
  8. Macjars Cupcake Apr 16, 2019

    Macjars, Apr 16, 2019 :
    Have you you read the older repls?
     

    #28
  9. F_Tribhuvan_Rawat_kdVf Cupcake Apr 24, 2019

    F_Tribhuvan_Rawat_kdVf, Apr 24, 2019 :
    Dear friend I had the same issue. And the solution is to replace the battery connector. Replace the battery connector and it will start working fine.
     

    #29