11
dirac control service has stopped

  1. qb1+
    Cupcake Dec 16, 2017

    qb1+ , Dec 16, 2017 :
    It's happen to me too, I've been wondering for a long time but find no solution. Hope oneplus dev concern about this issues!
     

    #21
  2. G_Drew_Thomas_mGpl
    Eclair Dec 16, 2017


    #22
  3. V1513279077180
    Donut Dec 22, 2017

    V1513279077180 , Dec 22, 2017 :
    I had the same issue. I reverted to 4.5.0 ( about 8 hours back) and so far, the phone's working like a charm. I will keep you updated if I feel otherwise. I figured this out after 5 days.
     

    #23
    tiga3541 likes this.
  4. lokesh prashar
    Donut Feb 23, 2018


    #24
  5. Deactivated User
    Feb 23, 2018


    #25
  6. kumarharsh8
    Froyo Feb 24, 2018

    kumarharsh8 , Feb 24, 2018 :
    Roll back to any previous Nougat builds via the special build that is available for the roll back of open beta users.
     

    #26
  7. kumarharsh8
    Froyo Feb 24, 2018


    #27
  8. kunal.h222
    KitKat Feb 24, 2018

    kunal.h222 , Feb 24, 2018 :
    clear app data of "dirac control service" n "Dirac" app
     

    #28
  9. tiga3541
    Donut Feb 27, 2018


    #29
    kunal.h222 likes this.
  10. kunal.h222
    KitKat Feb 27, 2018

    kunal.h222 , Feb 27, 2018 :
    have you tried this
     

    #30
  11. nikhiljjoshi
    Donut Mar 2, 2018

    nikhiljjoshi , Mar 2, 2018 :
    Hi Kunal,
    I faced the same issue, reverted back to 4.5.1 and now have no sound at all on the phone. Notifications, media, touch sounds nothing seems to work. I have tried clearing cache and data of the dirac apps multiple times. Any suggestions?
     

    #31
    kunal.h222 likes this.
  12. kunal.h222
    KitKat Mar 2, 2018

    kunal.h222 , Mar 2, 2018 :
    are you getting dirac control service stopped error as mentioned by users above?
    btw why you downgrade?
    also use reply or quote option while replying unless I didn't get notified
     

    #32
  13. mongojarle
    Cupcake Mar 2, 2018

    mongojarle , Mar 2, 2018 :
    Hi.
    I had the same problem as most of you. Dirac control service stopped in the first start, and made it so my setup could not continue. Always wanted to reset to factory settings, taking me to recovery. Everything was stock on the phone, latest stable OOS.
    So, pluged in a headset, and got thorugh the setup. Enabled developer mode, then USB debugging, always allowing my computer. Also enbaled OEM unlocking.
    Then I booted to fastboot and unlocked bootloader, installed TWRP and magisk. After that no problems with Dirac or sound (I had no microphone also before).
    Still on latest stock stable, did not flash rom or factory reset during this. However, unlocking bootloader will completely format the phone (system AND data).
    Don't know what step fixed it for me, as I had the headphones plugged inn the whole time until I was finished. At least I can use the phone again.
     
    Last edited: Mar 2, 2018

    #33
    amandeep 13 likes this.
  14. nikhiljjoshi
    Donut Mar 3, 2018

    nikhiljjoshi , Mar 3, 2018 :
    I read on a similar thread on the forum that the issue could have been due to Oreo. At the moment just about trying anything to get the phone to work! After the downgrade I am not getting the error. But sound doesn't work at all.
     

    #34
    kunal.h222 likes this.
  15. kunal.h222
    KitKat Mar 3, 2018

    kunal.h222 , Mar 3, 2018 :
    you can again go for Oreo then.
    you can clean install
     

    #35
  16. tiga3541
    Donut Mar 3, 2018

    tiga3541 , Mar 3, 2018 :
    Same problem with my OP3T, keeps returning even after factory reset, hard reset, tried everything
     

    #36
  17. nikhiljjoshi
    Donut Mar 3, 2018

    nikhiljjoshi , Mar 3, 2018 :
    I have tried clean Oreo flash, clean nougat flash. Cleared dirac apps data, cleared cache, factory resets. Everything that has been suggested in many threads spread across multiple forums. Nothing seems to work. I finally went to the service center where they said that there is an issue with the motherboard. Replacing a motherboard doesn't really make sense as its just too expensive. I don't think its a problem with the motherboard as many people seem to be having the same issue after the Oreo update.
     

    #37
    kunal.h222 likes this.
  18. kunal.h222
    KitKat Mar 3, 2018

    kunal.h222 , Mar 3, 2018 :
    and what happened when you connect headfones?
     

    #38
  19. nikhiljjoshi
    Donut Mar 3, 2018

    nikhiljjoshi , Mar 3, 2018 :
    nothing. same issue. no sound. everything else seems to work absolutely fine.
     

    #39
    kunal.h222 likes this.
  20. kunal.h222
    KitKat Mar 3, 2018

    kunal.h222 , Mar 3, 2018 :
    you can try to repair it in third party shop if the issue is not with motherboard
     

    #40