11
dirac control service has stopped

  1. EarthSalt
    Cupcake Mar 3, 2018

    EarthSalt , Mar 3, 2018 :
    I've had to factory reset my phone 3 times so far today. it seems to crash every few times there is a phone call.

    A few weeks back (2-3) my phone started slowing down. then last week, audio stopped working sometimes. a few days ago (2-5) people stopped being able to hear me on phone calls. 2 days ago my phone started shutting down for no reason whatsoever and the shutdowns near locked me out of my phone. Today I could hardly use my phone at all and have had to factory reset just to be able to use my phone for about half an hour at a time. while I assume this has something to do with the new oxygen OS, I can't be sure.
     

    #41
  2. Deactivated User
    Mar 3, 2018


    #42
    kunal.h222 likes this.
  3. EarthSalt
    Cupcake Mar 3, 2018

    EarthSalt , Mar 3, 2018 :
    will do!

    I'm not sure if it's an app, though: I've factory reset my phone, clearing all data and apps, and not installed anything. even with that the problem persists (albeit much less frequently).

    my current plan is to slowly go adding in apps (over the course of several days) to see if any of them exasperate the problem.
     

    #43
    kunal.h222 likes this.
  4. mongojarle
    Cupcake Mar 4, 2018

    mongojarle , Mar 4, 2018 :
    I don't think it's an app Martin. I would suggest to try to install another official rom. If you are running oreo beta, try the stable, if you are on oreo stable, try to go back to nougat.
    I have not heard any complains from my girlfriend who is using my OP3 that I fixed the other day, so that may also be something you can try if nothing else works.

    Edit: just had my girlfriend call me from the OP3, and it turns out the phone is not fixed. I could not hear her, and she didn't hear me. I have an OP5, and I know that is working fine.

    Okai, so when I tried to reboot the phone, the Dirac thingy is stopping, eventually sending me to recovery for factory reset again. I can not use the phone at all, as Dirac is stopping right after SIM unlock.
    Downloading custom ROM right now (Pixel experience 8.1.0), will try that and get back here with results.

    Have anyone been in contact with OnePlus about this issue?
     
    Last edited: Mar 4, 2018

    #44
  5. mongojarle
    Cupcake Mar 4, 2018


    #45
  6. lokesh prashar
    Donut Mar 5, 2018


    #46
  7. Angelo_Pasqua
    Cupcake Mar 5, 2018

    Angelo_Pasqua , Mar 5, 2018 :
    I had the same problem with continuous reboots and dirac crashes. I sent the phone in free assistance (it's under warranty) and it came back after 2 days in perfect working order. they replaced my motherboard
     

    #47
  8. mongojarle
    Cupcake Mar 5, 2018

    mongojarle , Mar 5, 2018 :
    I have also applied for a RMA, but I got to send it to a family member in the UK first, as that is where I bought it, and I live in Norway. Oneplus doesn't sell in Norway.
    Did you send it in, or personally handed it over in a store/service center?
     

    #48
  9. tiga3541
    Donut Mar 15, 2018


    #49
  10. tiga3541
    Donut Mar 21, 2018

    tiga3541 , Mar 21, 2018 :
    I HAVE FINALLY SOLVED THIS 100%

    In short:
    Delete Dirac and replace with Viper4Android

    1 Root device
    2 Explore root directory and delete Dirac
    3 Install Viper4Android sound system

    VOILA

    If you need any clarifications please just reply here or email me I'll be most happy to help! :D
    tiga354@gmail.com
     

    #50
    F_Henryk_Małysz_hqlH likes this.
  11. nikhiljjoshi
    Donut Mar 23, 2018

    nikhiljjoshi , Mar 23, 2018 :
    what is the ROM and version you are using?
     

    #51
  12. tiga3541
    Donut Mar 23, 2018

    tiga3541 , Mar 23, 2018 :
    I tried a bunch of ROMS all gave the Dirac error... FInally Oxygen OS 4.5.1 gave me no error (but no sound as well) . So I installed that then was able to complete the dirac replacement.

    I'm still trying to figure out a way to make the dirac replacement in Oreo
     

    #52
  13. elpirry5
    Froyo Apr 5, 2018

    elpirry5 , Apr 5, 2018 :
    I have the same issue, Help Please, the phone does not have sound at all, just the speaker are working the speaker call and mic are not working. This is a headache, I tried installing Viper4 but I could not put in working
     

    #53
  14. G_Finn_Jasper_Scholten_R
    Cupcake Apr 5, 2018


    #54
  15. Vishal Priajapati
    Cupcake Jun 15, 2018


    #55
  16. Vishal Priajapati
    Cupcake Jun 15, 2018

    Vishal Priajapati , Jun 15, 2018 :
    still audio icon showing on scree and not able to listen phone call in earphone
     

    #56
  17. mongojarle
    Cupcake Aug 28, 2018

    mongojarle , Aug 28, 2018 :
    I had my phone for repair because of this. They change the earpiece. I could not test the phone until today, and it turns out that there is no improvement. The phone reboots to recovery once it boots into system. Im tired of this...
     

    #57
  18. K1535125990312 Charliexop
    Froyo Aug 28, 2018


    #58
  19. THIAGARAJAN.S
    Eclair Aug 28, 2018


    #59