1
Disable OTG timeout option - disable

  1. scotthubbard
    Cupcake Nov 24, 2017

    scotthubbard , Nov 24, 2017 :
    Good morning all,

    I took delivery of my 5T yesterday and it is a lovely device, however one of the main uses for my phone is to listen to music via a USB OTG DAC. For some reason this device seems to think this should be permanently disabled, and then set on a 10 minute timeout when i unplug the USB.
    This is VERY, VERY frustrating and the 3T did not do this. Is there a way I can permanently set this to enabled?
     

    #1
    rajkishorch likes this.
  2. G_Adrián_Pérez_Marín_bIC
    Cupcake Nov 24, 2017


    #2
  3. scotthubbard
    Cupcake Nov 24, 2017

    scotthubbard , Nov 24, 2017 :
    That turns OTG on but with a 10 minute timeout, in other words I need to turn this on every time I want to plug my DAC in which is absurd. I want to permanently enable like you used to be able to.
     

    #3
  4. pwils025
    Cupcake Nov 30, 2017

    pwils025 , Nov 30, 2017 :
    @scotthubbard, did you find a solution to this problem? I am puzzled as to why they would limit this feature and my only conclusion is that they did it to conserve battery life.
     

    #4
  5. scotthubbard
    Cupcake Nov 30, 2017

    scotthubbard , Nov 30, 2017 :
    No nothing. I have no idea why they would implement this. In the 3T it was enabled, in the 5 you had to enable it but this was persistent, and in the 5T they have a timeout. It must be causing an issue somewhere but I have no idea where, and it is very annoying!
     

    #5
  6. tb77
    Gingerbread Dec 23, 2017


    #6
  7. scotthubbard
    Cupcake Dec 23, 2017

    scotthubbard , Dec 23, 2017 :
    I have just discovered that there is actually a notification toggle for this which makes it slightly less annoying, however I still don't see why it has to timeout!
     

    #7
    G_Fauzaan_Ahamed likes this.
  8. DodgeTHIS
    Cupcake Mar 19, 2018

    DodgeTHIS , Mar 19, 2018 :
    It's a kernel feature they have changed. I have the same on a op3 on more recent OOS. I installed a 3rd party kernel and this timeout was not present and USB OTG was default enabled. I'm using the toggle as you though as I went back to stock kernel.

    I suppose anyone with kernel config knowledge would know what to do....
     

    #8
  9. Dmalonson
    Donut Dec 28, 2018


    #9
    G_Thamarai_M_Bgwm and pwils025 like this.
  10. G_Thamarai_M_Bgwm
    Cupcake Mar 23, 2020 at 5:18 PM


    #10