1
Display not showing on incoming calls

  1. ngydat
    Lollipop Nov 8, 2018

    ngydat , Nov 8, 2018 :
    Don't pay attention to my previous post :

    Long press on the phone app -> App info -> Storage -> Clear data and cache
     

    #41
    hugo87 and DeepikAki like this.
  2. DeepikAki
    Cupcake Nov 8, 2018


    #42
    ngydat likes this.
  3. ankit17.ag
    Cupcake Nov 20, 2018

    ankit17.ag , Nov 20, 2018 :

    This worked for me.
     

    #43
  4. MEETRAJJADEJ
    Cupcake Nov 24, 2018

    MEETRAJJADEJ , Nov 24, 2018 :
    Go to settings /system/reset option/reset app reference

    Do it
     

    #44
  5. Unleashrevenge
    Cupcake Dec 3, 2018


    #45
  6. hegdesunil
    Cupcake Jan 11, 2019

    hegdesunil , Jan 11, 2019 :
    Hey, this issue showed up on my device for the past few days and your solution worked. Thank you very much.
     

    #46
  7. I1512037984811
    Cupcake Jan 12, 2019

    I1512037984811 , Jan 12, 2019 :
    Seems like a common problem.
    (1) Some have done a factory reset - I did NOT try this.
    (2) Others have had sucess with the solution above -- not me...
    (3) In my case I was using my network provider's calling-over-wifi app (because reception is not perfect everywhere), and I had inadvertently told Android to restrict its notification access too much (because it had an annoying notification when it wasn't being used), and so it did not have access to the screen. {So it was my fault!}

    Mainly, check the notification settings for any App that might receive the call, not just the Phone app itself.
     

    #47
  8. G_M_I_lGnd
    Cupcake Jan 16, 2019

    G_M_I_lGnd , Jan 16, 2019 :
    I followed the steps however under behavior its dithered out... can't select it. See screenshot
     

    Attached Files:


    #48
  9. G_M_I_lGnd
    Cupcake Jan 16, 2019

    G_M_I_lGnd , Jan 16, 2019 :
    I figured it out... it was the phone cover making the phone think its in pocket mode... had to remove the protective plastic cover over the screen to make it work
     

    #49
  10. hugo87
    Donut Mar 9, 2019

    hugo87 , Mar 9, 2019 :
    This worked for me (on Oneplus 5T) in combination with resetting all app settings (settings>system>reset options>reset app preferences). Not sure which of the 2 was the actual solution. Had this issue since new Pie Android upgrade (received incoming calls and vibration but screen stayed black). I did not have the option available as given earlier: "Behaviour -> Select "Make sound and pop up on screen" for me that setting could not be changed (was greyed out). Thanks!
     

    #50
    nharish143 likes this.
  11. kartik.puri95
    Cupcake May 25, 2019


    #51
  12. Avinash_Ch
    Cupcake Jun 2, 2019

    Avinash_Ch , Jun 2, 2019 :
    Could you please tell me how the screen cover related to pocket mode.
    Because I even have the same issue you have faced when trying to change the behaviour.
    And changing that solved your problem? Because i am facing a very rare case in my OnePlus 6T
     

    #52
  13. ayushgupta64
    Donut Jun 19, 2019


    #53
  14. nharish143
    Cupcake Jul 8, 2019

    nharish143 , Jul 8, 2019 :
    the behaviour is greyed out...how do i enable it?
     

    #54
  15. ngydat
    Lollipop Jul 8, 2019

    ngydat , Jul 8, 2019 :
    Long press on the phone app > app info > storage > clear data & cache
     

    #55
  16. yuvananda
    Donut Jul 18, 2019

    yuvananda , Jul 18, 2019 :
    Was facing the exact same issue on my OP 3 after the pie update. During an incoming call, the phone would vibrate / ring but never shows the caller screen. It was as if phone is in idle and if picked up it will show the ambient clock, even if you unlock nothing shows and the phone simply keeps on ringing. And only after a good 10-15 secs it shows the caller screen.
    First tried this and it dint work,
    Long Press on Phone App > App Info > Notifications > Incoming Call > Behavior was 'Pop on screen' but that cannot be modified
    And this worked,
    Long Press on Phone App > App Info > Notifications > Default > Behavior > Make sound and pop up on screen
    This solution also worked on Colleague's OP 7, so safe to say it may very well work on OP 5, OP 6 on Pie as well.
    Hope this helps
     

    #56
  17. Avinash_Ch
    Cupcake Jul 18, 2019

    Avinash_Ch , Jul 18, 2019 :
    Hello Praveen thanks for your solution.
    Actually in my OP 6T i am facing this problem from the month i have purchased it(Around 6 months). So I have tried all the solutions provided here. But none of them are working fine.
    So a week back i have tried the same which you have suggested, after resetting all my app preferences. But i am still facing this issue.
    Here i have noticed one more thing. Whenever the call comes and its not displaying open the phone app and you will see the call details/menu in notification screen.
    For me it looks like OP optimisation part is the reason causing this problem (First thing came in to my mind) .
    Hope you guys check it and put your comments.
     

    #57
  18. shubhankar
    Cupcake Aug 7, 2019

    shubhankar , Aug 7, 2019 :
    None of the above solutions worked for me.
    What worked for me was setting the 'Default Phone App' *** your 'Phone App'.

    After Phone->App Info->Default App option: You will either see a yes or a no. If it's not the default app, set it as default one and it will work. I think it has something to do with preferences on a system level.
     

    #58
  19. Vikram prabha
    Eclair Oct 22, 2019

    Vikram prabha , via OnePlus 6T , Oct 22, 2019 :
    Even I'm facing the same issue. display doesn't show up for 10secs or more and i have to short press the power on off button, and after 5-10secs it shows the caller ID. till then i can hear only the incoming tone.. I'm in a place where there is no OnePlus store too.
    request OnePlus to fix this bug. is frustrating
     

    #59
  20. Vikram prabha
    Eclair Oct 22, 2019

    Vikram prabha , via OnePlus 6T , Oct 22, 2019 :
    i have followed ur procedure. but when i press behaviour button it simply doesn't respond
     

    #60