5
dm-verity error

  1. despeh
    Froyo Jan 1, 2017

    despeh , Jan 1, 2017 :
    After flashing oos4.0 using original recovery, before booting into OS ,flash TWRP,format data and convert to f2fs if encounter the encrypted password for data partition. flash the latest SR1-SuperSU-v2.79.zip which will patched the dm-verity error msg. I have found successful with no more dm-verity problem when boot and rooted successfully.
     

    Attached Files:


    #21
    kapilathi likes this.
  2. genutzu199
    Eclair Jan 1, 2017

    genutzu199 , Jan 1, 2017 :
    Just followed these steps and I still get dm-verity error. It seems that if I flash TWRP, the error appears.
     

    #22
  3. despeh
    Froyo Jan 1, 2017

    despeh , Jan 1, 2017 :
    i agree with you that the TWRP is the caused of dm-verity. however 2.79 has patched it. recommended to perform the full reset of the phone via original recovery, then sideload the oos 4.0 image and continue the rest of the above steps.
     

    #23
  4. genutzu199
    Eclair Jan 1, 2017

    genutzu199 , Jan 1, 2017 :
    Tried again by following these steps (I initially had twrp-3.0.2-1.28-oneplus3 installed):

    1. booted to TWRP recovery;
    2. copied recovery_OBT8N.img to phone;
    3. installed stock recovery_OBT8N.img via TWRP as image > recovery;
    4. booted to stock recovery (directly from TWRP);
    5. while in stock recovery, I have wiped the phone (for a clean flash);
    6. installed OxygenOS 4.0 (N) via ADB;
    7. once the installation got completed, I rebooted the phone;
    8. once the phone started, I did not finished the startup setting;
    9. switched-off the phone and booted in fastboot mode;
    10. flashed TWRP recovery - twrp-3.0.2-1.28-oneplus3 again;
    11. switched off the phone;
    12. started the phone in TWRP recovery; TWRP asks for a password to decrypt - ignore it;
    13. wiped the phone (I wanted to do so to make sure it is a really clean install, even if this wipes everything);
    14. rebooted again to TWRP recovery; this time I did not get any password prompt;
    15. from TWRP, I copied SR1-SuperSU-v2.79-SR1-20161221223537.zip to phone storage (while connected to my laptop, obviously);
    16. installed SR1-SuperSU-v2.79-SR1-20161221223537.zip, wiped data & cache and rebooted system;
    17. everything went fine, with no dm-verity and rooted. :)
     

    #24
    maxflo, ZiViky, Johannes1098 and 3 others like this.
  5. Prowhiz
    Honeycomb Jan 2, 2017

    Prowhiz , Jan 2, 2017 :
    How did you root and retain stock recovery? or did you flash back the stock recovery after rooting with twrp?
     

    #25
  6. Zh_kilat
    Android Q Jan 2, 2017

    Zh_kilat , Jan 2, 2017 :
    boot (do not flash) twrp.img from fastboot ..... adb sideload SuperSUname.zip ...... boot ..... you got your phone with root and stock recovery
     
    Last edited: Jan 5, 2017

    #26
    Prowhiz likes this.
  7. Prowhiz
    Honeycomb Jan 2, 2017

    Prowhiz , Jan 2, 2017 :
    Does it work with the latest stable nougat update?
     

    #27
  8. Zh_kilat
    Android Q Jan 2, 2017

    Zh_kilat , Jan 2, 2017 :
    yup .....
     

    #28
  9. Anonymous B-)
    Gingerbread Jan 2, 2017

  10. dhakedrkd
    Froyo Jan 2, 2017

    dhakedrkd , Jan 2, 2017 :
    pls help my contact is not working not import after update andorid n through vpn in india
     

    #30
  11. Ahryos
    Froyo Jan 2, 2017

    Ahryos , Jan 2, 2017 :
    Do you have to wipe internal storage?
     

    #31
  12. genutzu199
    Eclair Jan 2, 2017

    genutzu199 , Jan 2, 2017 :
    Yes, if you want to remove TWRP password prompt. Basically, removing the password means removing the storage encryption. I assume it works without wipe but TWRP will ask for a password, even if you can ignore it. You can test by yourself and see. I intended to wipe the internal storage anyway.
     

    #32
  13. hAMMERlized
    Cupcake Jan 2, 2017

    hAMMERlized , Jan 2, 2017 :
    hi,

    i have the same issue with the oneplus 3t. i will give your steps a try, just replacing it with the 3t recovery.img. but, what if you are flashing another rom? for example the nougat betas or a former oxygen version? not sure but do i have to delete the fingerprint option and change setting back to password before booting into recovery and flash a new rom? to prevent the "encrypt unsuccessful" error. hope you know what i mean.

    thanks in advance
     

    #33
  14. Fehritail
    Froyo Jan 2, 2017


    #34
  15. genutzu199
    Eclair Jan 2, 2017

    genutzu199 , Jan 2, 2017 :
    I know what you mean. I kept my password and fingerprint data and still ended with the result previously posted; but I have made a clean flash so everything got wiped anyway. As a fact, everytime I tried to change the partition to F2FS, I ended with the error. By default, one of data or system partition (don't remember exactly which one) is F2FS but, in my stupidity, I have tried to change the file system for data and system partition. There is no need to do that.
    If flashing another ROM, I guess you'll need to start from a point/ROM where there is no dm-verify error. I guess you're going to make a clean flash of a new ROM and this wipes fingerprint data. I recommend a clean Nougat flash. It takes some time to restore everything but it worths.
     
    Last edited: Jan 2, 2017

    #35
  16. hAMMERlized
    Cupcake Jan 2, 2017

    hAMMERlized , Jan 2, 2017 :
    hmm, device is not recognized while i am in stock recovery. so i can't do adb sideload etc. :/ usb debugging is turned on
     

    #36
  17. shatadrusp
    Honeycomb Jan 3, 2017

    shatadrusp , Jan 3, 2017 :
    Well, I haven't tested that myself but it should work most likely as it worked well with beta 10.
     

    #37
  18. Fehritail
    Froyo Jan 3, 2017

    Fehritail , Jan 3, 2017 :
    I tested it, it did work.
     

    #38
    shatadrusp likes this.
  19. genutzu199
    Eclair Jan 3, 2017

    genutzu199 , Jan 3, 2017 :
    Make sure the drivers are properly installed on your computer. A restart is needed after driver install. You can use adb-setup-1.4.3. Or check on XDA.
     

    #39
  20. hAMMERlized
    Cupcake Jan 3, 2017

    hAMMERlized , Jan 3, 2017 :
    After hours of searching, trying, wiping, flashing and so on....i've finally found a solution for this god damn issue bothering me, thanks to xda forums. Did not thought this would be that simple.

    So for anybody who is interested, these are the steps that helped me out:

    1. Flash official nougat using TWRP (i am using 3.0.2.0), which make the issue appear
    2. This should replace the TWRP with the stock recovery
    3. Before booting into OS, reflash TWRP with adb sideload
    4. Boot into recovery
    5. Flash OxygenOS 3.5.4 firmware https://forum.xda-developers.com/oneplus-3t/how-to/zip-flashable-firmware-modem-t3509015
    6. Wipe dalvik cache and cache
    7. Reboot and profit

    Sidenote: If you are facing any wifi issues (disconnecting / connecting from time to time) with OxygenOS 4.0, like i did, flash the OxygenOS 3.5.4 radio (use link above). This solved it for me as well.
     

    #40