3
[Submitted] Do Not Disturb is turning itself off

  1. Tajgeer
    Cupcake Oct 25, 2019

    Tajgeer , Oct 25, 2019 :
    Running latest OOS: 10.0.3.
    1. Create new DND rule with checkbox allowing alarm to disable DND ticked.
    2. Set alarm.
    3. Check for DND presence after 10 minutes.
     

    #1
    Gepstra, Jolly and Leon Shmulevich like this.
  2. Leon Shmulevich
    Cupcake Dec 4, 2019

    Leon Shmulevich , Dec 4, 2019 :
    Same here, OnePlus 7T, build 10.0.6.
    If I go to dnd settings and edit the rule,
    just changing something with the time e.g., it re-enables DND mode back on. But after several minutes of not touching the phone, it goes off again.
    I suspect perhaps some battery optimization feature kills the service responsible for DND, but could not find anything in the settings of battery optimization.
    Very frustrating issue.
     

    #2
  3. alexbicapopii
    Cupcake Mar 18, 2021

    alexbicapopii , Mar 18, 2021 :
    Same problem on my device (OnePlus 7 Pro, GM1910, Oxygen OS 10.3.8.GM21AA) that started happening only after the last software update.

    I use the DND every night, with the following settings:
    - Manual DND;
    - Automatically turn on: Schedules - Never (off);
    - Exceptions: Calls - allow from starred contacts and repeat callers; SMS, MMS and messaging apps - Don't allow any messages; See all exceptions: Allow alarms, Play media sounds switched to on, the rest switched to off;
    - Behaviour: Restrict notifications - No visuals or sound from notifications; Default duration - Until you turn off.

    I do not have any app set to override the DND.

    What can I do to solve this?
     

    #3
  4. Jolly
    Cupcake Sep 28, 2021

    Jolly , via OnePlus 8T , Sep 28, 2021 :
    Same here... Mine is turning on at 23.30, and I figured out that if I don't use the phone from 23.30 to 00.00, it will turn off, otherwise will keep activate... For a while. Last night at 5 a.m. my phone ringed 'cause the DND was deactivated.
    For now, i will activate it for myself, but it's ridiculous.
    Furthermore, my bt keeps deactivating during overnight, and the problem seems to be the night battery optimization, that I turned off today... Maybe it's that for the DND too? I will test it this night.
     
    Last edited: Sep 28, 2021

    #4
  5. Gepstra
    Gingerbread Jan 13, 2022

    Gepstra , Jan 13, 2022 :
    Why does this still happen OnePlus?

    My 6T didn't have a problem on Android 11, my new 8T does this shit since the beginning...
     

    #5
    Jolly likes this.
  6. Jolly
    Cupcake Jan 17, 2022


    #6