24
Download and Install OnePlus 3 USB Drivers & ADB / Fastboot Drivers

  1. Vatu
    Honeycomb Jun 17, 2016


    #1
  2. Jim Driskill
    Eclair Jun 19, 2016

    Jim Driskill , Jun 19, 2016 :
    Vatu: - I installed your driver set to my Windows 7 Pro OS, but still can't get my OP3 to be recognized by Windows. Any suggestions?
     

    #2
    Umakantha S, abhsatvat and vukicivan like this.
  3. drebux
    Cupcake Jun 23, 2016

    drebux , Jun 23, 2016 :
    Yeah I can't get my OP3 to connect to any computer, Windows or Mac, and I've installed every driver known to man. My OPO and OP2 worked fine.
     

    #3
  4. F_Jignesh_Goyani_Bdot
    Cupcake Jun 24, 2016


    #4
  5. obakesan
    Ice Cream Sandwich Jun 24, 2016

    obakesan , Jun 24, 2016 :
    Have you checked the USB options. The default looks like "charging" so presumably no file transfer. Swipe down the notification shade, select USB options and change to transfer. I've used the OP3 on both Mac and Windows fine.
     

    #5
    sanskidoo, helene85 and t.dide like this.
  6. obakesan
    Ice Cream Sandwich Jun 24, 2016

    obakesan , Jun 24, 2016 :
    PSA The drivers (for Windows on on the device, so no need to download from whereever)

    1) Plug Phone
    2) Change USB to File Transfer
    3) Install Drivers
    4) Transfer......
    5) Done.
     

    #6
  7. Lancelot_69
    Lollipop Jun 24, 2016

    Lancelot_69 , Jun 24, 2016 :
    When you connect to pc/Mac an icon should appear on your device's in the top left hand corner where other notifications come. Drag that icon down, select transfer files. Make sure you have usb debugging in developer options open
     

    #7
    pa5t1s likes this.
  8. t.dide
    Cupcake Jun 24, 2016

    t.dide , Jun 24, 2016 :
    thanks mate, that was it...
     

    #8
    obakesan likes this.
  9. androidForever9864
    Honeycomb Jun 26, 2016

    androidForever9864 , Jun 26, 2016 :
    The OP3 was directly recognized as USB device for file exchange etc. by my windows pc. But it was not recognized as Android ADB device.

    Then I downloaded the OP driver (which incl. OP3) from here
    http://www.teamandroid.com/download-android-usb-drivers/
    but my anti-virus software says NO to this download file, it is containing a known virus pattern.

    Then I connected my OP3 with the PC again, ignored all popups and opened the displayed unrecognized android usb device in the device manager. I go forward for updating the driver, and selected to search in my computer, and after some points was able to select already existing driver for android adb interface. Here I choose the newest drive I found for Samsung devices that I once installed. If finished successfull and the OP3 was recogized and adb device and adb logcat shows the information.
     

    #9
  10. pathologo
    Froyo Jun 29, 2016

    pathologo , Jun 29, 2016 :
    The ADB driver for Windows 7 x64 is definitely NOT working ot there is none delivered at all. The extracted driver files - which you backup and use it for manual installation via device manager if you know where to look - are definitely NOT compatible with Windows 7 x64 and Windows won't find any compatible driver in the folder for the Android device with the Hardware Id:
    USB\VID_05C6&PID_900E&REV_0318
    This is definitely a corrupt driver.

    These are the only extracted driver files:
    amd64\WdfCoInstaller01009.dll
    amd64\WinUSBCoInstaller2.dll
    androidwinusba64.cat
    oneplus_android_winusb.inf

    Also this driver is unsigned and thus will put Windows into Test Mode.
     
    Last edited: Jun 29, 2016

    #10
  11. CarlosOnline
    Cupcake Jul 3, 2016


    #11
    paucoma likes this.
  12. pa5t1s
    Marshmallow Jul 3, 2016

    pa5t1s , Jul 3, 2016 :
    Under Windows (7, 8.x or 10), when you plug your phone in USB slot, a new drive (CD) is mounted: all drivers are there, just use them and install.
    Of course, on your phone, you need to choose the 'MTP' option instead of the 'Charge' option in the top pull-down bar.
    After that done, your phone will appear as a device (not a drive) like "A3003" or whatever...
     

    #12
  13. thealternatives
    Cupcake Jul 4, 2016

    thealternatives , Jul 4, 2016 :
    When I plug in my OP3 i dont get the USB options in the notification bar so I can't select MTP instead of charge. I activated developer mode and switched it on there and still no dice. I installed all the drivers the first time I plugged my OP3 in and ever since then I can't seem to get it to do anything other than charge. I'm running Windows 7 x64
     

    #13
  14. swimman
    Cupcake Jul 20, 2016

    swimman , Jul 20, 2016 :
    Hi to all. The same thing for my Win7-64. Even in device manager - nothing. Only charging. Use Oxygen 3.2.1. In developer mode choose any modes for usb - nothing.. Any ideas?
     

    #14
  15. Salty Wagyu
    Froyo Jul 20, 2016

    Salty Wagyu , Jul 20, 2016 :
    Try a different USB port if MTP isn't working under Windows 7 x64, I had to do that once. After the driver automatically installs then you should be able to connect it back to the USB port you prefer.
     

    #15
  16. swimman
    Cupcake Jul 21, 2016

    swimman , Jul 21, 2016 :
    What do you mean - "driver automatically installs"? Windows finds driver but itself?
    Try your advice even on another laptop with Win7 - every port - nothing... Wait about 3 minutes on each.. Maybe I need to reset it to factory defaults?

    Changes of usb-mode only accepts if I turn off/on developer mode...
     

    #16
  17. JV44Rall
    Cupcake Aug 6, 2016

    JV44Rall , Aug 6, 2016 :
    Me too!

    For we non-experten, the full path is "Settings," "Developer options," scroll down to "Networking," open "Select USB Configuration" and change it from "Charging." I selected "MTP" and it seems to work fine.
     

    #17
  18. kleveille
    Donut Aug 8, 2016

    kleveille , Aug 8, 2016 :
    I've been having an issue with OxygenOS 3.2.2 where the hotspot feature is no longer working since I updated last week. My kids can connect their devices to my hotspot but are not able to get internet access. I've worked with my carrier (MTS in Manitoba, Canada) but all the APN settings were fine so I'm trying a downgrade to OxygenOS 3.2.1 to see if it resolves the issue.

    When I connected the phone to my Windows 10 PC (Dell XPS desktop) Windows would see a device attach, disconnect, attach, etc. over and over without resolution.

    I switched the phone USB connection settings to "File Transfer", disconnected the USB cable & reconnected but no difference.

    I moved the USB cable from the USB 2 ports (black colour) on the top to one of the USB 3 ports (blue colour) on the front and it connected successfully. The CD-ROM with the OnePlus 3 drivers showed up in Windows explorer & I was able to install the drivers.

    I then flashed 3.2.1 onto my phone following the steps for ADB sideloading from OnePlus website:

    Instructions:
    http://downloads.oneplus.net/oneplus-3/oneplus_3_oxygenos_3.2.1/

    ROM Downloads:
    http://downloads.oneplus.net/devices/oneplus-3/

    The hotspot feature works again after flashing version 3.2.1.
     

    #18
  19. 888leoj
    Cupcake Sep 6, 2016

    888leoj , Sep 6, 2016 :
    the problem with the drivers not installing correctly seems to be (atleast on windows 8,10 not sure about windows 7 but i presume it´s the same on there) is that windows will mormally block any unsigned drivers from being installed. what you need to do to stop windows from blocking the installation of the oneplus usb drivers is.

    1. in the start menu go to the restart button and before you press the button you hold down shift. then you will get an options menu pop up after a little while. choose troubleshoot and advanced boot options. the computer will then proceed to restart and you'll get another menu in which you get an number of different options. press 7 on your keyboard and it should boot up without the windows drivers blocking thing.
    2. download or use the drivers that you should see after plugging in the device to the computer and during the process you should this time get an pop up saying do you wish to allow this driver to be installed. just press yes and it should be installed and your phone should be fully working. you may need to restart as well.
     

    #19
  20. G_Matt_Gauthier_aPRc
    Cupcake Sep 16, 2016


    #20