1
Download pending - Can't download apps on playstore

  1. Random Indian
    Gingerbread Nov 23, 2017

    Random Indian , Nov 23, 2017 :
    Always shows download pending for any app on playstore. On both wifi and mobile data.

    Battery saver and data saver are turned off.

    Cleared playstore and play store services apps caches. Rebooted a couple of times.

    Not sure what else is to be tried
     

    #1
    Mustasim likes this.
  2. imattv4
    Ice Cream Sandwich Nov 23, 2017

    imattv4 , Nov 23, 2017 :
    Update Play Services (Try from the PlayStore, if not, download and install manually)

    Then restart the phone and you will be good to go.
     

    #2
  3. Lancelot_69
    Lollipop Nov 23, 2017

    Lancelot_69 , Nov 23, 2017 :
    Go to settings - google play services - manage data - delete data and cache then reboot your phone.
     

    #3
    H1556072876181 likes this.
  4. Lancelot_69
    Lollipop Nov 23, 2017

    Lancelot_69 , Nov 23, 2017 :
    Go to settings - google play services - manage data - delete data and cache then reboot your phone.
     

    #4
  5. zAcard0312
    Cupcake Jan 4, 2018

    zAcard0312 , Jan 4, 2018 :
    If you have another store app other than playstore like apkpure etc. downloaded to your cp, Uninstall it.. i dont know why but it works for me..
     

    #5
  6. MatthiasDL
    Eclair May 24, 2018

    MatthiasDL , May 24, 2018 :
    Hi there,

    I got the same problem over here with my OnePlus 6.
    I searched the web and tried lots of things and finally found a quite simple solution:

    Go to settings > apps > 'application list' > press the three dots on the upper right corner of the screen > reset app preferences > reset apps.

    I really hope this will help for you as well, please leave a like when it did.

    And remember,
    NEVER SETTLE !
     

    #6
  7. ankur500
    Cupcake May 30, 2018

    ankur500 , May 30, 2018 :
    I have resolved this issue on OP6 yesterday by disabling Google Movies and Google Music apps from playstore followed by reboot. Hope it works for others too.
     

    #7
    Anish_Mandalika likes this.
  8. G_Viru
    Jelly Bean Aug 16, 2018


    #8
  9. Ohav
    Cupcake Aug 17, 2018


    #9
  10. nomorebreaka
    Cupcake Sep 8, 2018

    nomorebreaka , Sep 8, 2018 :
    Thanks a lot !!
    This also works for my OnePlus6!
    One more thing, if it still fail, restart the phone after all this step! Good luck!
     

    #10
    saurabhcfp likes this.
  11. Classfellows
    Eclair Sep 9, 2018

    Classfellows , Sep 9, 2018 :
    perfect, worked for me.
     

    #11
    Bruno Brazão and abdullaamori like this.
  12. Abide83
    Cupcake Sep 28, 2018

    Abide83 , Sep 28, 2018 :
    Hi everyone,

    My OnePlus 6 would download apps from playstore very very slowly and then it does not install it.
    Can someone help?
    I have a very very fast internet and it started as soon as I upgraded to the Android 9 (stable version, never installed the DPs or Betas).
    I need help here.

    Thanks.
     

    #12
  13. Classfellows
    Eclair Sep 28, 2018

    Classfellows , Sep 28, 2018 :
    if you have installed Aptoide or apkpure remove that it will start working immediately.
     

    #13
  14. abdullaamori
    Gingerbread Oct 1, 2018

    abdullaamori , Oct 1, 2018 :
    It works using your suggestion. Thanks a lot man . I was going crazy about this error
     

    #14
  15. leogt
    Cupcake Oct 3, 2018

    leogt , Oct 3, 2018 :
    I'm having the same issue. I do not have any third party app stores like apkpure. I've restarted several times. It will install the one app that downloaded and got "stuck" but then will download but not install the next app in the cue. Help please! I've cleared the play services cache too.
     

    #15
    R1569917436435 likes this.
  16. Classfellows
    Eclair Oct 3, 2018

    Classfellows , Oct 3, 2018 :
    try using app cloner premium from AC market, try to clone an app if it works then after that you can start using the Play store it will working fine.
     

    #16
  17. Abide83
    Cupcake Oct 5, 2018

    Abide83 , Oct 5, 2018 :
    I do not have apkpure on all my devices. I however have Aptoide on another device (NOT on my OP6), with same gmail account and therefore with same playstore login details. Could that be the reason?
     

    #17
  18. C1539896659044
    Cupcake Oct 19, 2018

    C1539896659044 , Oct 19, 2018 :
    Same issue on my OnePlus 6. Already tried all the above methods without success.

    I have other issues with my phone though as it is seen as "uncertified" from Google Play. Can't use Google Pay for that reason as well.
     

    #18
  19. Abide83
    Cupcake Oct 19, 2018

    Abide83 , Oct 19, 2018 :
    Are you still running the DP version? I believe running that version makes your device "uncertified" in Google play.

    Well, in my case I was and still running the OTA of Android Pie.
    To solve my issue, after everything didn't work, I uninstalled a big (storage wise) game that was also waiting for update.
    I took that decision when I realized, update would download ONLY 68.1 MB and no more than that. I also paused all downloads.
    Step by Step
    1. Uninstall a big app on my phone waiting for update.
    2. Stop (cancel) all update downloads.
    3. Turn off the wifi (so that auto update and downloads will stop. I've my settings such that, there is auto updates on wifi not on mobile data.)
    4. Restart phone.
    5. Go to Google play store and MANUALLY, select apps with smaller size updates to update first. Repeat for all other apps. NB, you may turn on wifi at this time if you must.
    6. Updates and installations worked, after this. So, I restart the phone again and then went to download that big app, again.

    That is how I solved my case, not even the "expert" could help me in this case.
    If you choose to try it, let me know how that pan out, please.

    Good luck.
     

    #19
  20. N1539507688887
    Cupcake Nov 1, 2018

    N1539507688887 , Nov 1, 2018 :
    Thanks a ton mate! It worked
     

    #20