DTMF not working with IVR

Thread Status:
Not open for further replies.
  1. hreidt Eclair Sep 7, 2017

    hreidt, Sep 7, 2017 :
    My voicemail system needs pin verification when I connect from abroad.
    But IVR does not receive DTMF tones. Dialpad tones switched off and on.
    Happened in Thailand and in France (but not limited to these countries of course).
    Solution is to disable 3G and 4G (thus you get 2G).
    Also happens on other devices
    Go to Settings - SIM & network settings - Preferred network type - Select 2G only
    No issue on Oneplus One, but of course that is CM and not OxygenOS

    SukruDemirelOP3T likes this.
  2. SukruDemirelOP3T Cupcake Sep 7, 2017

    SukruDemirelOP3T, Sep 7, 2017 :
    I had the exact same thing, on holiday. I could net get through a call center because the dailtone was not recognised by the callcenter computer. I searched for the option on Oxygen-Os to change the DTMF settings to long dialtone, but i could not find the setting. AnyOne else with the same problem?

  3. Bob Ong Honeycomb Sep 13, 2017

    Bob Ong, Sep 13, 2017 :
    Hello hreidt,

    This is from the OnePlus Bug Hunters.

    This thread will be marked as "Unable to reproduce" and will be closed due to lack on information.

    Please initiate a new bug report once the issue is replicated so that we can immediately review into it.

    Thank you and have a great one

    Kind regards,

    OnePlus Bug Hunters