0
Sound Earphone nasty bug (partially solved)

  1. sergiopi
    Cupcake Feb 14, 2018

    sergiopi , Feb 14, 2018 :
    5T, Oreo, brand new. With earphones plugged in (Bose, android version with mic) answering a call I can't talk. Pushing the button the call is answered but the MIC is disconnected. Partially solved because I tried to disconnect the AUDIO from my Samsung gear frontier 3 watch, connected also as mic and speaker and... miracle, now the mic earphone mic is working . Some nasty config error, may be the MIC, even if I am answering with button, is routed to BT

    I can confirm other bug described on earphone use: the button can't start/stop track, neither double click to go to the next track is working, nor click to play a track. Only long press "OK Google" works!.

    P.S. I am a retired XDA senior moderator, before posting the bug I've tested the bug with many other earphones (I have the Samsung, Huawei, LG earphones) the BOSE earphones are working with my old Oneplus one, tested on Oneplus 3, cleared cache, restarted the phone.
     

    #1