0
EFS Lost?

  1. dmo
    Ice Cream Sandwich Sep 14, 2014

    dmo , Sep 14, 2014 :
    What I did wrong:
    • Didn't backup EFS obviously (figured it wouldn't be an issue having owned 2 Samsung phones, as long as you're not doing anything crazy)
    • I backed up my 0913 nightly on TWRP and installed an older nightly to try to diagnose a CM bug. When I restored the 0913 nightly (I'm guessing restoring the modem part was the troublemaker), it came back with no IMEI, no connectivity, etc.
    I checked the root folder of the phone and there's no EFS folder.

    Am I screwed?

    1. I tried to follow this thread on XDA to flash ColorOS, but no dice. The phone boots, but still no IMEI. No EFS folder is rebuilt
    2. Also tried what someone suggested with flashing a 33R Rooted ROM including the radio. No go.
    My Nexus 5 is out on RMA (woohoo), so I have activated the SGS2 for now. Ugh.
     

    #1
  2. dmo
    Ice Cream Sandwich Sep 15, 2014


    #2
  3. Parinya-f
    Honeycomb Sep 15, 2014

    Parinya-f , Sep 15, 2014 :
    Your are in deep sh... I suppose.

    I had once screwed up my Sammy Galaxy S the same way while flashing custom ROM. Anyhow SS reset IMEI to its default value and fortunately the phone still worked.

    Later I sent the phone to a repair shop to have original IMEI written back to my phone. Special equipment and software are required to do that.
     

    #3
  4. Parinya-f
    Honeycomb Sep 15, 2014

    Parinya-f , Sep 15, 2014 :
    Ask those experts at XDA Developers or CyanogenMod. Hope you can find the solution soon.
     

    #4
  5. murathai
    Gingerbread Sep 15, 2014

    murathai , Sep 15, 2014 :
    It can be fixed with qpst but location of imei number in nvram is unknown. Only oneplus support can help you.
     

    #5
  6. Ram1111
    Donut Sep 15, 2014


    #6
  7. aspherical
    Jelly Bean Sep 16, 2014


    #7
  8. Elrey311
    Ice Cream Sandwich Sep 16, 2014

    Elrey311 , Sep 16, 2014 :
    I lost my IMEI# also and I fixed it with your first suggestion, but it didn't work the first time I did it. The time it did work I made sure I had my SIM card in the phone. I don't know if that was the reason or not. I also erased the modemst1 and modemst2, because my was just rebooting constantly and would not connect to wifi. I followed that thread step by step and it worked for me.
     

    #8
  9. Ramiro16
    Honeycomb Sep 16, 2014

    Ramiro16 , Sep 16, 2014 :
    Always i mean always make a backup of your EFS file thats the first thing to backup :)
     

    #9
  10. dmo
    Ice Cream Sandwich Sep 16, 2014

    dmo , Sep 16, 2014 :
    Update 9/15:

    I flashed Unofficial TWRP 2.7.0.1 and performed a restore of the TWRP backup. It seems that WiFi and Bluetooth can work. Bluetooth and WiFi Mac addresses show. However, IMEI is still empty.

    When I reboot its gone.

    So I've gotten closer, but no mobile connectivity yet.

    I'm not sure whats missing!!! Agh.
     

    #10
  11. nikku_hot123
    Honeycomb Sep 30, 2014

    nikku_hot123 , Sep 30, 2014 :
    me facing the same problem :(

    I had original ROM backup and tried to restore it with TWRP 2.8.0.1 but after restoration the phone booted up without mobile network,IMEI, WIFI and baseband, I read it's TWRP Problem of not restoring
    efs properly. I tried flashing the official CM11s 33R but again failed to get network and moreover it deleted all the data on my mobile including the nandroid backup [​IMG]. I tried restoring the efs.img which i
    backed up with manudroid toolkit but still no luck. manudroid toolkit it backing up /dev/block/mmcblk0p15 which i guess is the wrong partition to back up.
    I tried the method of flashing up official ColorOS but again failed, Then i came to this thread and successfully completed all the steps but still my phone is nothing more than a Paperweight. [​IMG]
     

    #11
  12. alteredgene
    Cupcake Jan 7, 2015

    alteredgene , Jan 7, 2015 :
    I have just purchased the phone from **********.

    and when i turned on the phone, found out that its missing IMEI number (showing unknown).

    oddly, i don't think the phone was tampered with, it had the screen sticker on and all that.

    is this possible?

    it was missing IMEI number to begin with, so i didn't have a chance to back it up either.

    i was wondering if this is fixable?
     

    #12